1.4.2 or 5.0

Discussion in 'Java' started by frank, Jun 28, 2005.

  1. frank

    frank Guest

    trying to figure out as I've heard a couple of stories here. Is Java
    1.4.2 the current version that you would term production release and 5.0
    is still like a beta (of course it works etc. but recommended for
    critical systems yet)? Even Sun's web site say's 1.4.2 is the current
    lease and to upgrade to it.


    Thanks,

    Frank
     
    frank, Jun 28, 2005
    #1
    1. Advertising

  2. frank

    . Guest

    On Tue, 28 Jun 2005, frank wrote:

    > trying to figure out as I've heard a couple of stories here. Is Java
    > 1.4.2 the current version that you would term production release and 5.0
    > is still like a beta (of course it works etc. but recommended for
    > critical systems yet)? Even Sun's web site say's 1.4.2 is the current
    > lease and to upgrade to it.


    Depends who you talk to. For example, WebLogic 8.1.4 usually ships with
    1.4.2 and WebLogic 9.0 will ship with 5.0. Since 9.0 is still beta you
    would want to go with WebLogic 8.1.4 and JDK 1.4.2. Additionally,
    WebSphere 6.0.1 is shipping with 1.4.2 as well.

    However, if you are using something that does not ship with a JDK/JRE then
    you are free to use whatever you want. JBoss 4.0.1 and Tomcat 5.5.9 for
    example might be used with JDK 5.0.

    Generally speaking, the big boys are still using 1.4.2 but 5.0 has been
    out there for a while and is definitely beyond beta. JDK 6.0 (or 1.6 or
    Java SE 6) is prerelease already. That is what you want to avoid if you
    want stable.

    --
    Send e-mail to: darrell dot grainger at utoronto dot ca
     
    ., Jun 28, 2005
    #2
    1. Advertising

  3. frank

    Roedy Green Guest

    On Tue, 28 Jun 2005 10:18:07 -0400, frank <> wrote
    or quoted :

    >trying to figure out as I've heard a couple of stories here. Is Java
    >1.4.2 the current version that you would term production release and 5.0
    >is still like a beta (of course it works etc. but recommended for
    >critical systems yet)? Even Sun's web site say's 1.4.2 is the current
    >lease and to upgrade to it.


    The reason I am holding back is when you use 1.5, people without 1.5
    will not run your code, and they will get some totally inscrutable
    behaviour, not something simple like an error message saying, "please
    upgrade java 1.5 at this URL to run this program.

    Even on my own machine sometimes Mozilla likes to use 1.4 and code
    stops working even when compiled with -source 1.4 and -target 1.4.

    However the new language features are SO juicy. I keep wanting to
    rewrite old perfectly working code just because enums would be so
    slick.

    --
    Bush crime family lost/embezzled $3 trillion from Pentagon.
    Complicit Bush-friendly media keeps mum. Rumsfeld confesses on video.
    http://www.infowars.com/articles/us/mckinney_grills_rumsfeld.htm

    Canadian Mind Products, Roedy Green.
    See http://mindprod.com/iraq.html photos of Bush's war crimes
     
    Roedy Green, Jun 28, 2005
    #3
  4. Roedy Green wrote:
    > On Tue, 28 Jun 2005 10:18:07 -0400, frank <> wrote
    > or quoted :
    >
    >
    >>trying to figure out as I've heard a couple of stories here. Is Java
    >>1.4.2 the current version that you would term production release and 5.0
    >>is still like a beta (of course it works etc. but recommended for
    >>critical systems yet)? Even Sun's web site say's 1.4.2 is the current
    >>lease and to upgrade to it.

    >
    >
    > The reason I am holding back is when you use 1.5, people without 1.5
    > will not run your code, and they will get some totally inscrutable
    > behaviour, not something simple like an error message saying, "please
    > upgrade java 1.5 at this URL to run this program.
    >
    > Even on my own machine sometimes Mozilla likes to use 1.4 and code
    > stops working even when compiled with -source 1.4 and -target 1.4.
    >
    > However the new language features are SO juicy. I keep wanting to
    > rewrite old perfectly working code just because enums would be so
    > slick.
    >

    The J2EE standard version 1.4 relies on J2SE1.4. So if you are
    interested in J2EE1.4 compatibility, use j2sdk1.4.2_08, otherwise use
    jdk5.0.

    --

    --ukriegel
    ---------------------------------------------------------------------
    Dr. E.Ulrich Kriegel, ,
    Fraunhofer ISST, Mollstra├če 1, D-10178 Berlin, Germany
    tel: (++49(0)30) 243 06 446 fax: (++49 (0) 30) 24306 199.
    The PKI root certificate of the Fraunhofer Society can be obtained
    from http://pki.fraunhofer.de
    =====================================================================
     
    E. Ulrich Kriegel, Jun 29, 2005
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.

Share This Page