401.2 (Access Denied) Error When Moving Asp.Net to Production

Discussion in 'ASP .Net' started by ElGordo, May 10, 2005.

  1. ElGordo

    ElGordo Guest

    In our dev environment, our ASP.Net application works fine and outside users
    can access it when provided with the proper URL.

    Once we moved the application to our public server, we now get a 401.2
    error. A windows login prompt occurs once the URL is accessed in the
    browser and nobody can log in (no login appears on our dev server).

    None of the files have changed, and the Virtual Directory is configured
    identically to that of our dev server (Windows Authentication enabled,
    Anonymous access enabled).

    We have other ASP.Net applications which run without any problems on the
    production server.

    What could be causing this login box and 401.2 error?

    _____________________________________________
    Access is denied.
    Description: An error occurred while accessing the resources required to
    serve this request. The server may not be configured for access to the
    requested URL.

    Error message 401.2.: You do not have permission to view this directory or
    page using the credentials you supplied. Contact the Web server's
    administrator for help.
    _____________________________________________
     
    ElGordo, May 10, 2005
    #1
    1. Advertising

  2. ElGordo

    Karl Seguin Guest

    Do you have impersonate set to true in the web.config?

    Karl

    --
    MY ASP.Net tutorials
    http://www.openmymind.net/ - New and Improved (yes, the popup is
    annoying)
    http://www.openmymind.net/faq.aspx - unofficial newsgroup FAQ (more to
    come!)
    "ElGordo" <> wrote in message
    news:...
    > In our dev environment, our ASP.Net application works fine and outside
    > users can access it when provided with the proper URL.
    >
    > Once we moved the application to our public server, we now get a 401.2
    > error. A windows login prompt occurs once the URL is accessed in the
    > browser and nobody can log in (no login appears on our dev server).
    >
    > None of the files have changed, and the Virtual Directory is configured
    > identically to that of our dev server (Windows Authentication enabled,
    > Anonymous access enabled).
    >
    > We have other ASP.Net applications which run without any problems on the
    > production server.
    >
    > What could be causing this login box and 401.2 error?
    >
    > _____________________________________________
    > Access is denied.
    > Description: An error occurred while accessing the resources required to
    > serve this request. The server may not be configured for access to the
    > requested URL.
    >
    > Error message 401.2.: You do not have permission to view this directory or
    > page using the credentials you supplied. Contact the Web server's
    > administrator for help.
    > _____________________________________________
    >
     
    Karl Seguin, May 10, 2005
    #2
    1. Advertising

  3. ElGordo

    ElGordo Guest

    No, I don't.

    We didn't have this set in the app hosted on our dev box and public users
    can access it remotely without any problems.

    Is this an attribute of <authentication mode="Windows" /> ?





    "Karl Seguin" <karl REMOVE @ REMOVE openmymind REMOVEMETOO . ANDME net>
    wrote in message news:%...
    > Do you have impersonate set to true in the web.config?
    >
    > Karl
    >
    > --
    > MY ASP.Net tutorials
    > http://www.openmymind.net/ - New and Improved (yes, the popup is
    > annoying)
    > http://www.openmymind.net/faq.aspx - unofficial newsgroup FAQ (more to
    > come!)
    > "ElGordo" <> wrote in message
    > news:...
    >> In our dev environment, our ASP.Net application works fine and outside
    >> users can access it when provided with the proper URL.
    >>
    >> Once we moved the application to our public server, we now get a 401.2
    >> error. A windows login prompt occurs once the URL is accessed in the
    >> browser and nobody can log in (no login appears on our dev server).
    >>
    >> None of the files have changed, and the Virtual Directory is configured
    >> identically to that of our dev server (Windows Authentication enabled,
    >> Anonymous access enabled).
    >>
    >> We have other ASP.Net applications which run without any problems on the
    >> production server.
    >>
    >> What could be causing this login box and 401.2 error?
    >>
    >> _____________________________________________
    >> Access is denied.
    >> Description: An error occurred while accessing the resources required to
    >> serve this request. The server may not be configured for access to the
    >> requested URL.
    >>
    >> Error message 401.2.: You do not have permission to view this directory
    >> or page using the credentials you supplied. Contact the Web server's
    >> administrator for help.
    >> _____________________________________________
    >>

    >
    >
     
    ElGordo, May 10, 2005
    #3
  4. ElGordo

    Karl Seguin Guest

    no, it's an attribute of the <identity> element, if you don't have one
    (which you likely don't) it defaults to false, so that's not likely your
    problem.

    I take it you also don't have a <deny> element under authorization?

    It might be a ntfs permission problem..the anonymous user might not have
    access...

    Karl

    --
    MY ASP.Net tutorials
    http://www.openmymind.net/ - New and Improved (yes, the popup is
    annoying)
    http://www.openmymind.net/faq.aspx - unofficial newsgroup FAQ (more to
    come!)
    "ElGordo" <> wrote in message
    news:...
    > No, I don't.
    >
    > We didn't have this set in the app hosted on our dev box and public users
    > can access it remotely without any problems.
    >
    > Is this an attribute of <authentication mode="Windows" /> ?
    >
    >
    >
    >
    >
    > "Karl Seguin" <karl REMOVE @ REMOVE openmymind REMOVEMETOO . ANDME net>
    > wrote in message news:%...
    >> Do you have impersonate set to true in the web.config?
    >>
    >> Karl
    >>
    >> --
    >> MY ASP.Net tutorials
    >> http://www.openmymind.net/ - New and Improved (yes, the popup is
    >> annoying)
    >> http://www.openmymind.net/faq.aspx - unofficial newsgroup FAQ (more to
    >> come!)
    >> "ElGordo" <> wrote in message
    >> news:...
    >>> In our dev environment, our ASP.Net application works fine and outside
    >>> users can access it when provided with the proper URL.
    >>>
    >>> Once we moved the application to our public server, we now get a 401.2
    >>> error. A windows login prompt occurs once the URL is accessed in the
    >>> browser and nobody can log in (no login appears on our dev server).
    >>>
    >>> None of the files have changed, and the Virtual Directory is configured
    >>> identically to that of our dev server (Windows Authentication enabled,
    >>> Anonymous access enabled).
    >>>
    >>> We have other ASP.Net applications which run without any problems on the
    >>> production server.
    >>>
    >>> What could be causing this login box and 401.2 error?
    >>>
    >>> _____________________________________________
    >>> Access is denied.
    >>> Description: An error occurred while accessing the resources required to
    >>> serve this request. The server may not be configured for access to the
    >>> requested URL.
    >>>
    >>> Error message 401.2.: You do not have permission to view this directory
    >>> or page using the credentials you supplied. Contact the Web server's
    >>> administrator for help.
    >>> _____________________________________________
    >>>

    >>
    >>

    >
    >
     
    Karl Seguin, May 10, 2005
    #4
  5. ElGordo

    ElGordo Guest

    Hmmm....

    I added the line <identity impersonate="true" /> under the <system.web>
    element and now we can access that application remotely without any
    permissions issues.

    Thanks- I was not aware of this setting.

    "Karl Seguin" <karl REMOVE @ REMOVE openmymind REMOVEMETOO . ANDME net>
    wrote in message news:%...
    > Do you have impersonate set to true in the web.config?
    >
    > Karl
    >
    > --
    > MY ASP.Net tutorials
    > http://www.openmymind.net/ - New and Improved (yes, the popup is
    > annoying)
    > http://www.openmymind.net/faq.aspx - unofficial newsgroup FAQ (more to
    > come!)
    > "ElGordo" <> wrote in message
    > news:...
    >> In our dev environment, our ASP.Net application works fine and outside
    >> users can access it when provided with the proper URL.
    >>
    >> Once we moved the application to our public server, we now get a 401.2
    >> error. A windows login prompt occurs once the URL is accessed in the
    >> browser and nobody can log in (no login appears on our dev server).
    >>
    >> None of the files have changed, and the Virtual Directory is configured
    >> identically to that of our dev server (Windows Authentication enabled,
    >> Anonymous access enabled).
    >>
    >> We have other ASP.Net applications which run without any problems on the
    >> production server.
    >>
    >> What could be causing this login box and 401.2 error?
    >>
    >> _____________________________________________
    >> Access is denied.
    >> Description: An error occurred while accessing the resources required to
    >> serve this request. The server may not be configured for access to the
    >> requested URL.
    >>
    >> Error message 401.2.: You do not have permission to view this directory
    >> or page using the credentials you supplied. Contact the Web server's
    >> administrator for help.
    >> _____________________________________________
    >>

    >
    >
     
    ElGordo, May 10, 2005
    #5
  6. ElGordo

    Karl Seguin Guest

    You probably want to read up on the feature before enabling it. It can
    certainly have some unexpected effects..i wouldn't expect this to be your
    final solution...

    Karl

    --
    MY ASP.Net tutorials
    http://www.openmymind.net/ - New and Improved (yes, the popup is
    annoying)
    http://www.openmymind.net/faq.aspx - unofficial newsgroup FAQ (more to
    come!)
    "ElGordo" <> wrote in message
    news:%23Xl%...
    > Hmmm....
    >
    > I added the line <identity impersonate="true" /> under the <system.web>
    > element and now we can access that application remotely without any
    > permissions issues.
    >
    > Thanks- I was not aware of this setting.
    >
    > "Karl Seguin" <karl REMOVE @ REMOVE openmymind REMOVEMETOO . ANDME net>
    > wrote in message news:%...
    >> Do you have impersonate set to true in the web.config?
    >>
    >> Karl
    >>
    >> --
    >> MY ASP.Net tutorials
    >> http://www.openmymind.net/ - New and Improved (yes, the popup is
    >> annoying)
    >> http://www.openmymind.net/faq.aspx - unofficial newsgroup FAQ (more to
    >> come!)
    >> "ElGordo" <> wrote in message
    >> news:...
    >>> In our dev environment, our ASP.Net application works fine and outside
    >>> users can access it when provided with the proper URL.
    >>>
    >>> Once we moved the application to our public server, we now get a 401.2
    >>> error. A windows login prompt occurs once the URL is accessed in the
    >>> browser and nobody can log in (no login appears on our dev server).
    >>>
    >>> None of the files have changed, and the Virtual Directory is configured
    >>> identically to that of our dev server (Windows Authentication enabled,
    >>> Anonymous access enabled).
    >>>
    >>> We have other ASP.Net applications which run without any problems on the
    >>> production server.
    >>>
    >>> What could be causing this login box and 401.2 error?
    >>>
    >>> _____________________________________________
    >>> Access is denied.
    >>> Description: An error occurred while accessing the resources required to
    >>> serve this request. The server may not be configured for access to the
    >>> requested URL.
    >>>
    >>> Error message 401.2.: You do not have permission to view this directory
    >>> or page using the credentials you supplied. Contact the Web server's
    >>> administrator for help.
    >>> _____________________________________________
    >>>

    >>
    >>

    >
    >
     
    Karl Seguin, May 10, 2005
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Rich
    Replies:
    1
    Views:
    752
    =?Utf-8?B?RXNraW1v?=
    May 26, 2005
  2. Patrick.O.Ige

    'HTTP/1.1 401 Access Denied'.error

    Patrick.O.Ige, Oct 12, 2005, in forum: ASP .Net
    Replies:
    2
    Views:
    7,214
    Patrick.O.Ige
    Oct 13, 2005
  3. Jay Balapa
    Replies:
    2
    Views:
    17,950
    johnny keung
    May 23, 2006
  4. rote
    Replies:
    4
    Views:
    1,782
    Alexey Smirnov
    Aug 4, 2008
  5. Alex Washtell via .NET 247

    Web Service + Anon Access, but getting 401 Access Denied Error

    Alex Washtell via .NET 247, Apr 5, 2005, in forum: ASP .Net Web Services
    Replies:
    1
    Views:
    226
    Mauro Ottaviani [MSFT]
    Apr 5, 2005
Loading...

Share This Page