__dopostback javascript problem

Discussion in 'ASP .Net' started by Fredrik Elestedt, Apr 22, 2004.

  1. Hi,

    I have a problem with the __dopostback script when I run my webbapplication
    on certain servers. The code is not recompiled and the aspx filer are
    untouched...
    This is what happens, on a server where it works the formname used in the
    __doPostBack javascript function is __aspnetForm and in the case of the
    server where it does not work it is _ctl0:theForm

    The name of the form when I look at the source is the same - yet it is
    rendered differently. I've compared all settings that I could find and they
    are the same.
    Any ideas or suggestions on what to try is welcome - of course I would
    appriciate the solution as well.

    // Fredrik
     
    Fredrik Elestedt, Apr 22, 2004
    #1
    1. Advertising

  2. This is a bug in Framework 1.1. It is fixed in the following KB article:
    http://support.microsoft.com/default.aspx?kbid=818803.

    --
    John Saunders
    John.Saunders at SurfControl.com


    "Fredrik Elestedt" <> wrote in message
    news:%...
    > Hi,
    >
    > I have a problem with the __dopostback script when I run my

    webbapplication
    > on certain servers. The code is not recompiled and the aspx filer are
    > untouched...
    > This is what happens, on a server where it works the formname used in the
    > __doPostBack javascript function is __aspnetForm and in the case of the
    > server where it does not work it is _ctl0:theForm
    >
    > The name of the form when I look at the source is the same - yet it is
    > rendered differently. I've compared all settings that I could find and

    they
    > are the same.
    > Any ideas or suggestions on what to try is welcome - of course I would
    > appriciate the solution as well.
    >
    > // Fredrik
    >
    >
     
    John Saunders, Apr 22, 2004
    #2
    1. Advertising

  3. Good to know. Now all I have to do is figure out how to get some support
    from microsoft... since the patch doesn't appear to be available on the net.
    Any ideas? I've tried the link to Product Support Services but I can't
    figure out which alternative to use...

    // Fredrik

    "John Saunders" <john.saunders at SurfControl.com> wrote in message
    news:...
    > This is a bug in Framework 1.1. It is fixed in the following KB article:
    > http://support.microsoft.com/default.aspx?kbid=818803.
    >
    > --
    > John Saunders
    > John.Saunders at SurfControl.com
    >
    >
    > "Fredrik Elestedt" <> wrote in message
    > news:%...
    > > Hi,
    > >
    > > I have a problem with the __dopostback script when I run my

    > webbapplication
    > > on certain servers. The code is not recompiled and the aspx filer are
    > > untouched...
    > > This is what happens, on a server where it works the formname used in

    the
    > > __doPostBack javascript function is __aspnetForm and in the case of the
    > > server where it does not work it is _ctl0:theForm
    > >
    > > The name of the form when I look at the source is the same - yet it is
    > > rendered differently. I've compared all settings that I could find and

    > they
    > > are the same.
    > > Any ideas or suggestions on what to try is welcome - of course I would
    > > appriciate the solution as well.
    > >
    > > // Fredrik
    > >
    > >

    >
    >
     
    Fredrik Elestedt, Apr 22, 2004
    #3
  4. You should call them and reference the KB article. It will be free.

    --
    John Saunders
    John.Saunders at SurfControl.com


    "Fredrik Elestedt" <> wrote in message
    news:%...
    > Good to know. Now all I have to do is figure out how to get some support
    > from microsoft... since the patch doesn't appear to be available on the

    net.
    > Any ideas? I've tried the link to Product Support Services but I can't
    > figure out which alternative to use...
    >
    > // Fredrik
    >
    > "John Saunders" <john.saunders at SurfControl.com> wrote in message
    > news:...
    > > This is a bug in Framework 1.1. It is fixed in the following KB

    article:
    > > http://support.microsoft.com/default.aspx?kbid=818803.
    > >
    > > --
    > > John Saunders
    > > John.Saunders at SurfControl.com
    > >
    > >
    > > "Fredrik Elestedt" <> wrote in message
    > > news:%...
    > > > Hi,
    > > >
    > > > I have a problem with the __dopostback script when I run my

    > > webbapplication
    > > > on certain servers. The code is not recompiled and the aspx filer are
    > > > untouched...
    > > > This is what happens, on a server where it works the formname used in

    > the
    > > > __doPostBack javascript function is __aspnetForm and in the case of

    the
    > > > server where it does not work it is _ctl0:theForm
    > > >
    > > > The name of the form when I look at the source is the same - yet it is
    > > > rendered differently. I've compared all settings that I could find and

    > > they
    > > > are the same.
    > > > Any ideas or suggestions on what to try is welcome - of course I would
    > > > appriciate the solution as well.
    > > >
    > > > // Fredrik
    > > >
    > > >

    > >
    > >

    >
    >
     
    John Saunders, Apr 23, 2004
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Nikhil Patel

    javascript:__doPostBack error

    Nikhil Patel, Feb 26, 2004, in forum: ASP .Net
    Replies:
    3
    Views:
    8,053
    Scott M.
    Feb 26, 2004
  2. Adrian
    Replies:
    1
    Views:
    3,296
    Adrian
    Apr 26, 2004
  3. bredal Jensen
    Replies:
    4
    Views:
    23,357
    bredal Jensen
    Apr 27, 2004
  4. Granger Godbold
    Replies:
    0
    Views:
    958
    Granger Godbold
    May 12, 2004
  5. Murray Patrick via DotNetMonster.com

    __doPostBack Error -- Javascript

    Murray Patrick via DotNetMonster.com, Feb 11, 2005, in forum: ASP .Net
    Replies:
    1
    Views:
    2,697
    Murray Patrick via DotNetMonster.com
    Feb 11, 2005
Loading...

Share This Page