A little off topic!

Discussion in 'ASP .Net' started by Martyn Fewtrell, Jan 7, 2004.

  1. I know this is a little off topic but I wondered if anybody else is having
    similar problems to me.

    Visual studio 2003 keeps reformatting my HTML and normally gets it wrong.

    Currently it has a habit of removing the quotes from around attributes which
    often causes page load errors. Yes I do have the settings on the options
    box to add quotes.

    It also seems to put the closing tags in Upper case despite the fact that I
    have specified all tags as lower case in the options/formatting box for
    HTML.

    I just dont seems to be able to keep a closing </li> on the end of my lists.

    The problems seem to occur when moving from design view to code view and
    back again - I have also set it not to check formatting etc

    Does everybody have this problem or am I missing something?

    It seems that web matrix lays out code beautifully (just as you type it) and
    doesn't mess about with things once laid out so I cant see why Visual Studio
    cant manage the same.

    Martyn Fewtrell
     
    Martyn Fewtrell, Jan 7, 2004
    #1
    1. Advertising

  2. Martyn Fewtrell

    Fred. Guest

    Hi there,

    I have the exact same problem, on 2002.

    I sort go around it by telling VS to not display design
    view by default, and by saving the file before going into
    design view, and doing ctr-z(undo) when going back to html
    view.

    I only use the design view to find controls on page, so
    not too much of a problem for me.

    Fred.



    >-----Original Message-----
    >I know this is a little off topic but I wondered if

    anybody else is having
    >similar problems to me.
    >
    >Visual studio 2003 keeps reformatting my HTML and

    normally gets it wrong.
    >
    >Currently it has a habit of removing the quotes from

    around attributes which
    >often causes page load errors. Yes I do have the

    settings on the options
    >box to add quotes.
    >
    >It also seems to put the closing tags in Upper case

    despite the fact that I
    >have specified all tags as lower case in the

    options/formatting box for
    >HTML.
    >
    >I just dont seems to be able to keep a closing </li> on

    the end of my lists.
    >
    >The problems seem to occur when moving from design view

    to code view and
    >back again - I have also set it not to check formatting

    etc
    >
    >Does everybody have this problem or am I missing

    something?
    >
    >It seems that web matrix lays out code beautifully (just

    as you type it) and
    >doesn't mess about with things once laid out so I cant

    see why Visual Studio
    >cant manage the same.
    >
    >Martyn Fewtrell
    >
    >
    >.
    >
     
    Fred., Jan 7, 2004
    #2
    1. Advertising

  3. Martyn Fewtrell

    Michael Guest

    Funny, I switched from web matrix to vs.net for almost the same reason, (it
    was reformatting my html code). Then I figured out that vs.net does the
    same thing. Then I just gave up...I wanted vs.net for the code completion,
    so I learned to live with it.

    Ya hear that microsoft! YOU WIN! You are successfully controlling the
    layout of my html pages now! It would be very nice if there was the ability
    to turn that off, so the text editor acted just like notepad.

    "Martyn Fewtrell" <> wrote in message
    news:...
    > I know this is a little off topic but I wondered if anybody else is having
    > similar problems to me.
    >
    > Visual studio 2003 keeps reformatting my HTML and normally gets it wrong.
    >
    > Currently it has a habit of removing the quotes from around attributes

    which
    > often causes page load errors. Yes I do have the settings on the options
    > box to add quotes.
    >
    > It also seems to put the closing tags in Upper case despite the fact that

    I
    > have specified all tags as lower case in the options/formatting box for
    > HTML.
    >
    > I just dont seems to be able to keep a closing </li> on the end of my

    lists.
    >
    > The problems seem to occur when moving from design view to code view and
    > back again - I have also set it not to check formatting etc
    >
    > Does everybody have this problem or am I missing something?
    >
    > It seems that web matrix lays out code beautifully (just as you type it)

    and
    > doesn't mess about with things once laid out so I cant see why Visual

    Studio
    > cant manage the same.
    >
    > Martyn Fewtrell
    >
    >
     
    Michael, Jan 7, 2004
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. A little off topic

    , Feb 4, 2005, in forum: ASP .Net
    Replies:
    0
    Views:
    360
  2. ohaya
    Replies:
    1
    Views:
    2,183
    Sudsy
    Aug 21, 2004
  3. Claude
    Replies:
    0
    Views:
    362
    Claude
    Mar 7, 2004
  4. Cliff R.
    Replies:
    3
    Views:
    424
    Roy Schestowitz
    Jun 15, 2005
  5. Tan Thuan Seah

    A little off topic but..

    Tan Thuan Seah, Oct 13, 2004, in forum: C++
    Replies:
    3
    Views:
    320
Loading...

Share This Page