Access Denied error in Watir 1.5.3 (Using Ruby 1.8.6)

Discussion in 'Ruby' started by Samiran Sil, Aug 14, 2008.

  1. Samiran Sil

    Samiran Sil Guest

    Dear Friends,

    I am getting an error in Watir 1.5.3 (Using Ruby 1.8.6).

    Error:

    "there are 1 frames
    frame index: 1 Access Denied, see
    http://wiki.openqa.org/display/WTR/FAQ#access-denied
    c:/ruby/lib/ruby/gems/1.8/gems/watir-1.5.3/./watir/element.rb:49:in
    `assert_exists': Unable to locate object, using name and
    customerFirstName (Watir::Exception::UnknownObjectException)
    from
    c:/ruby/lib/ruby/gems/1.8/gems/watir-1.5.3/./watir/input_elements.rb:227:in
    `to_s'
    from samtest.rb:30"


    Plz help me out for the same.

    Thanks & Regards,
    Samiran Sil.
    --
    Posted via http://www.ruby-forum.com/.
    Samiran Sil, Aug 14, 2008
    #1
    1. Advertising

  2. [Note: parts of this message were removed to make it a legal post.]

    Have you read all the FAQ info?

    http://wiki.openqa.org/display/WTR/FAQ#FAQ-WhydoIgetanaccessdeniederrorwhentryingtoaccessaframe?

    Read through it and then repost stating that there is no answer found in the
    docs. But, it usually means you are trying to access a frame that's source
    is from another domain. I saw this alot for ads that were in iframes.

    /Shawn

    On Thu, Aug 14, 2008 at 7:20 AM, Samiran Sil <> wrote:

    > Dear Friends,
    >
    > I am getting an error in Watir 1.5.3 (Using Ruby 1.8.6).
    >
    > Error:
    >
    > "there are 1 frames
    > frame index: 1 Access Denied, see
    > http://wiki.openqa.org/display/WTR/FAQ#access-denied
    > c:/ruby/lib/ruby/gems/1.8/gems/watir-1.5.3/./watir/element.rb:49:in
    > `assert_exists': Unable to locate object, using name and
    > customerFirstName (Watir::Exception::UnknownObjectException)
    > from
    > c:/ruby/lib/ruby/gems/1.8/gems/watir-1.5.3/./watir/input_elements.rb:227:in
    > `to_s'
    > from samtest.rb:30"
    >
    >
    > Plz help me out for the same.
    >
    > Thanks & Regards,
    > Samiran Sil.
    > --
    > Posted via http://www.ruby-forum.com/.
    >
    >
    Shawn Anderson, Aug 15, 2008
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jay
    Replies:
    2
    Views:
    1,061
  2. Alex Washtell via .NET 247

    Web Service + Anon Access, but getting 401 Access Denied Error

    Alex Washtell via .NET 247, Apr 5, 2005, in forum: ASP .Net Web Services
    Replies:
    1
    Views:
    191
    Mauro Ottaviani [MSFT]
    Apr 5, 2005
  3. Anukul Singhal
    Replies:
    1
    Views:
    157
    Charley Baker
    May 15, 2008
  4. Pradeepta Swain

    watir , access is denied

    Pradeepta Swain, Jun 27, 2008, in forum: Ruby
    Replies:
    5
    Views:
    180
    Pradeepta Swain
    Jul 1, 2008
  5. Diego Fernández Santos
    Replies:
    2
    Views:
    230
Loading...

Share This Page