ADODB connection string on SBS 2008

Discussion in 'ASP General' started by Onetoomany, Nov 16, 2008.

  1. Onetoomany

    Onetoomany Guest

    Hi,

    I've just upgraded to Small Business Server 2008, 64 bit.

    My website, which worked perfectly before, is having issues with the
    connection string:
    I've tried:
    1) sConnection = "Provider=Microsoft.Jet.OLEDB.4.0;Data
    Source=F:\Website\databases\database.mdb;"
    2) sConnection = "Provider=Microsoft.ACE.OLEDB.12.0;Data
    Source=F:\Website\databases\database.mdb;"
    3) sConnection = "Driver={Microsoft Access Driver
    (*.mdb)};Dbq=F:\Website\Manydown.com\databases\manydown.mdb;"

    I get the error: (1 & 2)
    ADODB.Recordset error '800a0e7a'
    Provider cannot be found. It may not be properly installed.

    /default.asp, line 55

    (3)
    error '80004005'
    /default.asp, line 55

    Googling seems to indicate that MS has removed Jet from Server 2008, but I
    can't find a suitable replacement. I've downloaded the 2007 Access driver,
    so I'm surprised that I get this error from it.
    I've given IUSR_server (Internet Guest Account) and Network Service full
    rights to my database folder.

    Help?

    Thanks

    Richard.
    Onetoomany, Nov 16, 2008
    #1
    1. Advertising

  2. Onetoomany

    Bob Barrows Guest

    Onetoomany wrote:
    > Hi,
    >
    > I've just upgraded to Small Business Server 2008, 64 bit.
    >
    > My website, which worked perfectly before, is having issues with the
    > connection string:
    > I've tried:
    > 1) sConnection = "Provider=Microsoft.Jet.OLEDB.4.0;Data
    > Source=F:\Website\databases\database.mdb;"
    > 2) sConnection = "Provider=Microsoft.ACE.OLEDB.12.0;Data
    > Source=F:\Website\databases\database.mdb;"
    > 3) sConnection = "Driver={Microsoft Access Driver
    > (*.mdb)};Dbq=F:\Website\Manydown.com\databases\manydown.mdb;"
    >
    > I get the error: (1 & 2)
    > ADODB.Recordset error '800a0e7a'
    > Provider cannot be found. It may not be properly installed.
    >
    > /default.asp, line 55
    >
    > (3)
    > error '80004005'
    > /default.asp, line 55
    >
    > Googling seems to indicate that MS has removed Jet from Server 2008,
    > but I can't find a suitable replacement. I've downloaded the 2007
    > Access driver, so I'm surprised that I get this error from it.
    > I've given IUSR_server (Internet Guest Account) and Network Service
    > full rights to my database folder.
    >


    You need to download the 64-bit Jet components from MS:
    http://www.microsoft.com/downloads/...98-DE73-47DC-911B-50F4F0627FF4&displaylang=en


    But doesn't SBS use a SQL Server backend?

    --
    Microsoft MVP - ASP/ASP.NET - 2004-2007
    Please reply to the newsgroup. This email account is my spam trap so I
    don't check it very often. If you must reply off-line, then remove the
    "NO SPAM"
    Bob Barrows, Nov 16, 2008
    #2
    1. Advertising

  3. Onetoomany

    Onetoomany Guest

    Thanks. Jet does not want to install onto 2008 - it seems that (according
    to microsoft) Jet is already installed...

    I've managed to solve the problem, but not overly satisfactoraily:
    1) Set the applicaiton pool to 32 bit
    This then gave me a "The requested page cannot be accessed because the
    related configuration data for the page is invalid" error.

    To solve this I had to:
    2) Uninstall RPC over HTTP Proxy
    3) Disable the httpCompression

    Finally working, but getting errors in the system log for having uninstalled
    the RPC over HTTP proxy.

    "Bob Barrows" <> wrote in message
    news:%...
    > Onetoomany wrote:
    >> Hi,
    >>
    >> I've just upgraded to Small Business Server 2008, 64 bit.
    >>
    >> My website, which worked perfectly before, is having issues with the
    >> connection string:
    >> I've tried:
    >> 1) sConnection = "Provider=Microsoft.Jet.OLEDB.4.0;Data
    >> Source=F:\Website\databases\database.mdb;"
    >> 2) sConnection = "Provider=Microsoft.ACE.OLEDB.12.0;Data
    >> Source=F:\Website\databases\database.mdb;"
    >> 3) sConnection = "Driver={Microsoft Access Driver
    >> (*.mdb)};Dbq=F:\Website\Manydown.com\databases\manydown.mdb;"
    >>
    >> I get the error: (1 & 2)
    >> ADODB.Recordset error '800a0e7a'
    >> Provider cannot be found. It may not be properly installed.
    >>
    >> /default.asp, line 55
    >>
    >> (3)
    >> error '80004005'
    >> /default.asp, line 55
    >>
    >> Googling seems to indicate that MS has removed Jet from Server 2008,
    >> but I can't find a suitable replacement. I've downloaded the 2007
    >> Access driver, so I'm surprised that I get this error from it.
    >> I've given IUSR_server (Internet Guest Account) and Network Service
    >> full rights to my database folder.
    >>

    >
    > You need to download the 64-bit Jet components from MS:
    > http://www.microsoft.com/downloads/...98-DE73-47DC-911B-50F4F0627FF4&displaylang=en
    >
    >
    > But doesn't SBS use a SQL Server backend?
    >
    > --
    > Microsoft MVP - ASP/ASP.NET - 2004-2007
    > Please reply to the newsgroup. This email account is my spam trap so I
    > don't check it very often. If you must reply off-line, then remove the
    > "NO SPAM"
    >
    Onetoomany, Nov 16, 2008
    #3
  4. Onetoomany

    Bob Barrows Guest

    You may want to run this by the folks over at .inetserver.iis ...

    Onetoomany wrote:
    > Thanks. Jet does not want to install onto 2008 - it seems that
    > (according to microsoft) Jet is already installed...
    >
    > I've managed to solve the problem, but not overly satisfactoraily:
    > 1) Set the applicaiton pool to 32 bit
    > This then gave me a "The requested page cannot be accessed because the
    > related configuration data for the page is invalid" error.
    >
    > To solve this I had to:
    > 2) Uninstall RPC over HTTP Proxy
    > 3) Disable the httpCompression
    >
    > Finally working, but getting errors in the system log for having
    > uninstalled the RPC over HTTP proxy.
    >
    > "Bob Barrows" <> wrote in message
    > news:%...
    >> Onetoomany wrote:
    >>> Hi,
    >>>
    >>> I've just upgraded to Small Business Server 2008, 64 bit.
    >>>
    >>> My website, which worked perfectly before, is having issues with the
    >>> connection string:
    >>> I've tried:
    >>> 1) sConnection = "Provider=Microsoft.Jet.OLEDB.4.0;Data
    >>> Source=F:\Website\databases\database.mdb;"
    >>> 2) sConnection = "Provider=Microsoft.ACE.OLEDB.12.0;Data
    >>> Source=F:\Website\databases\database.mdb;"
    >>> 3) sConnection = "Driver={Microsoft Access Driver
    >>> (*.mdb)};Dbq=F:\Website\Manydown.com\databases\manydown.mdb;"
    >>>
    >>> I get the error: (1 & 2)
    >>> ADODB.Recordset error '800a0e7a'
    >>> Provider cannot be found. It may not be properly installed.
    >>>
    >>> /default.asp, line 55
    >>>
    >>> (3)
    >>> error '80004005'
    >>> /default.asp, line 55
    >>>
    >>> Googling seems to indicate that MS has removed Jet from Server 2008,
    >>> but I can't find a suitable replacement. I've downloaded the 2007
    >>> Access driver, so I'm surprised that I get this error from it.
    >>> I've given IUSR_server (Internet Guest Account) and Network Service
    >>> full rights to my database folder.
    >>>

    >>
    >> You need to download the 64-bit Jet components from MS:
    >>

    http://www.microsoft.com/downloads/...98-DE73-47DC-911B-50F4F0627FF4&displaylang=en
    >>
    >>
    >> But doesn't SBS use a SQL Server backend?
    >>
    >> --
    >> Microsoft MVP - ASP/ASP.NET - 2004-2007
    >> Please reply to the newsgroup. This email account is my spam trap so
    >> I don't check it very often. If you must reply off-line, then remove
    >> the "NO SPAM"


    --
    HTH,
    Bob Barrows
    Bob Barrows, Nov 17, 2008
    #4
  5. Onetoomany wrote on Sun, 16 Nov 2008 22:26:32 -0000:

    > Thanks. Jet does not want to install onto 2008 - it seems that
    > (according to microsoft) Jet is already installed...


    Windows 2008 includes the latest version of Jet - however, it's still only
    32-bit (there is no 64-bit version of Jet that I am aware of). The 64-bit
    SP8 for Jet 4 for Windows 2003 is the same installer that runs on the 32-bit
    OS versions too - the 64-bit in the KB article name is irrelevant, it's just
    there for those users who have 2003 64-bit.


    > I've managed to solve the problem, but not overly satisfactoraily:
    > 1) Set the applicaiton pool to 32 bit
    > This then gave me a "The requested page cannot be accessed because the
    > related configuration data for the page is invalid" error.


    > To solve this I had to:
    > 2) Uninstall RPC over HTTP Proxy
    > 3) Disable the httpCompression


    > Finally working, but getting errors in the system log for having
    > uninstalled the RPC over HTTP proxy.



    I think you need to run IIS itself in 32-bit mode to use the Jet drivers
    properly - you seem to have managed to kludge it to work with IIS in 64-bit
    mode with a 32-bit application pool and I'm not sure this is supported or
    even stable.

    Dan

    > "Bob Barrows" <> wrote in message news:%...
    >> Onetoomany wrote:
    >>> Hi,


    >>> I've just upgraded to Small Business Server 2008, 64 bit.


    >>> My website, which worked perfectly before, is having issues with the
    >>> connection string:
    >>> I've tried:
    >>> 1) sConnection = "Provider=Microsoft.Jet.OLEDB.4.0;Data
    >>> Source=F:\Website\databases\database.mdb;"
    >>> 2) sConnection = "Provider=Microsoft.ACE.OLEDB.12.0;Data
    >>> Source=F:\Website\databases\database.mdb;"
    >>> 3) sConnection = "Driver={Microsoft Access Driver
    >>> (*.mdb)};Dbq=F:\Website\Manydown.com\databases\manydown.mdb;"


    >>> I get the error: (1 & 2)
    >>> ADODB.Recordset error '800a0e7a'
    >>> Provider cannot be found. It may not be properly installed.


    >>> /default.asp, line 55


    >>> (3)
    >>> error '80004005'
    >>> /default.asp, line 55


    >>> Googling seems to indicate that MS has removed Jet from Server 2008,
    >>> but I can't find a suitable replacement. I've downloaded the 2007
    >>> Access driver, so I'm surprised that I get this error from it.
    >>> I've given IUSR_server (Internet Guest Account) and Network Service
    >>> full rights to my database folder.



    >> You need to download the 64-bit Jet components from MS:
    >> http://www.microsoft.com/downloads/details.aspx?familyid=AD2B6698-
    >> DE73-47DC-911B-50F4F0627FF4&displaylang=en



    >> But doesn't SBS use a SQL Server backend?


    >> --
    >> Microsoft MVP - ASP/ASP.NET - 2004-2007
    >> Please reply to the newsgroup. This email account is my spam trap so
    >> I don't check it very often. If you must reply off-line, then remove
    >> the "NO SPAM"
    Daniel Crichton, Nov 18, 2008
    #5
  6. "Daniel Crichton" <> wrote in message
    news:...
    > Onetoomany wrote on Sun, 16 Nov 2008 22:26:32 -0000:
    >
    >> Thanks. Jet does not want to install onto 2008 - it seems that
    >> (according to microsoft) Jet is already installed...

    >
    > Windows 2008 includes the latest version of Jet - however, it's still only
    > 32-bit (there is no 64-bit version of Jet that I am aware of). The 64-bit
    > SP8 for Jet 4 for Windows 2003 is the same installer that runs on the
    > 32-bit OS versions too - the 64-bit in the KB article name is irrelevant,
    > it's just there for those users who have 2003 64-bit.
    >
    >
    >> I've managed to solve the problem, but not overly satisfactoraily:
    >> 1) Set the applicaiton pool to 32 bit
    >> This then gave me a "The requested page cannot be accessed because the
    >> related configuration data for the page is invalid" error.

    >
    >> To solve this I had to:
    >> 2) Uninstall RPC over HTTP Proxy
    >> 3) Disable the httpCompression

    >
    >> Finally working, but getting errors in the system log for having
    >> uninstalled the RPC over HTTP proxy.

    >
    >
    > I think you need to run IIS itself in 32-bit mode to use the Jet drivers
    > properly - you seem to have managed to kludge it to work with IIS in
    > 64-bit mode with a 32-bit application pool and I'm not sure this is
    > supported or even stable.
    >


    IIS itself won't run in 64 bit on a 2008 server. Its the application pools
    where the choice needs to be made. No 32 bit components will attempt to run
    in the inetinfo process. Everything (including the ISAPI filters) run in
    the w3wp worker processes which may be either 32 to 64 bits.

    It would be appropriate in this case to set the application pool to use the
    Classic pipeline, and therefore make it behave much more like IIS6.

    --
    Anthony Jones - MVP ASP/ASP.NET
    Anthony Jones, Nov 18, 2008
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Douglas J. Badin
    Replies:
    0
    Views:
    429
    Douglas J. Badin
    Nov 13, 2003
  2. jt
    Replies:
    0
    Views:
    303
  3. TomislaW

    Forms authentication problem on SBS

    TomislaW, Apr 5, 2005, in forum: ASP .Net
    Replies:
    1
    Views:
    272
    TomislaW
    Apr 5, 2005
  4. Simon
    Replies:
    0
    Views:
    1,274
    Simon
    Sep 5, 2005
  5. Steve
    Replies:
    0
    Views:
    211
    Steve
    Feb 28, 2006
Loading...

Share This Page