anonymous authentication

Discussion in 'ASP .Net' started by =?Utf-8?B?SnVsaWE=?=, Sep 2, 2005.

  1. Hi,
    I have a problem when I browse my asp.net pages. The style sheet is not
    loaded. If I try to browse the style sheet from the IIS I get this message :
    "You are not authorized to view this page".

    In my config file I have this settings:

    <authentication mode="Forms">
    <forms loginUrl="AppLogin.aspx" name=".ASPXFORMSAUTH" protection="All"
    slidingExpiration="true"/>
    </authentication>

    <authorization>
    <deny users="?" />
    </authorization>

    And in my IIS I have marked the Enable Anonymos Access. I am running a
    Windows Server 2003.

    What can I do to fix this?

    Thanks
    Julia
     
    =?Utf-8?B?SnVsaWE=?=, Sep 2, 2005
    #1
    1. Advertising

  2. Let's have a look at the HTML for the StyleSheet Link.

    --
    HTH,

    Kevin Spencer
    Microsoft MVP
    ..Net Developer
    Neither a follower nor a lender be.

    "Julia" <> wrote in message
    news:...
    > Hi,
    > I have a problem when I browse my asp.net pages. The style sheet is not
    > loaded. If I try to browse the style sheet from the IIS I get this message
    > :
    > "You are not authorized to view this page".
    >
    > In my config file I have this settings:
    >
    > <authentication mode="Forms">
    > <forms loginUrl="AppLogin.aspx" name=".ASPXFORMSAUTH" protection="All"
    > slidingExpiration="true"/>
    > </authentication>
    >
    > <authorization>
    > <deny users="?" />
    > </authorization>
    >
    > And in my IIS I have marked the Enable Anonymos Access. I am running a
    > Windows Server 2003.
    >
    > What can I do to fix this?
    >
    > Thanks
    > Julia
    >
     
    Kevin Spencer, Sep 2, 2005
    #2
    1. Advertising

  3. =?Utf-8?B?SnVsaWE=?=

    Bruce Barker Guest

    if you style sheet is name.css or name.html, (not aspx) then security is
    handled by iis only. iis use directory security, so check the permission of
    the stylesheet directory for the anonymous accout given to iis.


    -- bruce (sqlwork.com)

    "Julia" <> wrote in message
    news:...
    > Hi,
    > I have a problem when I browse my asp.net pages. The style sheet is not
    > loaded. If I try to browse the style sheet from the IIS I get this message
    > :
    > "You are not authorized to view this page".
    >
    > In my config file I have this settings:
    >
    > <authentication mode="Forms">
    > <forms loginUrl="AppLogin.aspx" name=".ASPXFORMSAUTH" protection="All"
    > slidingExpiration="true"/>
    > </authentication>
    >
    > <authorization>
    > <deny users="?" />
    > </authorization>
    >
    > And in my IIS I have marked the Enable Anonymos Access. I am running a
    > Windows Server 2003.
    >
    > What can I do to fix this?
    >
    > Thanks
    > Julia
    >
     
    Bruce Barker, Sep 2, 2005
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Darren Oakey

    Anonymous login and Windows Authentication

    Darren Oakey, Oct 29, 2003, in forum: ASP .Net
    Replies:
    1
    Views:
    2,632
    Lyndon Hills
    Oct 29, 2003
  2. Curt_C [MVP]
    Replies:
    2
    Views:
    364
    Curt_C [MVP]
    Sep 21, 2004
  3. =?Utf-8?B?U2hhcmlm?=

    use anonymous but get get an authentication box

    =?Utf-8?B?U2hhcmlm?=, Sep 21, 2004, in forum: ASP .Net
    Replies:
    0
    Views:
    374
    =?Utf-8?B?U2hhcmlm?=
    Sep 21, 2004
  4. Reporter
    Replies:
    3
    Views:
    485
    Mike Schilling
    May 12, 2007
  5. Replies:
    1
    Views:
    228
Loading...

Share This Page