Anyone use Visual Sourcesafe?

Discussion in 'ASP .Net' started by Rosanne, Jul 19, 2005.

  1. Rosanne

    Rosanne Guest

    I've taken over a vb.net application. Any time I open an aspx page i
    visual studio, I get the "check out" box from visual source saf
    telling me that I cannot edit files without checking them out first.
    This box appears as soon as the page is opened - before I even have
    chance to make any changes. The problem seems to be with 2 @registe
    tags at the top of the HTML. Visual studio will try to flip flop thes
    tags with the @page tag when the page is opened. But, even if I chec
    it out and save the changes that visual studio made and check it bac
    in, I have the same problem if I try to open the page again - it flip
    the tags again and forces me to check out the file. This doesn'
    happen in the other vb.net application I work on. Any ideas?? It'
    driving me nuts!

    Thanks

    --
    Rosann
    -----------------------------------------------------------------------
    Rosanne's Profile: http://www.highdots.com/forums/member.php?userid=28
    View this thread: http://www.highdots.com/forums/showthread.php?t=205299
    Rosanne, Jul 19, 2005
    #1
    1. Advertising

  2. Rosanne,

    We have the exact same situation here. I haven't dived too deep into
    the issue, but we are in the same boat =). Let me know if you find a
    solution. Everything works great, just a bit annoying with that alert
    popping up every time a page is opened.

    Aaron
    Aaron Corcoran, Jul 19, 2005
    #2
    1. Advertising

  3. In Visual Studio, go to Tools, Options, Source Control

    There you will find your answer. May the Schwartz be with you.

    "Rosanne" wrote:

    >
    > I've taken over a vb.net application. Any time I open an aspx page in
    > visual studio, I get the "check out" box from visual source safe
    > telling me that I cannot edit files without checking them out first.
    > This box appears as soon as the page is opened - before I even have a
    > chance to make any changes. The problem seems to be with 2 @register
    > tags at the top of the HTML. Visual studio will try to flip flop these
    > tags with the @page tag when the page is opened. But, even if I check
    > it out and save the changes that visual studio made and check it back
    > in, I have the same problem if I try to open the page again - it flips
    > the tags again and forces me to check out the file. This doesn't
    > happen in the other vb.net application I work on. Any ideas?? It's
    > driving me nuts!
    >
    > Thanks!
    >
    >
    > --
    > Rosanne
    > ------------------------------------------------------------------------
    > Rosanne's Profile: http://www.highdots.com/forums/member.php?userid=283
    > View this thread: http://www.highdots.com/forums/showthread.php?t=2052998
    >
    >
    =?Utf-8?B?QnJhZCBSb2JlcnRz?=, Jul 19, 2005
    #3
  4. Rosanne

    Marina Guest

    I believe there are options for this in VS.NET. If you go under Options,
    Source Control, change the dropdown to 'Do Nothing' for the 'when checked in
    items are edited' option.

    If the 'when checked in items are saved' option is set to Prompt for check
    out, you will still get prompts for when you save the file.

    Another option is to not use the VSS integration into VS.NET. Just do the
    check in/out right from VSS.
    If you try to save a file that is checked out, it should be read-only on
    your PC, so you will know you need to go check it out first.

    "Rosanne" <> wrote in message
    news:...
    >
    > I've taken over a vb.net application. Any time I open an aspx page in
    > visual studio, I get the "check out" box from visual source safe
    > telling me that I cannot edit files without checking them out first.
    > This box appears as soon as the page is opened - before I even have a
    > chance to make any changes. The problem seems to be with 2 @register
    > tags at the top of the HTML. Visual studio will try to flip flop these
    > tags with the @page tag when the page is opened. But, even if I check
    > it out and save the changes that visual studio made and check it back
    > in, I have the same problem if I try to open the page again - it flips
    > the tags again and forces me to check out the file. This doesn't
    > happen in the other vb.net application I work on. Any ideas?? It's
    > driving me nuts!
    >
    > Thanks!
    >
    >
    > --
    > Rosanne
    > ------------------------------------------------------------------------
    > Rosanne's Profile: http://www.highdots.com/forums/member.php?userid=283
    > View this thread: http://www.highdots.com/forums/showthread.php?t=2052998
    >
    Marina, Jul 19, 2005
    #4
  5. Rosanne

    Rosanne Guest

    Thanks for the replies! I don't really have an issue with sourc
    control asking me to check out the file it if thinks I edited it.
    have an issue with Visual Studio making changes to HTML when I open th
    page. I guess my title was a bit misleading...I was really wonderin
    why visual studio does this and how to stop it.

    Thanks again! Rosann

    --
    Rosann
    -----------------------------------------------------------------------
    Rosanne's Profile: http://www.highdots.com/forums/member.php?userid=28
    View this thread: http://www.highdots.com/forums/showthread.php?t=205299
    Rosanne, Jul 19, 2005
    #5
  6. Rosanne

    Scott Allen Guest

    Hi Rosanna:

    You can go to Tools -> Options -> Text Editor -> HTML/XML -> Format
    and uncheck the 'apply automatic formatting' options. I hope this will
    help out your scenario, but there will always be times in VS.2003 when
    the designer tweaks the code behind your back.

    --
    Scott
    http://www.OdeToCode.com/blogs/scott/

    On Tue, 19 Jul 2005 22:32:30 +0200, Rosanne
    <> wrote:

    >
    >Thanks for the replies! I don't really have an issue with source
    >control asking me to check out the file it if thinks I edited it. I
    >have an issue with Visual Studio making changes to HTML when I open the
    >page. I guess my title was a bit misleading...I was really wondering
    >why visual studio does this and how to stop it.
    >
    >Thanks again! Rosanne
    Scott Allen, Jul 20, 2005
    #6
  7. Rosanne

    Rosanne Guest

    Rosanne, Jul 21, 2005
    #7
  8. Brad/Marina,

    Thank you for the tip, it worked wonders!

    Aaron
    Aaron Corcoran, Jul 22, 2005
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jason Barnett
    Replies:
    3
    Views:
    3,759
    Jason Barnett
    Sep 16, 2005
  2. Jason Shohet

    where do i find visual sourcesafe?

    Jason Shohet, Dec 15, 2004, in forum: ASP .Net
    Replies:
    4
    Views:
    1,784
    Juan T. Llibre [MVP]
    Dec 16, 2004
  3. Damien
    Replies:
    0
    Views:
    1,556
    Damien
    Aug 4, 2005
  4. abbym
    Replies:
    0
    Views:
    433
    abbym
    Oct 28, 2005
  5. looping
    Replies:
    0
    Views:
    325
    looping
    Mar 14, 2006
Loading...

Share This Page