Apache question

Discussion in 'HTML' started by soup_or_power@yahoo.com, Apr 21, 2005.

  1. Guest

    , Apr 21, 2005
    #1
    1. Advertising

  2. Els Guest

    wrote:

    > Sorry about this thread. I didn't know where else to post.


    news:alt.apache.configuration

    --
    Els http://locusmeus.com/
    Sonhos vem. Sonhos vão. O resto é imperfeito.
    - Renato Russo -
    Now playing: Mr. Big - Wild World
    Els, Apr 21, 2005
    #2
    1. Advertising

  3. Travis Newbury, Apr 21, 2005
    #3
  4. While the city slept, Travis Newbury () feverishly
    typed...

    > wrote:
    >> Sorry about this thread. I didn't know where else to post. The apache
    >> server currently expands "tilda" but won't accept a full path:
    >> http://storm/~megauser/image.jpg works
    >> http://storm/export/home/megauser/image.jpg doesn't work

    >
    > Awe crap, I thought this was a thread about Indians. Nevermind


    And I thought it was about the music of Hank Marvin! ;-)

    Cheers,
    Nige

    --
    Nigel Moss
    http://www.nigenet.org.uk
    Mail address not valid. , take the DOG. out!
    In the land of the blind, the one-eyed man is very, very busy!
    nice.guy.nige, Apr 21, 2005
    #4
  5. Baho Utot Guest

    On Thu, 21 Apr 2005 09:49:00 -0700, soup_or_power wrote:

    > Sorry about this thread. I didn't know where else to post. The apache
    > server currently expands "tilda" but won't accept a full path:
    > http://storm/~megauser/image.jpg works
    > http://storm/export/home/megauser/image.jpg doesn't work
    >
    > Is there any way to tweak the apache so that the second URL will work.
    >
    > Many thanks


    Ok, I'll try to help

    I suspect Apache says something like access deined. If so you need to add
    a directory command for that to work.

    Something like this:
    <Directory /storm/export/home/megauser/>
    Order Deny,Allow
    Allow from all
    </Directory>

    This is usally placed into the VirtualHost part of the configuration file.

    You may also need other options according to what your trying to
    accomplish.

    If this doesn't work then I will need to see your config file httpd.conf



    The reason the tilda works is because Apache's configuration has users
    home directories enabled.


    --
    Tayo'y Mga Pinoy
    Baho Utot, Apr 21, 2005
    #5
  6. Toby Inkster Guest

    soup_or_power wrote:

    > Sorry about this thread. I didn't know where else to post. The apache
    > server currently expands "tilda" but won't accept a full path:
    > http://storm/~megauser/image.jpg works
    > http://storm/export/home/megauser/image.jpg doesn't work


    Errr.... D'oh! You're completely misunderstanding how Apache maps URLs
    onto the filesystem.

    Hint: "http://storm/foo.html" does not correspond to the file "/foo.html".
    It probably corresponds to something like "/var/www/html/foo.html".

    So if you access "http://storm/export/home/megauser/image.jpg" it won't
    look for "/export/home/megauser/image.jpg", but rather it will look for
    "/var/www/html/export/home/megauser/image.jpg".

    Read this to get started:
    http://httpd.apache.org/docs-2.0/urlmapping.html

    --
    Toby A Inkster BSc (Hons) ARCS
    Contact Me ~ http://tobyinkster.co.uk/contact
    Toby Inkster, Apr 21, 2005
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.

Share This Page