Applet no longer works in IE

Discussion in 'Java' started by Mark, Nov 15, 2005.

  1. Mark

    Mark Guest

    Hi all,

    I've got this applet that works fine. Worked fine. The applet consist
    of couple of classes, packed in a jar-file. Now recently I put all of
    the classes, except the main class, in a separate package. And now the
    applet no longer works in Internet Explorer with the Microsoft VM. I
    get a ClassNotFoundException on the main class.
    The applet works fine in Firefox, Opera, and in Intener Explorer with
    the Sun VM.
    The applet I'm testing is here:
    http://www.smorf.nl/smorfde/frames360.html
    I would appreciate your help.

    thanks, Mark.
    Mark, Nov 15, 2005
    #1
    1. Advertising

  2. Mark wrote:

    > The applet I'm testing is here:
    > http://www.smorf.nl/smorfde/frames360.html


    That's a frames based page, and when I try to get
    the applet itself*, I get directed back to the frames
    page.

    * I need to see the HTML source.

    Fix that and I'll help.
    Andrew Thompson, Nov 15, 2005
    #2
    1. Advertising

  3. Mark

    Mark Guest

    Sorry, yes I forgot. I don't like frames but how else can you prevent
    having to reload the applet every time you load another page?
    I have removed the redirection.
    This is the HTML:

    <!DOCTYPE HTML PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <HTML xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
    <HEAD>
    <TITLE>Smorf applet 360x360</TITLE>
    <META NAME="ROBOTS" CONTENT="NOINDEX, NOFOLLOW">
    <META http-equiv="Content-type" content="text/html;
    charset=iso-8859-1" />
    <meta http-equiv="imagetoolbar" content="no" />
    <meta content="TRUE" name="MSSmartTagsPreventParsing" />
    <link rel="stylesheet" type="text/css" href="styles.css" />
    <script language="javascript">
    if(self.location==top.location)self.location="frames360.html";
    </script>
    </HEAD>
    <BODY>
    <APPLET
    code="SmorfApplet.class"
    height=360 width=360
    name="smorf"
    archive="smorfob.jar, jazz3d3.jar, jazz3d3_primitives.jar"
    </APPLET>
    </BODY>
    </HTML>

    anyway I found out creating the package isn't the problem. I put all
    the classes in a single package and jar file, the problem is still
    there.

    Mark.

    On Tue, 15 Nov 2005 21:20:49 GMT, Andrew Thompson
    <> wrote:

    >Mark wrote:
    >
    >> The applet I'm testing is here:
    >> http://www.smorf.nl/smorfde/frames360.html

    >
    >That's a frames based page, and when I try to get
    >the applet itself*, I get directed back to the frames
    >page.
    >
    >* I need to see the HTML source.
    >
    >Fix that and I'll help.
    Mark, Nov 15, 2005
    #3
  4. Mark wrote:

    > Sorry, yes I forgot. I don't like frames but how else can you prevent
    > having to reload the applet every time you load another page?
    > I have removed the redirection.


    Cool.

    > This is the HTML:

    ....
    > <APPLET
    > code="SmorfApplet.class"
    > height=360 width=360
    > name="smorf"
    > archive="smorfob.jar, jazz3d3.jar, jazz3d3_primitives.jar"


    Note that the archive separator is ',', as opposed to ', '.
    There is no space needed, and while user agents (browsers)
    might be smart enough to trim the space character, others may not.
    Remove it for best reliability.

    But...

    > </APPLET>
    > </BODY>
    > </HTML>


    I strongly suspect the problem is that the class has
    accidentally been compiled for a Java class version
    greater than Java 1.1.

    To compile code for an earlier release, you need
    to specify the -target, probably the -source, and
    ideally a -bootclasspath to a 1.1 JVM/JRE.
    <http://java.sun.com/j2se/1.5.0/docs/tooldocs/windows/javac.html#crosscomp-options>

    The trickiest bit is finding a 1.1 VM for the
    bootclasspath, but if you have an IE with the
    MSVM, you are in luck. There is one hiding
    right on your file system.
    Andrew Thompson, Nov 15, 2005
    #4
  5. Mark

    Mark Guest

    Re: Applet no longer works in IE - problem fixed

    Hi Andrew,

    It seems that the source of my problem is the fact that I upgraded
    from Eclipse 2.1.1. to 3.2.0. After testing with the latest working
    version of my applet I found out that the compiler compliance setting
    has to be 1.3 for the applet to work in IE. Default setting is 1.4.
    :-|

    thanks, Mark.


    On Tue, 15 Nov 2005 22:35:10 +0100, Mark <> wrote:

    >Sorry, yes I forgot. I don't like frames but how else can you prevent
    >having to reload the applet every time you load another page?
    >I have removed the redirection.
    >This is the HTML:
    >
    ><!DOCTYPE HTML PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    > "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    ><HTML xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
    ><HEAD>
    ><TITLE>Smorf applet 360x360</TITLE>
    ><META NAME="ROBOTS" CONTENT="NOINDEX, NOFOLLOW">
    ><META http-equiv="Content-type" content="text/html;
    >charset=iso-8859-1" />
    ><meta http-equiv="imagetoolbar" content="no" />
    ><meta content="TRUE" name="MSSmartTagsPreventParsing" />
    ><link rel="stylesheet" type="text/css" href="styles.css" />
    ><script language="javascript">
    > if(self.location==top.location)self.location="frames360.html";
    ></script>
    ></HEAD>
    ><BODY>
    > <APPLET
    > code="SmorfApplet.class"
    > height=360 width=360
    > name="smorf"
    > archive="smorfob.jar, jazz3d3.jar, jazz3d3_primitives.jar"
    > </APPLET>
    ></BODY>
    ></HTML>
    >
    >anyway I found out creating the package isn't the problem. I put all
    >the classes in a single package and jar file, the problem is still
    >there.
    >
    >Mark.
    >
    >On Tue, 15 Nov 2005 21:20:49 GMT, Andrew Thompson
    ><> wrote:
    >
    >>Mark wrote:
    >>
    >>> The applet I'm testing is here:
    >>> http://www.smorf.nl/smorfde/frames360.html

    >>
    >>That's a frames based page, and when I try to get
    >>the applet itself*, I get directed back to the frames
    >>page.
    >>
    >>* I need to see the HTML source.
    >>
    >>Fix that and I'll help.
    Mark, Nov 15, 2005
    #5
  6. Mark

    Mark Guest

    Hi Andrew,

    Thank you! Compiling to an earlier version fixed my problem.
    I never realized there could be a problem with spaces in the applet
    archive parameter, I will fix that.

    regards, Mark.






    On Tue, 15 Nov 2005 22:10:03 GMT, Andrew Thompson
    <> wrote:

    >Mark wrote:
    >
    >> Sorry, yes I forgot. I don't like frames but how else can you prevent
    >> having to reload the applet every time you load another page?
    >> I have removed the redirection.

    >
    >Cool.
    >
    >> This is the HTML:

    >...
    >> <APPLET
    >> code="SmorfApplet.class"
    >> height=360 width=360
    >> name="smorf"
    >> archive="smorfob.jar, jazz3d3.jar, jazz3d3_primitives.jar"

    >
    >Note that the archive separator is ',', as opposed to ', '.
    >There is no space needed, and while user agents (browsers)
    >might be smart enough to trim the space character, others may not.
    >Remove it for best reliability.
    >
    >But...
    >
    >> </APPLET>
    >> </BODY>
    >> </HTML>

    >
    >I strongly suspect the problem is that the class has
    >accidentally been compiled for a Java class version
    >greater than Java 1.1.
    >
    >To compile code for an earlier release, you need
    >to specify the -target, probably the -source, and
    >ideally a -bootclasspath to a 1.1 JVM/JRE.
    ><http://java.sun.com/j2se/1.5.0/docs/tooldocs/windows/javac.html#crosscomp-options>
    >
    >The trickiest bit is finding a 1.1 VM for the
    >bootclasspath, but if you have an IE with the
    >MSVM, you are in luck. There is one hiding
    >right on your file system.
    Mark, Nov 15, 2005
    #6
  7. Mark wrote:

    > Thank you!


    You're welcome.

    >...Compiling to an earlier version fixed my problem.
    > I never realized there could be a problem with spaces in the applet
    > archive parameter,


    I am not saying that ", " will break in any browser,
    but OTOH - you can be sure that "," works.

    >...I will fix that.


    Better safe than sorry.
    Andrew Thompson, Nov 15, 2005
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Cory Nelson
    Replies:
    2
    Views:
    394
    Cory Nelson
    Apr 15, 2004
  2. =?Utf-8?B?QnJ5YW4gWk0=?=
    Replies:
    1
    Views:
    1,143
    =?Utf-8?B?QnJ5YW4gWk0=?=
    May 26, 2005
  3. bb
    Replies:
    2
    Views:
    373
  4. Matt Whiteley

    Import no longer works in Python 2.3.x

    Matt Whiteley, Feb 11, 2004, in forum: Python
    Replies:
    4
    Views:
    294
    Matt Whiteley
    Feb 13, 2004
  5. Replies:
    0
    Views:
    533
Loading...

Share This Page