ASP forbidden on the network

Discussion in 'ASP General' started by J_J, Sep 27, 2005.

  1. J_J

    J_J Guest

    Hi,

    Below is the message I received when I attempted to use a web page on our
    network that makes use of ASP.

    The page cannot be displayed
    You have attempted to execute a CGI, ISAPI, or other executable program from
    a directory that does not allow programs to be executed.
    --------------------------------------------------------------------------------

    Please try the following:

    a.. Contact the Web site administrator if you believe this directory
    should allow execute access.
    HTTP Error 403.1 - Forbidden: Execute access is denied.
    Internet Information Services (IIS)

    --------------------------------------------------------------------------------


    Does that mean that we need to relocate the files where the server allows
    ASP executable commands to function?
    Or can the directories properties be changed so that such executables is
    allowed?

    TIA
    J_J
    J_J, Sep 27, 2005
    #1
    1. Advertising

  2. J_J

    Evertjan. Guest

    J_J wrote on 27 sep 2005 in microsoft.public.inetserver.asp.general:

    > Hi,
    >
    > Below is the message I received when I attempted to use a web page on
    > our network that makes use of ASP.
    >
    > The page cannot be displayed
    > You have attempted to execute a CGI, ISAPI, or other executable
    > program from a directory that does not allow programs to be executed.
    > -----------------------------------------------------------------------
    >
    > Please try the following:
    >
    > a.. Contact the Web site administrator if you believe this directory
    > should allow execute access.
    > HTTP Error 403.1 - Forbidden: Execute access is denied.
    > Internet Information Services (IIS)
    >
    > -----------------------------------------------------------------------
    >
    > Does that mean that we need to relocate the files where the server
    > allows ASP executable commands to function?
    > Or can the directories properties be changed so that such executables
    > is allowed?


    Either ask your administrator, or if you are the one, allow the directory
    involved, or relocate.

    This iis(?) a iis problem, not an asp one, so ideally this is OT.


    --
    Evertjan.
    The Netherlands.
    (Replace all crosses with dots in my emailaddress)
    Evertjan., Sep 27, 2005
    #2
    1. Advertising

  3. J_J

    Terren Guest

    Try these two things (I am assuming you are using IE)

    Go to Tools-->Internet options-->Advanced.
    Under Browsing scroll down to where is says Show friendly Http error
    messages. Make sure this is unticked.

    The try again. This should give you a better idea of what is wrong.

    Then create or copy a file called index.htm into your web app root
    directory C:\Inetpub\wwwroot\$webapp$\.

    This file is your default page, basically is IE doesn't know what to do
    then it will use this page. If it does go to this page know, then it
    means you are trying to call a page that you don't have
    Terren, Sep 27, 2005
    #3
  4. J_J

    J_J Guest

    Thanks Terren,
    Maybe I should have said that I am using an XP.
    Your first suggestion (ticked or unticked) has not changed anything.
    Thus with XP I do not have such a path (Inetpub) on C...I beleive this is
    valid for Windows98 only.
    Regards
    J_J



    "Terren" <> wrote in message
    news:...
    > Try these two things (I am assuming you are using IE)
    >
    > Go to Tools-->Internet options-->Advanced.
    > Under Browsing scroll down to where is says Show friendly Http error
    > messages. Make sure this is unticked.
    >
    > The try again. This should give you a better idea of what is wrong.
    >
    > Then create or copy a file called index.htm into your web app root
    > directory C:\Inetpub\wwwroot\$webapp$\.
    >
    > This file is your default page, basically is IE doesn't know what to do
    > then it will use this page. If it does go to this page know, then it
    > means you are trying to call a page that you don't have
    >
    J_J, Sep 27, 2005
    #4
  5. J_J wrote:
    > Hi,
    >
    > Below is the message I received when I attempted to use a web page on
    > our network that makes use of ASP.
    >
    > The page cannot be displayed
    > You have attempted to execute a CGI, ISAPI, or other executable
    > program from a directory that does not allow programs to be executed.
    > --------------------------------------------------------------------------------
    >
    > Please try the following:
    >
    > a.. Contact the Web site administrator if you believe this directory
    > should allow execute access.
    > HTTP Error 403.1 - Forbidden: Execute access is denied.
    > Internet Information Services (IIS)
    >
    > --------------------------------------------------------------------------------
    >
    >
    > Does that mean that we need to relocate the files where the server
    > allows ASP executable commands to function?


    Not necessarily

    > Or can the directories properties be changed so that such executables
    > is allowed?
    >

    Yes. This is done by using IIS Manager. You can find information about this
    at www.iisfaq.com

    --
    Microsoft MVP - ASP/ASP.NET
    Please reply to the newsgroup. This email account is my spam trap so I
    don't check it very often. If you must reply off-line, then remove the
    "NO SPAM"
    Bob Barrows [MVP], Sep 27, 2005
    #5
  6. J_J

    Prabhat Guest

    "J_J" <> wrote in message
    news:...
    > Hi,
    >
    > Below is the message I received when I attempted to use a web page on our
    > network that makes use of ASP.
    >
    > The page cannot be displayed
    > You have attempted to execute a CGI, ISAPI, or other executable program

    from
    > a directory that does not allow programs to be executed.
    > --------------------------------------------------------------------------

    ------
    >
    > Please try the following:
    >
    > a.. Contact the Web site administrator if you believe this directory
    > should allow execute access.
    > HTTP Error 403.1 - Forbidden: Execute access is denied.
    > Internet Information Services (IIS)
    >
    > --------------------------------------------------------------------------

    ------
    >
    >
    > Does that mean that we need to relocate the files where the server allows
    > ASP executable commands to function?
    > Or can the directories properties be changed so that such executables is
    > allowed?
    >
    > TIA
    > J_J
    >


    Hi,

    Verify the execute permission is set to "Script and Executable" for the
    folder that contains the executables.

    To do this: open ISM and select the website, virtual dir and go the the
    specific folder and see property - Execute Permission.

    Thanks
    Prabhat
    Prabhat, Sep 27, 2005
    #6
  7. J_J

    Danny@Kendal Guest

    "J_J" <> wrote in message
    news:...
    > Hi,
    >
    > Below is the message I received when I attempted to use a web page on our
    > network that makes use of ASP.
    >
    > The page cannot be displayed
    > You have attempted to execute a CGI, ISAPI, or other executable program
    > from a directory that does not allow programs to be executed.


    For WindowsXP running a personal IIS webserver, do the following:

    Control Panel -> Administrative Tools -> IIS WebServer

    Use the folder tree on the left to navigate to where your local website is
    stored.

    Right-click (or left-click if you've swapped the button functions around) on
    the folder then select PROPERTIES

    Look near the bottom of the first tab (Directory), there should be an option
    called "Execute Permissions". Make sure it reads "Scripts only" or "Scripts
    and Executables".

    Did that cure it?
    Danny@Kendal, Sep 27, 2005
    #7
  8. J_J

    J_J Guest

    Thank you so much;
    Evertjan, Terren, Bob, Prabhat and Danny
    You guys are great. I get in touch with our web admin and find out that the
    Server was enabled to run ASP.NET but not ASP. Enabled it and
    ..........everything turned to normal.
    Thank you all
    J_J


    "Danny@Kendal" <> wrote in message
    news:...
    > "J_J" <> wrote in message
    > news:...
    >> Hi,
    >>
    >> Below is the message I received when I attempted to use a web page on our
    >> network that makes use of ASP.
    >>
    >> The page cannot be displayed
    >> You have attempted to execute a CGI, ISAPI, or other executable program
    >> from a directory that does not allow programs to be executed.

    >
    > For WindowsXP running a personal IIS webserver, do the following:
    >
    > Control Panel -> Administrative Tools -> IIS WebServer
    >
    > Use the folder tree on the left to navigate to where your local website is
    > stored.
    >
    > Right-click (or left-click if you've swapped the button functions around)
    > on the folder then select PROPERTIES
    >
    > Look near the bottom of the first tab (Directory), there should be an
    > option called "Execute Permissions". Make sure it reads "Scripts only" or
    > "Scripts and Executables".
    >
    > Did that cure it?
    >
    J_J, Sep 27, 2005
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Patrick Spence
    Replies:
    2
    Views:
    2,277
    Patrick Spence
    Nov 20, 2003
  2. Chianti73
    Replies:
    0
    Views:
    374
    Chianti73
    Dec 12, 2003
  3. Jerry

    403 Access Forbidden, ASP IIS

    Jerry, Feb 19, 2004, in forum: ASP .Net
    Replies:
    2
    Views:
    4,814
    Steven Cheng[MSFT]
    Feb 24, 2004
  4. David Hunt
    Replies:
    4
    Views:
    11,306
    gullsinn
    Oct 4, 2009
  5. Mark J. McGinty

    IIS HTTP 403.1 Forbidden: Execute Access Forbidden

    Mark J. McGinty, Dec 9, 2005, in forum: ASP General
    Replies:
    2
    Views:
    354
    Kyle Peterson
    Dec 9, 2005
Loading...

Share This Page