ASP.NET 2.0 (64bit), IIS 6, Windows Server 2003 (64 bit)

Discussion in 'ASP .Net' started by =?Utf-8?B?QnJpYW4gRGVsYWh1bnR5?=, Jun 13, 2006.

  1. I'm having a bit of a weird problem and I've spent the last few hours
    scouring the web trying to solve this before coming here.

    Here is the problem:
    I get 404 errors for all ASP.NET 2.0 content trying to be served from IIS.

    Setup:
    IIS 6 (64 bit)
    Windows Server 2003 64bit
    ASP.NET 2.0 (64 bit)

    Some Additional Facts:
    Classic-ASP components for IIS not installed.
    ASP.NET is registered with IIS.
    Directory permissions are fine.
    Just .NET 2.0 64 bit on machine (no 1.1 installed)
    It's not the "app_offline.htm" issue.
    File extension mappings (aspx, asmx, ashx, etc) all fine

    What I have tried so far:
    It's not the "app_offline.htm" issue - I have confirmed that. I have
    unregistered ASP.NET from IIS and re-registered it. No difference. When
    ASP.NET is unregistered the files are found and served by IIS (although they
    obviously don't work as ASP.NET is not installed). When ASP.NET is registered
    it's an immediate 404.

    I'm trying to service webservices but I have tried it with simple ASPX file
    with no code behind and just "static" html content - same problem. I've tried
    it with ASPX files with code behind - same problem.

    I've tried removing IIS, restarting machine (even though this is not
    necessary), reinstall IIS, re-register ASP.NET 2 with IIS - no difference.
    Same problem. All the ASPX and ASMX files/projects I have tried work fine on
    IIS 5 on my XP pro dev box.

    I've tried manually recreating the file extension mappings to the 64 bit
    ASP.NET engine
    (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll). That
    didn't work either.

    I've enabled directory browsing to see if IIS itself is even seeing the file
    which I knew it was as when ASP.NET in not registered it does try to serve
    it... anyway, IIS sees it, but when you click on the file - 404. I checked
    the error mappings to ensure it really is a 404 and it is - the log says 404
    too.

    I mapped .html files to the ASP.NET worker process too
    (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll) and when
    mapped to it, they give 404s too.

    And, after doing all this, I again uninstalled and reinstalled IIS and
    re-registered ASP.NET 2.0 and still no joy!

    Anybody have any suggestions?
     
    =?Utf-8?B?QnJpYW4gRGVsYWh1bnR5?=, Jun 13, 2006
    #1
    1. Advertising

  2. Have you enabled ASP.NET 2.0 in IIS 6.0 ?

    You need to enable ASP.NET by opening the IIS Manager
    and scrolling down the left-hand side to "Web Service Extensions",
    click once on it and look on the right-hand panel.

    Click once on the ASP.NET version you want to enable,
    ( in this case 2.0 ) and click the "Allow" button.




    Juan T. Llibre, asp.net MVP
    aspnetfaq.com : http://www.aspnetfaq.com/
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ===================================
    "Brian Delahunty" <> wrote in message
    news:...
    > I'm having a bit of a weird problem and I've spent the last few hours
    > scouring the web trying to solve this before coming here.
    >
    > Here is the problem:
    > I get 404 errors for all ASP.NET 2.0 content trying to be served from IIS.
    >
    > Setup:
    > IIS 6 (64 bit)
    > Windows Server 2003 64bit
    > ASP.NET 2.0 (64 bit)
    >
    > Some Additional Facts:
    > Classic-ASP components for IIS not installed.
    > ASP.NET is registered with IIS.
    > Directory permissions are fine.
    > Just .NET 2.0 64 bit on machine (no 1.1 installed)
    > It's not the "app_offline.htm" issue.
    > File extension mappings (aspx, asmx, ashx, etc) all fine
    >
    > What I have tried so far:
    > It's not the "app_offline.htm" issue - I have confirmed that. I have
    > unregistered ASP.NET from IIS and re-registered it. No difference. When
    > ASP.NET is unregistered the files are found and served by IIS (although they
    > obviously don't work as ASP.NET is not installed). When ASP.NET is registered
    > it's an immediate 404.
    >
    > I'm trying to service webservices but I have tried it with simple ASPX file
    > with no code behind and just "static" html content - same problem. I've tried
    > it with ASPX files with code behind - same problem.
    >
    > I've tried removing IIS, restarting machine (even though this is not
    > necessary), reinstall IIS, re-register ASP.NET 2 with IIS - no difference.
    > Same problem. All the ASPX and ASMX files/projects I have tried work fine on
    > IIS 5 on my XP pro dev box.
    >
    > I've tried manually recreating the file extension mappings to the 64 bit
    > ASP.NET engine
    > (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll). That
    > didn't work either.
    >
    > I've enabled directory browsing to see if IIS itself is even seeing the file
    > which I knew it was as when ASP.NET in not registered it does try to serve
    > it... anyway, IIS sees it, but when you click on the file - 404. I checked
    > the error mappings to ensure it really is a 404 and it is - the log says 404
    > too.
    >
    > I mapped .html files to the ASP.NET worker process too
    > (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll) and when
    > mapped to it, they give 404s too.
    >
    > And, after doing all this, I again uninstalled and reinstalled IIS and
    > re-registered ASP.NET 2.0 and still no joy!
    >
    > Anybody have any suggestions?
     
    Juan T. Llibre, Jun 13, 2006
    #2
    1. Advertising

  3. =?Utf-8?B?QnJpYW4gRGVsYWh1bnR5?=

    mnichols Guest

    Hi,

    If you go to the IIS Manager and select the Web Service Extensions node
    is ASP.NET "allowed"? This is something that can be missed.

    Also, look into aspnet_regiis.exe and it various options (see msdn).

    Windows firewall?

    hth

    mnichols

    Brian Delahunty wrote:
    > I'm having a bit of a weird problem and I've spent the last few hours
    > scouring the web trying to solve this before coming here.
    >
    > Here is the problem:
    > I get 404 errors for all ASP.NET 2.0 content trying to be served from IIS.
    >
    > Setup:
    > IIS 6 (64 bit)
    > Windows Server 2003 64bit
    > ASP.NET 2.0 (64 bit)
    >
    > Some Additional Facts:
    > Classic-ASP components for IIS not installed.
    > ASP.NET is registered with IIS.
    > Directory permissions are fine.
    > Just .NET 2.0 64 bit on machine (no 1.1 installed)
    > It's not the "app_offline.htm" issue.
    > File extension mappings (aspx, asmx, ashx, etc) all fine
    >
    > What I have tried so far:
    > It's not the "app_offline.htm" issue - I have confirmed that. I have
    > unregistered ASP.NET from IIS and re-registered it. No difference. When
    > ASP.NET is unregistered the files are found and served by IIS (although they
    > obviously don't work as ASP.NET is not installed). When ASP.NET is registered
    > it's an immediate 404.
    >
    > I'm trying to service webservices but I have tried it with simple ASPX file
    > with no code behind and just "static" html content - same problem. I've tried
    > it with ASPX files with code behind - same problem.
    >
    > I've tried removing IIS, restarting machine (even though this is not
    > necessary), reinstall IIS, re-register ASP.NET 2 with IIS - no difference.
    > Same problem. All the ASPX and ASMX files/projects I have tried work fine on
    > IIS 5 on my XP pro dev box.
    >
    > I've tried manually recreating the file extension mappings to the 64 bit
    > ASP.NET engine
    > (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll). That
    > didn't work either.
    >
    > I've enabled directory browsing to see if IIS itself is even seeing the file
    > which I knew it was as when ASP.NET in not registered it does try to serve
    > it... anyway, IIS sees it, but when you click on the file - 404. I checked
    > the error mappings to ensure it really is a 404 and it is - the log says 404
    > too.
    >
    > I mapped .html files to the ASP.NET worker process too
    > (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll) and when
    > mapped to it, they give 404s too.
    >
    > And, after doing all this, I again uninstalled and reinstalled IIS and
    > re-registered ASP.NET 2.0 and still no joy!
    >
    > Anybody have any suggestions?
     
    mnichols, Jun 13, 2006
    #3
  4. Yep. Sorry. Forgot to mention that I had enabled it.

    I'm wondering if it has something to do with the whole 64 bit thing.


    "Juan T. Llibre" wrote:

    > Have you enabled ASP.NET 2.0 in IIS 6.0 ?
    >
    > You need to enable ASP.NET by opening the IIS Manager
    > and scrolling down the left-hand side to "Web Service Extensions",
    > click once on it and look on the right-hand panel.
    >
    > Click once on the ASP.NET version you want to enable,
    > ( in this case 2.0 ) and click the "Allow" button.
    >
    >
    >
    >
    > Juan T. Llibre, asp.net MVP
    > aspnetfaq.com : http://www.aspnetfaq.com/
    > asp.net faq : http://asp.net.do/faq/
    > foros de asp.net, en español : http://asp.net.do/foros/
    > ===================================
    > "Brian Delahunty" <> wrote in message
    > news:...
    > > I'm having a bit of a weird problem and I've spent the last few hours
    > > scouring the web trying to solve this before coming here.
    > >
    > > Here is the problem:
    > > I get 404 errors for all ASP.NET 2.0 content trying to be served from IIS.
    > >
    > > Setup:
    > > IIS 6 (64 bit)
    > > Windows Server 2003 64bit
    > > ASP.NET 2.0 (64 bit)
    > >
    > > Some Additional Facts:
    > > Classic-ASP components for IIS not installed.
    > > ASP.NET is registered with IIS.
    > > Directory permissions are fine.
    > > Just .NET 2.0 64 bit on machine (no 1.1 installed)
    > > It's not the "app_offline.htm" issue.
    > > File extension mappings (aspx, asmx, ashx, etc) all fine
    > >
    > > What I have tried so far:
    > > It's not the "app_offline.htm" issue - I have confirmed that. I have
    > > unregistered ASP.NET from IIS and re-registered it. No difference. When
    > > ASP.NET is unregistered the files are found and served by IIS (although they
    > > obviously don't work as ASP.NET is not installed). When ASP.NET is registered
    > > it's an immediate 404.
    > >
    > > I'm trying to service webservices but I have tried it with simple ASPX file
    > > with no code behind and just "static" html content - same problem. I've tried
    > > it with ASPX files with code behind - same problem.
    > >
    > > I've tried removing IIS, restarting machine (even though this is not
    > > necessary), reinstall IIS, re-register ASP.NET 2 with IIS - no difference.
    > > Same problem. All the ASPX and ASMX files/projects I have tried work fine on
    > > IIS 5 on my XP pro dev box.
    > >
    > > I've tried manually recreating the file extension mappings to the 64 bit
    > > ASP.NET engine
    > > (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll). That
    > > didn't work either.
    > >
    > > I've enabled directory browsing to see if IIS itself is even seeing the file
    > > which I knew it was as when ASP.NET in not registered it does try to serve
    > > it... anyway, IIS sees it, but when you click on the file - 404. I checked
    > > the error mappings to ensure it really is a 404 and it is - the log says 404
    > > too.
    > >
    > > I mapped .html files to the ASP.NET worker process too
    > > (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll) and when
    > > mapped to it, they give 404s too.
    > >
    > > And, after doing all this, I again uninstalled and reinstalled IIS and
    > > re-registered ASP.NET 2.0 and still no joy!
    > >
    > > Anybody have any suggestions?

    >
    >
    >
    >
     
    =?Utf-8?B?QnJpYW4gRGVsYWh1bnR5?=, Jun 13, 2006
    #4
  5. ASP.NET is allowed and I'm testing from the local machine.


    "mnichols" wrote:

    > Hi,
    >
    > If you go to the IIS Manager and select the Web Service Extensions node
    > is ASP.NET "allowed"? This is something that can be missed.
    >
    > Also, look into aspnet_regiis.exe and it various options (see msdn).
    >
    > Windows firewall?
    >
    > hth
    >
    > mnichols
    >
    > Brian Delahunty wrote:
    > > I'm having a bit of a weird problem and I've spent the last few hours
    > > scouring the web trying to solve this before coming here.
    > >
    > > Here is the problem:
    > > I get 404 errors for all ASP.NET 2.0 content trying to be served from IIS.
    > >
    > > Setup:
    > > IIS 6 (64 bit)
    > > Windows Server 2003 64bit
    > > ASP.NET 2.0 (64 bit)
    > >
    > > Some Additional Facts:
    > > Classic-ASP components for IIS not installed.
    > > ASP.NET is registered with IIS.
    > > Directory permissions are fine.
    > > Just .NET 2.0 64 bit on machine (no 1.1 installed)
    > > It's not the "app_offline.htm" issue.
    > > File extension mappings (aspx, asmx, ashx, etc) all fine
    > >
    > > What I have tried so far:
    > > It's not the "app_offline.htm" issue - I have confirmed that. I have
    > > unregistered ASP.NET from IIS and re-registered it. No difference. When
    > > ASP.NET is unregistered the files are found and served by IIS (although they
    > > obviously don't work as ASP.NET is not installed). When ASP.NET is registered
    > > it's an immediate 404.
    > >
    > > I'm trying to service webservices but I have tried it with simple ASPX file
    > > with no code behind and just "static" html content - same problem. I've tried
    > > it with ASPX files with code behind - same problem.
    > >
    > > I've tried removing IIS, restarting machine (even though this is not
    > > necessary), reinstall IIS, re-register ASP.NET 2 with IIS - no difference.
    > > Same problem. All the ASPX and ASMX files/projects I have tried work fine on
    > > IIS 5 on my XP pro dev box.
    > >
    > > I've tried manually recreating the file extension mappings to the 64 bit
    > > ASP.NET engine
    > > (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll). That
    > > didn't work either.
    > >
    > > I've enabled directory browsing to see if IIS itself is even seeing the file
    > > which I knew it was as when ASP.NET in not registered it does try to serve
    > > it... anyway, IIS sees it, but when you click on the file - 404. I checked
    > > the error mappings to ensure it really is a 404 and it is - the log says 404
    > > too.
    > >
    > > I mapped .html files to the ASP.NET worker process too
    > > (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll) and when
    > > mapped to it, they give 404s too.
    > >
    > > And, after doing all this, I again uninstalled and reinstalled IIS and
    > > re-registered ASP.NET 2.0 and still no joy!
    > >
    > > Anybody have any suggestions?

    >
     
    =?Utf-8?B?QnJpYW4gRGVsYWh1bnR5?=, Jun 13, 2006
    #5
  6. =?Utf-8?B?QnJpYW4gRGVsYWh1bnR5?=

    mnichols Guest

    A client had similar problems and it was because of folder permissions.

    A few more ideas:

    Check IIS logs: C:\windows\system32\Logfiles
    Check httplogs: C:\WINDOWS\system32\LogFiles\HTTPERR
    Run Filemon from SystemInternals to see if permissions are an issue
    Event viewer?

    hth

    mnichols

    Brian Delahunty wrote:
    > ASP.NET is allowed and I'm testing from the local machine.
    >
    >
    > "mnichols" wrote:
    >
    >> Hi,
    >>
    >> If you go to the IIS Manager and select the Web Service Extensions node
    >> is ASP.NET "allowed"? This is something that can be missed.
    >>
    >> Also, look into aspnet_regiis.exe and it various options (see msdn).
    >>
    >> Windows firewall?
    >>
    >> hth
    >>
    >> mnichols
    >>
    >> Brian Delahunty wrote:
    >>> I'm having a bit of a weird problem and I've spent the last few hours
    >>> scouring the web trying to solve this before coming here.
    >>>
    >>> Here is the problem:
    >>> I get 404 errors for all ASP.NET 2.0 content trying to be served from IIS.
    >>>
    >>> Setup:
    >>> IIS 6 (64 bit)
    >>> Windows Server 2003 64bit
    >>> ASP.NET 2.0 (64 bit)
    >>>
    >>> Some Additional Facts:
    >>> Classic-ASP components for IIS not installed.
    >>> ASP.NET is registered with IIS.
    >>> Directory permissions are fine.
    >>> Just .NET 2.0 64 bit on machine (no 1.1 installed)
    >>> It's not the "app_offline.htm" issue.
    >>> File extension mappings (aspx, asmx, ashx, etc) all fine
    >>>
    >>> What I have tried so far:
    >>> It's not the "app_offline.htm" issue - I have confirmed that. I have
    >>> unregistered ASP.NET from IIS and re-registered it. No difference. When
    >>> ASP.NET is unregistered the files are found and served by IIS (although they
    >>> obviously don't work as ASP.NET is not installed). When ASP.NET is registered
    >>> it's an immediate 404.
    >>>
    >>> I'm trying to service webservices but I have tried it with simple ASPX file
    >>> with no code behind and just "static" html content - same problem. I've tried
    >>> it with ASPX files with code behind - same problem.
    >>>
    >>> I've tried removing IIS, restarting machine (even though this is not
    >>> necessary), reinstall IIS, re-register ASP.NET 2 with IIS - no difference.
    >>> Same problem. All the ASPX and ASMX files/projects I have tried work fine on
    >>> IIS 5 on my XP pro dev box.
    >>>
    >>> I've tried manually recreating the file extension mappings to the 64 bit
    >>> ASP.NET engine
    >>> (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll). That
    >>> didn't work either.
    >>>
    >>> I've enabled directory browsing to see if IIS itself is even seeing the file
    >>> which I knew it was as when ASP.NET in not registered it does try to serve
    >>> it... anyway, IIS sees it, but when you click on the file - 404. I checked
    >>> the error mappings to ensure it really is a 404 and it is - the log says 404
    >>> too.
    >>>
    >>> I mapped .html files to the ASP.NET worker process too
    >>> (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll) and when
    >>> mapped to it, they give 404s too.
    >>>
    >>> And, after doing all this, I again uninstalled and reinstalled IIS and
    >>> re-registered ASP.NET 2.0 and still no joy!
    >>>
    >>> Anybody have any suggestions?
     
    mnichols, Jun 13, 2006
    #6
  7. Nah...I'm very sure this isn't 64-bit related.
    We would have heard many reports by now if it was.

    I know you said that : "ASP.NET is registered with IIS" but
    have you run aspnet_regiis -i from the
    "c:\windows\Microsoft.NET\Framework64\v2.0.50727" directory ?

    ( just to make sure... )

    Also, how are you calling your ASP.NET pages ?

    http://yourserver.com/some.aspx ?
    http://yourserver.com/somevirtualdir/some.aspx ?
    http://yourmachinename/some.aspx ?
    http://yourmachinename/somevirtualdir/some.aspx ?

    I mention this because you say that "when you click on the file - 404",
    and you don't call aspx files by clicking on them.

    Did you mean "click on a link" ?
    But, if you clicked on a link...then your original aspx file *did* load.




    Juan T. Llibre, asp.net MVP
    aspnetfaq.com : http://www.aspnetfaq.com/
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ===================================
    "Brian Delahunty" <> wrote in message
    news:...
    > Yep. Sorry. Forgot to mention that I had enabled it.
    >
    > I'm wondering if it has something to do with the whole 64 bit thing.
    >
    >
    > "Juan T. Llibre" wrote:
    >
    >> Have you enabled ASP.NET 2.0 in IIS 6.0 ?
    >>
    >> You need to enable ASP.NET by opening the IIS Manager
    >> and scrolling down the left-hand side to "Web Service Extensions",
    >> click once on it and look on the right-hand panel.
    >>
    >> Click once on the ASP.NET version you want to enable,
    >> ( in this case 2.0 ) and click the "Allow" button.
    >>
    >>
    >>
    >>
    >> Juan T. Llibre, asp.net MVP
    >> aspnetfaq.com : http://www.aspnetfaq.com/
    >> asp.net faq : http://asp.net.do/faq/
    >> foros de asp.net, en español : http://asp.net.do/foros/
    >> ===================================
    >> "Brian Delahunty" <> wrote in message
    >> news:...
    >> > I'm having a bit of a weird problem and I've spent the last few hours
    >> > scouring the web trying to solve this before coming here.
    >> >
    >> > Here is the problem:
    >> > I get 404 errors for all ASP.NET 2.0 content trying to be served from IIS.
    >> >
    >> > Setup:
    >> > IIS 6 (64 bit)
    >> > Windows Server 2003 64bit
    >> > ASP.NET 2.0 (64 bit)
    >> >
    >> > Some Additional Facts:
    >> > Classic-ASP components for IIS not installed.
    >> > ASP.NET is registered with IIS.
    >> > Directory permissions are fine.
    >> > Just .NET 2.0 64 bit on machine (no 1.1 installed)
    >> > It's not the "app_offline.htm" issue.
    >> > File extension mappings (aspx, asmx, ashx, etc) all fine
    >> >
    >> > What I have tried so far:
    >> > It's not the "app_offline.htm" issue - I have confirmed that. I have
    >> > unregistered ASP.NET from IIS and re-registered it. No difference. When
    >> > ASP.NET is unregistered the files are found and served by IIS (although they
    >> > obviously don't work as ASP.NET is not installed). When ASP.NET is registered
    >> > it's an immediate 404.
    >> >
    >> > I'm trying to service webservices but I have tried it with simple ASPX file
    >> > with no code behind and just "static" html content - same problem. I've tried
    >> > it with ASPX files with code behind - same problem.
    >> >
    >> > I've tried removing IIS, restarting machine (even though this is not
    >> > necessary), reinstall IIS, re-register ASP.NET 2 with IIS - no difference.
    >> > Same problem. All the ASPX and ASMX files/projects I have tried work fine on
    >> > IIS 5 on my XP pro dev box.
    >> >
    >> > I've tried manually recreating the file extension mappings to the 64 bit
    >> > ASP.NET engine
    >> > (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll). That
    >> > didn't work either.
    >> >
    >> > I've enabled directory browsing to see if IIS itself is even seeing the file
    >> > which I knew it was as when ASP.NET in not registered it does try to serve
    >> > it... anyway, IIS sees it, but when you click on the file - 404. I checked
    >> > the error mappings to ensure it really is a 404 and it is - the log says 404
    >> > too.
    >> >
    >> > I mapped .html files to the ASP.NET worker process too
    >> > (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll) and when
    >> > mapped to it, they give 404s too.
    >> >
    >> > And, after doing all this, I again uninstalled and reinstalled IIS and
    >> > re-registered ASP.NET 2.0 and still no joy!
    >> >
    >> > Anybody have any suggestions?
     
    Juan T. Llibre, Jun 13, 2006
    #7
  8. I've checked all the permissions and everything seems fine. I'll turn on
    filemon and keep an eye on it.

    Cheers.

    "mnichols" wrote:

    > A client had similar problems and it was because of folder permissions.
    >
    > A few more ideas:
    >
    > Check IIS logs: C:\windows\system32\Logfiles
    > Check httplogs: C:\WINDOWS\system32\LogFiles\HTTPERR
    > Run Filemon from SystemInternals to see if permissions are an issue
    > Event viewer?
    >
    > hth
    >
    > mnichols
    >
    > Brian Delahunty wrote:
    > > ASP.NET is allowed and I'm testing from the local machine.
    > >
    > >
    > > "mnichols" wrote:
    > >
    > >> Hi,
    > >>
    > >> If you go to the IIS Manager and select the Web Service Extensions node
    > >> is ASP.NET "allowed"? This is something that can be missed.
    > >>
    > >> Also, look into aspnet_regiis.exe and it various options (see msdn).
    > >>
    > >> Windows firewall?
    > >>
    > >> hth
    > >>
    > >> mnichols
    > >>
    > >> Brian Delahunty wrote:
    > >>> I'm having a bit of a weird problem and I've spent the last few hours
    > >>> scouring the web trying to solve this before coming here.
    > >>>
    > >>> Here is the problem:
    > >>> I get 404 errors for all ASP.NET 2.0 content trying to be served from IIS.
    > >>>
    > >>> Setup:
    > >>> IIS 6 (64 bit)
    > >>> Windows Server 2003 64bit
    > >>> ASP.NET 2.0 (64 bit)
    > >>>
    > >>> Some Additional Facts:
    > >>> Classic-ASP components for IIS not installed.
    > >>> ASP.NET is registered with IIS.
    > >>> Directory permissions are fine.
    > >>> Just .NET 2.0 64 bit on machine (no 1.1 installed)
    > >>> It's not the "app_offline.htm" issue.
    > >>> File extension mappings (aspx, asmx, ashx, etc) all fine
    > >>>
    > >>> What I have tried so far:
    > >>> It's not the "app_offline.htm" issue - I have confirmed that. I have
    > >>> unregistered ASP.NET from IIS and re-registered it. No difference. When
    > >>> ASP.NET is unregistered the files are found and served by IIS (although they
    > >>> obviously don't work as ASP.NET is not installed). When ASP.NET is registered
    > >>> it's an immediate 404.
    > >>>
    > >>> I'm trying to service webservices but I have tried it with simple ASPX file
    > >>> with no code behind and just "static" html content - same problem. I've tried
    > >>> it with ASPX files with code behind - same problem.
    > >>>
    > >>> I've tried removing IIS, restarting machine (even though this is not
    > >>> necessary), reinstall IIS, re-register ASP.NET 2 with IIS - no difference.
    > >>> Same problem. All the ASPX and ASMX files/projects I have tried work fine on
    > >>> IIS 5 on my XP pro dev box.
    > >>>
    > >>> I've tried manually recreating the file extension mappings to the 64 bit
    > >>> ASP.NET engine
    > >>> (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll). That
    > >>> didn't work either.
    > >>>
    > >>> I've enabled directory browsing to see if IIS itself is even seeing the file
    > >>> which I knew it was as when ASP.NET in not registered it does try to serve
    > >>> it... anyway, IIS sees it, but when you click on the file - 404. I checked
    > >>> the error mappings to ensure it really is a 404 and it is - the log says 404
    > >>> too.
    > >>>
    > >>> I mapped .html files to the ASP.NET worker process too
    > >>> (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll) and when
    > >>> mapped to it, they give 404s too.
    > >>>
    > >>> And, after doing all this, I again uninstalled and reinstalled IIS and
    > >>> re-registered ASP.NET 2.0 and still no joy!
    > >>>
    > >>> Anybody have any suggestions?

    >
     
    =?Utf-8?B?QnJpYW4gRGVsYWh1bnR5?=, Jun 13, 2006
    #8
  9. =?Utf-8?B?QnJpYW4gRGVsYWh1bnR5?=

    mnichols Guest

    Our client gave 'everyone' permissions on the folder which is really
    wrong but it identified at least that security was an issue. The ASPNET
    user has very few rights by default.

    mnichols

    Brian Delahunty wrote:
    > I've checked all the permissions and everything seems fine. I'll turn on
    > filemon and keep an eye on it.
    >
    > Cheers.
    >
    > "mnichols" wrote:
    >
    >> A client had similar problems and it was because of folder permissions.
    >>
    >> A few more ideas:
    >>
    >> Check IIS logs: C:\windows\system32\Logfiles
    >> Check httplogs: C:\WINDOWS\system32\LogFiles\HTTPERR
    >> Run Filemon from SystemInternals to see if permissions are an issue
    >> Event viewer?
    >>
    >> hth
    >>
    >> mnichols
    >>
    >> Brian Delahunty wrote:
    >>> ASP.NET is allowed and I'm testing from the local machine.
    >>>
    >>>
    >>> "mnichols" wrote:
    >>>
    >>>> Hi,
    >>>>
    >>>> If you go to the IIS Manager and select the Web Service Extensions node
    >>>> is ASP.NET "allowed"? This is something that can be missed.
    >>>>
    >>>> Also, look into aspnet_regiis.exe and it various options (see msdn).
    >>>>
    >>>> Windows firewall?
    >>>>
    >>>> hth
    >>>>
    >>>> mnichols
    >>>>
    >>>> Brian Delahunty wrote:
    >>>>> I'm having a bit of a weird problem and I've spent the last few hours
    >>>>> scouring the web trying to solve this before coming here.
    >>>>>
    >>>>> Here is the problem:
    >>>>> I get 404 errors for all ASP.NET 2.0 content trying to be served from IIS.
    >>>>>
    >>>>> Setup:
    >>>>> IIS 6 (64 bit)
    >>>>> Windows Server 2003 64bit
    >>>>> ASP.NET 2.0 (64 bit)
    >>>>>
    >>>>> Some Additional Facts:
    >>>>> Classic-ASP components for IIS not installed.
    >>>>> ASP.NET is registered with IIS.
    >>>>> Directory permissions are fine.
    >>>>> Just .NET 2.0 64 bit on machine (no 1.1 installed)
    >>>>> It's not the "app_offline.htm" issue.
    >>>>> File extension mappings (aspx, asmx, ashx, etc) all fine
    >>>>>
    >>>>> What I have tried so far:
    >>>>> It's not the "app_offline.htm" issue - I have confirmed that. I have
    >>>>> unregistered ASP.NET from IIS and re-registered it. No difference. When
    >>>>> ASP.NET is unregistered the files are found and served by IIS (although they
    >>>>> obviously don't work as ASP.NET is not installed). When ASP.NET is registered
    >>>>> it's an immediate 404.
    >>>>>
    >>>>> I'm trying to service webservices but I have tried it with simple ASPX file
    >>>>> with no code behind and just "static" html content - same problem. I've tried
    >>>>> it with ASPX files with code behind - same problem.
    >>>>>
    >>>>> I've tried removing IIS, restarting machine (even though this is not
    >>>>> necessary), reinstall IIS, re-register ASP.NET 2 with IIS - no difference.
    >>>>> Same problem. All the ASPX and ASMX files/projects I have tried work fine on
    >>>>> IIS 5 on my XP pro dev box.
    >>>>>
    >>>>> I've tried manually recreating the file extension mappings to the 64 bit
    >>>>> ASP.NET engine
    >>>>> (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll). That
    >>>>> didn't work either.
    >>>>>
    >>>>> I've enabled directory browsing to see if IIS itself is even seeing the file
    >>>>> which I knew it was as when ASP.NET in not registered it does try to serve
    >>>>> it... anyway, IIS sees it, but when you click on the file - 404. I checked
    >>>>> the error mappings to ensure it really is a 404 and it is - the log says 404
    >>>>> too.
    >>>>>
    >>>>> I mapped .html files to the ASP.NET worker process too
    >>>>> (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll) and when
    >>>>> mapped to it, they give 404s too.
    >>>>>
    >>>>> And, after doing all this, I again uninstalled and reinstalled IIS and
    >>>>> re-registered ASP.NET 2.0 and still no joy!
    >>>>>
    >>>>> Anybody have any suggestions?
     
    mnichols, Jun 13, 2006
    #9
  10. Hi Juan,

    Yes, aspnet_regiis.exe -i has been run.. numerous times by now :)

    When I said I was clicking on the files I just meant that when I turned on
    directory browseing and saw the files - just to ensure that IIS itself was
    seeing them - clicking on them didn't work either. I'm normally just entering
    the URL.

    I think it might actually be a permissions thing in IIS. I'll look into it
    in more detail.

    "Juan T. Llibre" wrote:

    > Nah...I'm very sure this isn't 64-bit related.
    > We would have heard many reports by now if it was.
    >
    > I know you said that : "ASP.NET is registered with IIS" but
    > have you run aspnet_regiis -i from the
    > "c:\windows\Microsoft.NET\Framework64\v2.0.50727" directory ?
    >
    > ( just to make sure... )
    >
    > Also, how are you calling your ASP.NET pages ?
    >
    > http://yourserver.com/some.aspx ?
    > http://yourserver.com/somevirtualdir/some.aspx ?
    > http://yourmachinename/some.aspx ?
    > http://yourmachinename/somevirtualdir/some.aspx ?
    >
    > I mention this because you say that "when you click on the file - 404",
    > and you don't call aspx files by clicking on them.
    >
    > Did you mean "click on a link" ?
    > But, if you clicked on a link...then your original aspx file *did* load.
    >
    >
    >
    >
    > Juan T. Llibre, asp.net MVP
    > aspnetfaq.com : http://www.aspnetfaq.com/
    > asp.net faq : http://asp.net.do/faq/
    > foros de asp.net, en español : http://asp.net.do/foros/
    > ===================================
    > "Brian Delahunty" <> wrote in message
    > news:...
    > > Yep. Sorry. Forgot to mention that I had enabled it.
    > >
    > > I'm wondering if it has something to do with the whole 64 bit thing.
    > >
    > >
    > > "Juan T. Llibre" wrote:
    > >
    > >> Have you enabled ASP.NET 2.0 in IIS 6.0 ?
    > >>
    > >> You need to enable ASP.NET by opening the IIS Manager
    > >> and scrolling down the left-hand side to "Web Service Extensions",
    > >> click once on it and look on the right-hand panel.
    > >>
    > >> Click once on the ASP.NET version you want to enable,
    > >> ( in this case 2.0 ) and click the "Allow" button.
    > >>
    > >>
    > >>
    > >>
    > >> Juan T. Llibre, asp.net MVP
    > >> aspnetfaq.com : http://www.aspnetfaq.com/
    > >> asp.net faq : http://asp.net.do/faq/
    > >> foros de asp.net, en español : http://asp.net.do/foros/
    > >> ===================================
    > >> "Brian Delahunty" <> wrote in message
    > >> news:...
    > >> > I'm having a bit of a weird problem and I've spent the last few hours
    > >> > scouring the web trying to solve this before coming here.
    > >> >
    > >> > Here is the problem:
    > >> > I get 404 errors for all ASP.NET 2.0 content trying to be served from IIS.
    > >> >
    > >> > Setup:
    > >> > IIS 6 (64 bit)
    > >> > Windows Server 2003 64bit
    > >> > ASP.NET 2.0 (64 bit)
    > >> >
    > >> > Some Additional Facts:
    > >> > Classic-ASP components for IIS not installed.
    > >> > ASP.NET is registered with IIS.
    > >> > Directory permissions are fine.
    > >> > Just .NET 2.0 64 bit on machine (no 1.1 installed)
    > >> > It's not the "app_offline.htm" issue.
    > >> > File extension mappings (aspx, asmx, ashx, etc) all fine
    > >> >
    > >> > What I have tried so far:
    > >> > It's not the "app_offline.htm" issue - I have confirmed that. I have
    > >> > unregistered ASP.NET from IIS and re-registered it. No difference. When
    > >> > ASP.NET is unregistered the files are found and served by IIS (although they
    > >> > obviously don't work as ASP.NET is not installed). When ASP.NET is registered
    > >> > it's an immediate 404.
    > >> >
    > >> > I'm trying to service webservices but I have tried it with simple ASPX file
    > >> > with no code behind and just "static" html content - same problem. I've tried
    > >> > it with ASPX files with code behind - same problem.
    > >> >
    > >> > I've tried removing IIS, restarting machine (even though this is not
    > >> > necessary), reinstall IIS, re-register ASP.NET 2 with IIS - no difference.
    > >> > Same problem. All the ASPX and ASMX files/projects I have tried work fine on
    > >> > IIS 5 on my XP pro dev box.
    > >> >
    > >> > I've tried manually recreating the file extension mappings to the 64 bit
    > >> > ASP.NET engine
    > >> > (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll). That
    > >> > didn't work either.
    > >> >
    > >> > I've enabled directory browsing to see if IIS itself is even seeing the file
    > >> > which I knew it was as when ASP.NET in not registered it does try to serve
    > >> > it... anyway, IIS sees it, but when you click on the file - 404. I checked
    > >> > the error mappings to ensure it really is a 404 and it is - the log says 404
    > >> > too.
    > >> >
    > >> > I mapped .html files to the ASP.NET worker process too
    > >> > (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll) and when
    > >> > mapped to it, they give 404s too.
    > >> >
    > >> > And, after doing all this, I again uninstalled and reinstalled IIS and
    > >> > re-registered ASP.NET 2.0 and still no joy!
    > >> >
    > >> > Anybody have any suggestions?

    >
    >
    >
     
    =?Utf-8?B?QnJpYW4gRGVsYWh1bnR5?=, Jun 13, 2006
    #10
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. JohnH.
    Replies:
    1
    Views:
    5,258
    Roedy Green
    Dec 22, 2005
  2. Agnes
    Replies:
    2
    Views:
    496
    Juan T. Llibre
    Sep 21, 2006
  3. =?Utf-8?B?U3JpZGhhcg==?=

    running 64 bit web application on 32 bit windows server 2003

    =?Utf-8?B?U3JpZGhhcg==?=, Nov 16, 2006, in forum: ASP .Net
    Replies:
    0
    Views:
    359
    =?Utf-8?B?U3JpZGhhcg==?=
    Nov 16, 2006
  4. Philipp Ringel
    Replies:
    4
    Views:
    3,167
    virtuosity250
    May 21, 2009
  5. Allen Chen [MSFT]
    Replies:
    0
    Views:
    850
    Allen Chen [MSFT]
    Oct 14, 2008
Loading...

Share This Page