ASP.Net 2.0 'Register' Issue

Discussion in 'ASP .Net Web Controls' started by TCook, Jan 8, 2007.

  1. TCook

    TCook Guest

    Hey All,

    The code below worked fine in ASP.Net 2003:

    <%@ Register TagPrefix="CustomValidators" Namespace="CustomValidators"
    Assembly="MyAssembly" %>

    Under VS 2005, I get the following error:

    Could not load file or assembly 'MyAssembly' or one of its dependencies.
    The system cannot find the file specified.

    Any ideas?

    Thanks,

    TC
     
    TCook, Jan 8, 2007
    #1
    1. Advertising

  2. TCook

    Luke Smith Guest

    Have you got the MyAssembly.dll in the bin directory of your web application
    (added it as a Reference in the solution explorer).

    Luke

    "TCook" <> wrote in message
    news:...
    > Hey All,
    >
    > The code below worked fine in ASP.Net 2003:
    >
    > <%@ Register TagPrefix="CustomValidators" Namespace="CustomValidators"
    > Assembly="MyAssembly" %>
    >
    > Under VS 2005, I get the following error:
    >
    > Could not load file or assembly 'MyAssembly' or one of its
    > dependencies. The system cannot find the file specified.
    >
    > Any ideas?
    >
    > Thanks,
    >
    > TC
    >
    >
     
    Luke Smith, Jan 8, 2007
    #2
    1. Advertising

  3. TCook

    TCook Guest

    Hey Luke,

    That's just it. It appears there is a catch 22 here. The 'MyAssembly' is
    the actual name of the web app and this line of code is throwing the error
    which prevents it from compiling.

    Regards,

    Todd



    "Luke Smith" <stuffNOSPAM@lukesmithDOTnet> wrote in message
    news:...
    > Have you got the MyAssembly.dll in the bin directory of your web
    > application (added it as a Reference in the solution explorer).
    >
    > Luke
    >
    > "TCook" <> wrote in message
    > news:...
    >> Hey All,
    >>
    >> The code below worked fine in ASP.Net 2003:
    >>
    >> <%@ Register TagPrefix="CustomValidators" Namespace="CustomValidators"
    >> Assembly="MyAssembly" %>
    >>
    >> Under VS 2005, I get the following error:
    >>
    >> Could not load file or assembly 'MyAssembly' or one of its
    >> dependencies. The system cannot find the file specified.
    >>
    >> Any ideas?
    >>
    >> Thanks,
    >>
    >> TC
    >>
    >>
     
    TCook, Jan 8, 2007
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. TCook

    ASP.Net 2.0 'Register' Issue

    TCook, Jan 8, 2007, in forum: ASP .Net
    Replies:
    2
    Views:
    361
    TCook
    Jan 8, 2007
  2. chandan
    Replies:
    1
    Views:
    556
    Cowboy \(Gregory A. Beamer\)
    Mar 19, 2008
  3. chandan
    Replies:
    2
    Views:
    430
    Teemu Keiski
    Mar 19, 2008
  4. twdo
    Replies:
    1
    Views:
    732
    Juan T. Llibre
    May 25, 2008
  5. chandan

    can I progarmatically register asp.net to IIS

    chandan, Mar 19, 2008, in forum: ASP .Net Web Controls
    Replies:
    1
    Views:
    153
    Murali
    Mar 20, 2008
Loading...

Share This Page