ASP.NET Client Certificate Authentication Problem

Discussion in 'ASP .Net Security' started by EagleRed@HighFlyingBirds.com, Apr 29, 2004.

  1. Guest

    I am implementing an ASP.NET Web application that requires client certificates. I have a standalone certificate server (Windows 2000, SP4). I used it to generate a server certificate and a client certificate. The client certificate is installed in the Trusted Publishers-Enterprise store. I could not install it in the Personal store

    I build a web application using VS.NET 2003 and set the virtual directory to require SSL and client certs

    In IE 6.1 request, "https://localhost/[Virtual Dir.]/[page].aspx". I get the following result

    The page requires a client certificate
    The page you are trying to view requires the use of a client certificate.

    -------------------------------------------------------------------------------

    Please try the following

    Click the Refresh button to try again, if you have installed your client certificate.
    If you believe you should be able to view this directory or page, please contact the Web site administrator by using the e-mail address or phone number listed on the localhost home page.
    HTTP 403.7 - Forbidden: Client certificate require
    Internet Information Service

    -------------------------------------------------------------------------------

    Technical Information (for support personnel

    Background
    This error occurs when the resource you are attempting to access requires your browser to have a Secure Sockets Layer (SSL) client certificate that the server recognizes

    How can I get this to work? Ultimately, client certificates will be generated from a customer certificate server and distributed to a limited community of users of the application who will authenticate via certificates

    I would appreciate guidance on this.
    , Apr 29, 2004
    #1
    1. Advertising

  2. Guest

    One additional piece of information, I have never been prompted to select a client certificate by the browser.
    , Apr 29, 2004
    #2
    1. Advertising

  3. If you have no certificates installed on the client machine, or there are no
    certificates issued by CA's that the server trusts, then you wont be
    prompted.

    Make sure you have a client certificate installed in IE for the user who is
    accessing the site, and preferably have it issued by the same CA that issued
    the server's cert. (This last step isn't necessary, but just makes life
    easier during testing)

    Hope that helps.

    Later'ish
    Craig

    "" <> wrote
    in message news:...
    > One additional piece of information, I have never been prompted to select

    a client certificate by the browser.
    Craig Humphrey, Apr 30, 2004
    #3
  4. Guest

    I have certs install but none in the Personal store. I installed the client cert and took the "automatic" option which placed the cert into the Trusted Publishers store. I could not force it to the personal store. Does it have to be in the personal store? If so, how do I get it there

    Thanks
    Eagle.
    , Apr 30, 2004
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Colin
    Replies:
    1
    Views:
    803
    Masudur
    Jul 14, 2007
  2. Mfenetre
    Replies:
    11
    Views:
    1,594
    Joe Kaplan \(MVP - ADSI\)
    Oct 12, 2005
  3. DerekJMiller1
    Replies:
    5
    Views:
    671
    Guest
    Dec 13, 2006
  4. Colin
    Replies:
    1
    Views:
    147
    Masudur
    Jul 14, 2007
  5. Colin
    Replies:
    0
    Views:
    104
    Colin
    Jul 13, 2007
Loading...

Share This Page