ASP.NET Integrated Windows Authentication

Discussion in 'ASP .Net' started by ABHIJIT B, Mar 3, 2008.

  1. ABHIJIT B

    ABHIJIT B Guest

    Hi,

    We have developed Web Application using ASP.nET 2.0 with C#.The web
    site will be accessed by Intranet users(Within Domain).Currently we
    are using Integrated Windows Authentication.

    I have done following in Web.Config.

    <authentication mode="Windows"/>
    <identity impersonate="true"/>

    In IIS Web Server for web site I have selected only Integrated Windows
    access.

    The problem I am facing whenever I access website using http://10.2.36.61/webanswer/
    The prompt appears asking username and password.

    How can I disable this prompt whenever I connect to website ?

    Kindly help me for same.

    Best Regards,
    Abhijit B
     
    ABHIJIT B, Mar 3, 2008
    #1
    1. Advertising

  2. ABHIJIT B

    Norman Yuan Guest

    From user's Browser (IE), go to "Tools->Options...->Security tab", add the
    website address (http://10.2.36.61/webanswer) to "Trusted Sites", or
    highlight "Local Intranet" and click "Custom Level...", scroll down to "User
    Authentication->User Logon", select "Automatical logon with current user
    name and password".


    "ABHIJIT B" <> wrote in message
    news:...
    > Hi,
    >
    > We have developed Web Application using ASP.nET 2.0 with C#.The web
    > site will be accessed by Intranet users(Within Domain).Currently we
    > are using Integrated Windows Authentication.
    >
    > I have done following in Web.Config.
    >
    > <authentication mode="Windows"/>
    > <identity impersonate="true"/>
    >
    > In IIS Web Server for web site I have selected only Integrated Windows
    > access.
    >
    > The problem I am facing whenever I access website using
    > http://10.2.36.61/webanswer/
    > The prompt appears asking username and password.
    >
    > How can I disable this prompt whenever I connect to website ?
    >
    > Kindly help me for same.
    >
    > Best Regards,
    > Abhijit B
     
    Norman Yuan, Mar 3, 2008
    #2
    1. Advertising

  3. ABHIJIT B

    ABHIJIT B Guest

    Hi Norman,

    Thanks for your reply.

    But still I am getting Login user prompt.

    Kindly help me for same.

    Best Regards,
    Abhijit B

    On Mar 3, 1:19 pm, "Norman Yuan" <> wrote:
    > From user's Browser (IE), go to "Tools->Options...->Security tab", add the
    > website address (http://10.2.36.61/webanswer) to "Trusted Sites", or
    > highlight "Local Intranet" and click "Custom Level...", scroll down to "User
    > Authentication->User Logon", select "Automatical logon with current user
    > name and password".
    >
    > "ABHIJIT B" <> wrote in message
    >
    > news:...
    >
    > > Hi,

    >
    > > We have developed Web Application using ASP.nET 2.0 with C#.The web
    > > site will be accessed by Intranet users(Within Domain).Currently we
    > > are using Integrated Windows Authentication.

    >
    > > I have done following in Web.Config.

    >
    > > <authentication mode="Windows"/>
    > > <identity impersonate="true"/>

    >
    > > In IIS Web Server for web site I have selected only Integrated Windows
    > > access.

    >
    > > The problem I am facing whenever I access website using
    > >http://10.2.36.61/webanswer/
    > > The prompt appears asking username and password.

    >
    > > How can I disable this prompt whenever I connect to website ?

    >
    > > Kindly help me for same.

    >
    > > Best Regards,
    > > Abhijit B
     
    ABHIJIT B, Mar 7, 2008
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Mark
    Replies:
    0
    Views:
    692
  2. Amedee Van Gasse
    Replies:
    2
    Views:
    2,853
    Buddy Ackerman
    Jun 16, 2005
  3. grey
    Replies:
    0
    Views:
    417
  4. Will
    Replies:
    5
    Views:
    2,663
  5. skk
    Replies:
    0
    Views:
    322
Loading...

Share This Page