asp.net killing foreign letters??

Discussion in 'ASP .Net' started by Jerome, Apr 22, 2004.

  1. Jerome

    Jerome Guest

    Hi,

    I've made an input page in asp.net and the records are saved BUT without
    the 'foreign letters' like é, ä, ü and so on!?

    What could be the problem?

    My SQL database accepts these letters without problems, so it has to be
    asp.net who deletes them while inserting the record into the SQL
    database. The field in the database is defined as varchar(250).

    Any help is greatly appreciated!

    Jerome
    Jerome, Apr 22, 2004
    #1
    1. Advertising

  2. Try to define the field as a nvarchar(250)


    George.

    "Jerome" <> wrote in message
    news:...
    > Hi,
    >
    > I've made an input page in asp.net and the records are saved BUT without
    > the 'foreign letters' like é, ä, ü and so on!?
    >
    > What could be the problem?
    >
    > My SQL database accepts these letters without problems, so it has to be
    > asp.net who deletes them while inserting the record into the SQL
    > database. The field in the database is defined as varchar(250).
    >
    > Any help is greatly appreciated!
    >
    > Jerome
    George Ter-Saakov, Apr 22, 2004
    #2
    1. Advertising

  3. Jerome

    Jerome Guest

    Hm, doesn't work with nvarchar(250) neither.
    The special characters don't get saved! :(


    George Ter-Saakov wrote:
    > Try to define the field as a nvarchar(250)
    >
    >
    > George.
    >
    > "Jerome" <> wrote in message
    > news:...
    >
    >>Hi,
    >>
    >>I've made an input page in asp.net and the records are saved BUT without
    >>the 'foreign letters' like é, ä, ü and so on!?
    >>
    >>What could be the problem?
    >>
    >>My SQL database accepts these letters without problems, so it has to be
    >>asp.net who deletes them while inserting the record into the SQL
    >>database. The field in the database is defined as varchar(250).
    >>
    >>Any help is greatly appreciated!
    >>
    >>Jerome

    >
    >
    >
    Jerome, Apr 22, 2004
    #3
  4. Jerome

    Guest Guest

    Have you tried setting breakpoints in your application and step through
    every single line watching where the characters are and where they are not.


    "Jerome" <> wrote in message
    news:O9$...
    > Hm, doesn't work with nvarchar(250) neither.
    > The special characters don't get saved! :(
    >
    >
    > George Ter-Saakov wrote:
    >> Try to define the field as a nvarchar(250)
    >>
    >>
    >> George.
    >>
    >> "Jerome" <> wrote in message
    >> news:...
    >>
    >>>Hi,
    >>>
    >>>I've made an input page in asp.net and the records are saved BUT without
    >>>the 'foreign letters' like é, ä, ü and so on!?
    >>>
    >>>What could be the problem?
    >>>
    >>>My SQL database accepts these letters without problems, so it has to be
    >>>asp.net who deletes them while inserting the record into the SQL
    >>>database. The field in the database is defined as varchar(250).
    >>>
    >>>Any help is greatly appreciated!
    >>>
    >>>Jerome

    >>
    >>
    Guest, Apr 22, 2004
    #4
  5. Jerome

    Jerome Guest

    On the SQL server the field is defined a nvarch(250),
    but in the table in the SQL connection in Dreamweaver 2004 the same
    field is characterized as wchar(250)? But I can't change that there...

    What's this 'wchar'? Doesn't 'wchar' saved special characters?

    Thanks.

    wrote:
    > Have you tried setting breakpoints in your application and step through
    > every single line watching where the characters are and where they are not.
    >
    >
    > "Jerome" <> wrote in message
    > news:O9$...
    >
    >>Hm, doesn't work with nvarchar(250) neither.
    >>The special characters don't get saved! :(
    >>
    >>
    >>George Ter-Saakov wrote:
    >>
    >>>Try to define the field as a nvarchar(250)
    >>>
    >>>
    >>>George.
    >>>
    >>>"Jerome" <> wrote in message
    >>>news:...
    >>>
    >>>
    >>>>Hi,
    >>>>
    >>>>I've made an input page in asp.net and the records are saved BUT without
    >>>>the 'foreign letters' like é, ä, ü and so on!?
    >>>>
    >>>>What could be the problem?
    >>>>
    >>>>My SQL database accepts these letters without problems, so it has to be
    >>>>asp.net who deletes them while inserting the record into the SQL
    >>>>database. The field in the database is defined as varchar(250).
    >>>>
    >>>>Any help is greatly appreciated!
    >>>>
    >>>>Jerome
    >>>
    >>>

    >
    Jerome, Apr 22, 2004
    #5
  6. nvarchar holds Unicode strings
    wchar is the same. I guess different names.

    I am not sure what you mean by "in the table in the SQL connection in
    Dreamweaver 2004" always thought that dreamweaver is the tool to design
    HTML.

    George.


    "Jerome" <> wrote in message
    news:%...
    > On the SQL server the field is defined a nvarch(250),
    > but in the table in the SQL connection in Dreamweaver 2004 the same
    > field is characterized as wchar(250)? But I can't change that there...
    >
    > What's this 'wchar'? Doesn't 'wchar' saved special characters?
    >
    > Thanks.
    >
    > wrote:
    > > Have you tried setting breakpoints in your application and step through
    > > every single line watching where the characters are and where they are

    not.
    > >
    > >
    > > "Jerome" <> wrote in message
    > > news:O9$...
    > >
    > >>Hm, doesn't work with nvarchar(250) neither.
    > >>The special characters don't get saved! :(
    > >>
    > >>
    > >>George Ter-Saakov wrote:
    > >>
    > >>>Try to define the field as a nvarchar(250)
    > >>>
    > >>>
    > >>>George.
    > >>>
    > >>>"Jerome" <> wrote in message
    > >>>news:...
    > >>>
    > >>>
    > >>>>Hi,
    > >>>>
    > >>>>I've made an input page in asp.net and the records are saved BUT

    without
    > >>>>the 'foreign letters' like é, ä, ü and so on!?
    > >>>>
    > >>>>What could be the problem?
    > >>>>
    > >>>>My SQL database accepts these letters without problems, so it has to

    be
    > >>>>asp.net who deletes them while inserting the record into the SQL
    > >>>>database. The field in the database is defined as varchar(250).
    > >>>>
    > >>>>Any help is greatly appreciated!
    > >>>>
    > >>>>Jerome
    > >>>
    > >>>

    > >
    George Ter-Saakov, Apr 22, 2004
    #6
  7. Jerome

    Jerome Guest

    Hi, it seems like the code generated by Dreamweaver to insert the SQL is
    the problem. I've created a test page purely in ASP.NET and there the
    special characters don't disappear!

    So I've turned my attention to Dreamweaver forums, since I'd like to
    still use some of DW's neat features.

    THanks anyhow to all those who answered inhere!

    Jerome


    George Ter-Saakov wrote:
    > nvarchar holds Unicode strings
    > wchar is the same. I guess different names.
    >
    > I am not sure what you mean by "in the table in the SQL connection in
    > Dreamweaver 2004" always thought that dreamweaver is the tool to design
    > HTML.
    >
    > George.
    >
    >
    > "Jerome" <> wrote in message
    > news:%...
    >
    >>On the SQL server the field is defined a nvarch(250),
    >>but in the table in the SQL connection in Dreamweaver 2004 the same
    >>field is characterized as wchar(250)? But I can't change that there...
    >>
    >>What's this 'wchar'? Doesn't 'wchar' saved special characters?
    >>
    >>Thanks.
    >>
    >> wrote:
    >>
    >>>Have you tried setting breakpoints in your application and step through
    >>>every single line watching where the characters are and where they are

    >
    > not.
    >
    >>>
    >>>"Jerome" <> wrote in message
    >>>news:O9$...
    >>>
    >>>
    >>>>Hm, doesn't work with nvarchar(250) neither.
    >>>>The special characters don't get saved! :(
    >>>>
    >>>>
    >>>>George Ter-Saakov wrote:
    >>>>
    >>>>
    >>>>>Try to define the field as a nvarchar(250)
    >>>>>
    >>>>>
    >>>>>George.
    >>>>>
    >>>>>"Jerome" <> wrote in message
    >>>>>news:...
    >>>>>
    >>>>>
    >>>>>
    >>>>>>Hi,
    >>>>>>
    >>>>>>I've made an input page in asp.net and the records are saved BUT

    >
    > without
    >
    >>>>>>the 'foreign letters' like é, ä, ü and so on!?
    >>>>>>
    >>>>>>What could be the problem?
    >>>>>>
    >>>>>>My SQL database accepts these letters without problems, so it has to

    >
    > be
    >
    >>>>>>asp.net who deletes them while inserting the record into the SQL
    >>>>>>database. The field in the database is defined as varchar(250).
    >>>>>>
    >>>>>>Any help is greatly appreciated!
    >>>>>>
    >>>>>>Jerome
    >>>>>
    >>>>>

    >
    >
    Jerome, Apr 23, 2004
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. H5N1
    Replies:
    0
    Views:
    431
  2. Merrigan
    Replies:
    4
    Views:
    558
    Chris
    Dec 14, 2007
  3. Venugopal
    Replies:
    11
    Views:
    1,502
    Tassilo v. Parseval
    Nov 5, 2003
  4. dalei

    foreign letters in alert ()

    dalei, Aug 23, 2005, in forum: Javascript
    Replies:
    3
    Views:
    83
    dalei
    Aug 24, 2005
  5. dalei

    Bringing foreign letters to textarea

    dalei, Aug 27, 2005, in forum: Javascript
    Replies:
    1
    Views:
    75
Loading...

Share This Page