ASP.NET Membership

Discussion in 'ASP .Net Security' started by Marshall, Jun 30, 2006.

  1. Marshall

    Marshall Guest

    Hello,

    I am trying to use the new ASP.NET Membership features with one initial
    issue. I am trying to get things setup using the ASP.NET Configuration menu
    item.

    When I click on ASP.NET Configuration, I get the error: "Unable to connect
    to Visual Studio's Localhost Web Server". I have read several posts about
    this problem and nothing seemed to fix the issue.

    My web site setup using HTTP mode (versus File System mode) and is running
    under the default web site in IIS. My OS is Windows 2003 x64 with the
    lastest updates; I am not running R2. The web site itself works just fine.
    I am at a point where I want to implement the Memership services into the
    site but I cannot get it configured.

    I've already run the aspnet_regsql tool with params of -E -A mrp. I ran
    this on my PC and on one of my development servers. I would prefer to run
    the authentication against the dev server but at this point I won't be
    picky.

    I am using Visual Studio 2005 Team Edition for Software Developers.

    I have also tried creating a new web site (using both HTTP and File System
    modes) and running the ASP.NET Configuration without luck.

    I would greatly appreciate your help.

    Marshall
     
    Marshall, Jun 30, 2006
    #1
    1. Advertising

  2. Hello Marshall,

    I suspect this problem is related to the X64 platform you used. There are
    similar issue reported on X64 and the cause is due to missing ASP.NET
    registry keys. The reason these were missing was because we had installed
    ASP.NET after the IIS metabase setting Enable32bitAppOnWin64 had already
    been set to 1. Because IIS had already been switched to 32-bit mode, the
    ASP.NET installation did not create the ASP.NET registry keys in the
    "64-bit" registry, only in the "32-bit" (redirected) registry. This can be
    fixed by running following commands in a command prompt :

    1. cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs set
    w3svc/AppPools/Enable32bitAppOnWin64 0
    2. %windir%\microsoft.net\framework64\v2.0.50727\aspnet_regiis.exe ¨C i
    3. cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs set
    w3svc/AppPools/Enable32bitAppOnWin64 1
    4. %windir%\microsoft.net\framework\v2.0.50727\aspnet_regiis.exe ¨C i

    What this does is switch IIS to 64-bit mode, run the installation of 64-bit
    ASP.NET, switch back to 32-bit mode and then re-install 32-bit ASP.NET.
    Doing this causes the right registry keys to be created. This allows Visual
    Studio to correctly locate the path to WebDev.WebServer.exe so the Visual
    Studio dev web server can be launched.

    For more information on Windows-32-on-Windows-64 (WOW64) refer:
    http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/4
    05f5bb5-87a3-43d2-8138-54b75db73aa1.mspx

    How to switch between the 32-bit versions of ASP.NET 1.1 and the 64-bit
    version of ASP.NET 2.0 on a 64-bit version of Windows
    http://support.microsoft.com/?id=894435

    Regards,



    Luke Zhang
    Microsoft Online Community Lead

    ==================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.
    ==================================================

    (This posting is provided "AS IS", with no warranties, and confers no
    rights.)
     
    Luke Zhang [MSFT], Jun 30, 2006
    #2
    1. Advertising

  3. Marshall

    Marshall Guest

    Thank you very much Luke! That was what I needed!

    "Luke Zhang [MSFT]" <> wrote in message
    news:a9sI94%...
    > Hello Marshall,
    >
    > I suspect this problem is related to the X64 platform you used. There are
    > similar issue reported on X64 and the cause is due to missing ASP.NET
    > registry keys. The reason these were missing was because we had installed
    > ASP.NET after the IIS metabase setting Enable32bitAppOnWin64 had already
    > been set to 1. Because IIS had already been switched to 32-bit mode, the
    > ASP.NET installation did not create the ASP.NET registry keys in the
    > "64-bit" registry, only in the "32-bit" (redirected) registry. This can
    > be
    > fixed by running following commands in a command prompt :
    >
    > 1. cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs set
    > w3svc/AppPools/Enable32bitAppOnWin64 0
    > 2. %windir%\microsoft.net\framework64\v2.0.50727\aspnet_regiis.exe ¨C i
    > 3. cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs set
    > w3svc/AppPools/Enable32bitAppOnWin64 1
    > 4. %windir%\microsoft.net\framework\v2.0.50727\aspnet_regiis.exe ¨C i
    >
    > What this does is switch IIS to 64-bit mode, run the installation of
    > 64-bit
    > ASP.NET, switch back to 32-bit mode and then re-install 32-bit ASP.NET.
    > Doing this causes the right registry keys to be created. This allows
    > Visual
    > Studio to correctly locate the path to WebDev.WebServer.exe so the Visual
    > Studio dev web server can be launched.
    >
    > For more information on Windows-32-on-Windows-64 (WOW64) refer:
    > http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/4
    > 05f5bb5-87a3-43d2-8138-54b75db73aa1.mspx
    >
    > How to switch between the 32-bit versions of ASP.NET 1.1 and the 64-bit
    > version of ASP.NET 2.0 on a 64-bit version of Windows
    > http://support.microsoft.com/?id=894435
    >
    > Regards,
    >
    >
    >
    > Luke Zhang
    > Microsoft Online Community Lead
    >
    > ==================================================
    > When responding to posts, please "Reply to Group" via your newsreader so
    > that others may learn and benefit from your issue.
    > ==================================================
    >
    > (This posting is provided "AS IS", with no warranties, and confers no
    > rights.)
    >
     
    Marshall, Jun 30, 2006
    #3
  4. Thank you for update. I glad that we find a solution for the issue.

    Regards,

    Luke Zhang
    Microsoft Online Community Lead

    ==================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.
    ==================================================

    (This posting is provided "AS IS", with no warranties, and confers no
    rights.)
     
    Luke Zhang [MSFT], Jul 3, 2006
    #4
  5. Marshall

    Sevinfooter Guest

    Luke,

    This is in response to your posting, which is below.I have the same
    problem, but that solution did not work for me. I am also running
    Win64 and when I try to runthe asp.net configuration module from VS2005
    standard, it says "unable to connect to Visual Studio's localhost web
    server"

    I have uninstalled all of my .net framework, run the scripts as you
    have stated, but nothing seems to work for this. I can debug my
    application, i can run webDev.webserver.exe no problem.

    VS2005 has one localhost process up, bound to port 1662. When the
    "unable to connect" message comes up, it starts another instance of the
    webserver, and binds to port 1739. I have no firewall running, or
    anything else that might block that port, and have run on winX86 many
    times. any ideas?

    Cheers,

    Mark


    Luke Zhang [MSFT] wrote:
    > Hello Marshall,
    >
    > I suspect this problem is related to the X64 platform you used. There are
    > similar issue reported on X64 and the cause is due to missing ASP.NET
    > registry keys. The reason these were missing was because we had installed
    > ASP.NET after the IIS metabase setting Enable32bitAppOnWin64 had already
    > been set to 1. Because IIS had already been switched to 32-bit mode, the
    > ASP.NET installation did not create the ASP.NET registry keys in the
    > "64-bit" registry, only in the "32-bit" (redirected) registry. This can be
    > fixed by running following commands in a command prompt :
    >
    > 1. cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs set
    > w3svc/AppPools/Enable32bitAppOnWin64 0
    > 2. %windir%\microsoft.net\framework64\v2.0.50727\aspnet_regiis.exe ¨C i
    > 3. cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs set
    > w3svc/AppPools/Enable32bitAppOnWin64 1
    > 4. %windir%\microsoft.net\framework\v2.0.50727\aspnet_regiis.exe ¨C i
    >
    > What this does is switch IIS to 64-bit mode, run the installation of 64-bit
    > ASP.NET, switch back to 32-bit mode and then re-install 32-bit ASP.NET.
    > Doing this causes the right registry keys to be created. This allows Visual
    > Studio to correctly locate the path to WebDev.WebServer.exe so the Visual
    > Studio dev web server can be launched.
    >
    > For more information on Windows-32-on-Windows-64 (WOW64) refer:
    > http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/4
    > 05f5bb5-87a3-43d2-8138-54b75db73aa1.mspx
    >
    > How to switch between the 32-bit versions of ASP.NET 1.1 and the 64-bit
    > version of ASP.NET 2.0 on a 64-bit version of Windows
    > http://support.microsoft.com/?id=894435
    >
    > Regards,
    >
    >
    >
    > Luke Zhang
    > Microsoft Online Community Lead
    >
    > ==================================================
    > When responding to posts, please "Reply to Group" via your newsreader so
    > that others may learn and benefit from your issue.
    > ==================================================
    >
    > (This posting is provided "AS IS", with no warranties, and confers no
    > rights.)
     
    Sevinfooter, Jul 21, 2006
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    6
    Views:
    740
  2. Karl
    Replies:
    1
    Views:
    656
  3. Paul
    Replies:
    1
    Views:
    316
    sloan
    Nov 29, 2007
  4. Tino Donderwinkel
    Replies:
    2
    Views:
    767
    Tino Donderwinkel
    Jun 18, 2008
  5. Replies:
    7
    Views:
    211
Loading...

Share This Page