ASP.NET on Win2K3

Discussion in 'ASP .Net' started by =?Utf-8?B?amVzdGVy?=, Apr 12, 2004.

  1. When creating an ASP.NET project on a Win2K3 machine, I get the following prompt

    <START_OF_PROMPT
    The default Web access mode for this project is set to file share but the project folder at 'http://localhost/myProj' cannot be opened with the path 'c:\inetpub\wwwroot\myProj'. The error returned was

    Unable to create Web project 'myProj'. The file path 'c:\inetpub\wwwroot\myProj' does not correspond to the URL 'http://localhost/myProj'. The two need to map to the same server location. HTTP Error 404

    What would you like to do
    <option 1> Retry using a different file share path
    <option 2> Try to open the project with FrontPage Server Extension

    <END_OF_PROMPT

    Whichever option I choose doesn't solve the problem. I've allowed all Web Service Extensions w/in IIS. I've also done workarounds stated in this link http://www.dotnet247.com/247reference/msgs/29/148350.aspx but still no good. Please help. Thanks
    =?Utf-8?B?amVzdGVy?=, Apr 12, 2004
    #1
    1. Advertising

  2. A couple of ideas:

    1. Make sure your inetpub is on C
    2. Check the .webinfo file and make sure it is the proper URL. Try editing
    this to 127.0.0.1, or the machine name or the machine IP (if static).

    FrontPage extensions is a possibility, as it simplifies, but not my first
    choice. On a dev machine, no problem.

    --
    Gregory A. Beamer
    MVP; MCP: +I, SE, SD, DBA

    **********************************************************************
    Think Outside the Box!
    **********************************************************************
    "jester" <> wrote in message
    news:...
    >
    > When creating an ASP.NET project on a Win2K3 machine, I get the following

    prompt:
    >
    > <START_OF_PROMPT>
    > The default Web access mode for this project is set to file share but the

    project folder at 'http://localhost/myProj' cannot be opened with the path
    'c:\inetpub\wwwroot\myProj'. The error returned was:
    >
    > Unable to create Web project 'myProj'. The file path

    'c:\inetpub\wwwroot\myProj' does not correspond to the URL
    'http://localhost/myProj'. The two need to map to the same server location.
    HTTP Error 404:
    >
    > What would you like to do?
    > <option 1> Retry using a different file share path.
    > <option 2> Try to open the project with FrontPage Server Extensions
    >
    > <END_OF_PROMPT>
    >
    >
    > Whichever option I choose doesn't solve the problem. I've allowed all Web

    Service Extensions w/in IIS. I've also done workarounds stated in this link
    http://www.dotnet247.com/247reference/msgs/29/148350.aspx but still no good.
    Please help. Thanks
    Cowboy \(Gregory A. Beamer\), Apr 12, 2004
    #2
    1. Advertising

  3. =?Utf-8?B?amVzdGVy?=

    mikeb Guest

    jester wrote:
    > When creating an ASP.NET project on a Win2K3 machine, I get the following prompt:
    >
    > <START_OF_PROMPT>
    > The default Web access mode for this project is set to file share but the project folder at 'http://localhost/myProj' cannot be opened with the path 'c:\inetpub\wwwroot\myProj'. The error returned was:
    >
    > Unable to create Web project 'myProj'. The file path 'c:\inetpub\wwwroot\myProj' does not correspond to the URL 'http://localhost/myProj'. The two need to map to the same server location. HTTP Error 404:
    >
    > What would you like to do?
    > <option 1> Retry using a different file share path.
    > <option 2> Try to open the project with FrontPage Server Extensions
    >
    > <END_OF_PROMPT>
    >
    >
    > Whichever option I choose doesn't solve the problem. I've allowed all Web Service Extensions w/in IIS. I've also done workarounds stated in this link http://www.dotnet247.com/247reference/msgs/29/148350.aspx but still no good. Please help. Thanks


    See:

    http://support.microsoft.com/default.aspx?scid=kb;en-us;817264

    --
    mikeb
    mikeb, Apr 12, 2004
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Shikari Shambu
    Replies:
    2
    Views:
    457
  2. Eidolon
    Replies:
    4
    Views:
    558
    Ken Cox [Microsoft MVP]
    May 12, 2004
  3. Michael S. Collier

    ASP.NET Performance on Win2k3

    Michael S. Collier, Oct 6, 2004, in forum: ASP .Net
    Replies:
    3
    Views:
    355
    Scott Allen
    Oct 7, 2004
  4. =?Utf-8?B?TmlyYmhv?=

    Win2k3, IIS6, ASP.Net - Server Application Unavailable

    =?Utf-8?B?TmlyYmhv?=, May 10, 2005, in forum: ASP .Net
    Replies:
    4
    Views:
    2,842
    Juan T. Llibre
    May 10, 2005
  5. Adrian Inman
    Replies:
    1
    Views:
    2,845
    Adrian Inman
    Feb 24, 2006
Loading...

Share This Page