ASP.NET process identity does not have read permissions to the global assembly cache

Discussion in 'ASP .Net' started by JerryW, Dec 29, 2003.

  1. JerryW

    JerryW Guest

    I just reinstalled .NET 2003 (after repeated attempts to get ASP.NET
    Web Applications to work). I first did a complete uninstall of .NET
    2003, .NET Framework 1.1, and IIS. I also completely deleted
    c:\inetpub\wwwroot and rebooted before reinstalling.

    I created a new virtual directory from within IIS (e.g. MyWebTest).
    Then I tried to create a new Visual C# ASP.NET Web Application
    pointing to the location http://localhost/MyWebTest. I get an error:

    "The Web server reported the following error when attempting to create
    or open the Web project located at the following URL:
    'http://localhost/MyWebTest'. 'HTTP/1.1 500 Internal Server Error'.

    The Event log has:

    Failed to execute the request because the ASP.NET process identity
    does not have read permissions to the global assembly cache. Error:
    0x8013141a

    I could not see a way to change the permissions on the GAC folder
    (C:\Windows\assembly). As a test, I gave the ASPNET user Administrator
    privileges. That did not work - got the same error.

    Can anyone help me fix this? - Thanks
     
    JerryW, Dec 29, 2003
    #1
    1. Advertising

  2. Hi Jerry,

    If you unregister fusion.dll from a command prompt, you will be able to see
    the permissions on the GAC.

    Jim Cheshire, MCSE, MCSD [MSFT]
    ASP.NET Developer Support

    This post is provided "as-is" and infers no rights.

    --------------------
    >From: (JerryW)
    >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >Subject: ASP.NET process identity does not have read permissions to the

    global assembly cache
    >Date: 29 Dec 2003 08:31:46 -0800
    >Organization: http://groups.google.com
    >Lines: 24
    >Message-ID: <>
    >NNTP-Posting-Host: 24.91.252.243
    >Content-Type: text/plain; charset=ISO-8859-1
    >Content-Transfer-Encoding: 8bit
    >X-Trace: posting.google.com 1072715506 4325 127.0.0.1 (29 Dec 2003

    16:31:46 GMT)
    >X-Complaints-To:
    >NNTP-Posting-Date: Mon, 29 Dec 2003 16:31:46 +0000 (UTC)
    >Path:

    cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfeed00.su
    l.t-online.de!t-online.de!130.59.10.21.MISMATCH!irazu.switch.ch!switch.ch!ne
    ws.maxwell.syr.edu!postnews1.google.com!not-for-mail
    >Xref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:198618
    >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >
    >I just reinstalled .NET 2003 (after repeated attempts to get ASP.NET
    >Web Applications to work). I first did a complete uninstall of .NET
    >2003, .NET Framework 1.1, and IIS. I also completely deleted
    >c:\inetpub\wwwroot and rebooted before reinstalling.
    >
    >I created a new virtual directory from within IIS (e.g. MyWebTest).
    >Then I tried to create a new Visual C# ASP.NET Web Application
    >pointing to the location http://localhost/MyWebTest. I get an error:
    >
    >"The Web server reported the following error when attempting to create
    >or open the Web project located at the following URL:
    >'http://localhost/MyWebTest'. 'HTTP/1.1 500 Internal Server Error'.
    >
    >The Event log has:
    >
    >Failed to execute the request because the ASP.NET process identity
    >does not have read permissions to the global assembly cache. Error:
    >0x8013141a
    >
    >I could not see a way to change the permissions on the GAC folder
    >(C:\Windows\assembly). As a test, I gave the ASPNET user Administrator
    >privileges. That did not work - got the same error.
    >
    >Can anyone help me fix this? - Thanks
    >
     
    Jim Cheshire [MSFT], Dec 29, 2003
    #2
    1. Advertising

  3. JerryW

    JerryW Guest

    Thanks Jim. How do you actually see/change permissions on the GAC? I
    was trying to do this with Windows Explorer (Properties-Security and
    see no Security tab).

    Jerry


    (Jim Cheshire [MSFT]) wrote in message news:<$>...
    > Hi Jerry,
    >
    > If you unregister fusion.dll from a command prompt, you will be able to see
    > the permissions on the GAC.
    >
    > Jim Cheshire, MCSE, MCSD [MSFT]
    > ASP.NET Developer Support
    >
    > This post is provided "as-is" and infers no rights.
    >
    > --------------------
    > >From: (JerryW)
    > >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > >Subject: ASP.NET process identity does not have read permissions to the

    > global assembly cache
    > >Date: 29 Dec 2003 08:31:46 -0800
    > >Organization: http://groups.google.com
    > >Lines: 24
    > >Message-ID: <>
    > >NNTP-Posting-Host: 24.91.252.243
    > >Content-Type: text/plain; charset=ISO-8859-1
    > >Content-Transfer-Encoding: 8bit
    > >X-Trace: posting.google.com 1072715506 4325 127.0.0.1 (29 Dec 2003

    > 16:31:46 GMT)
    > >X-Complaints-To:
    > >NNTP-Posting-Date: Mon, 29 Dec 2003 16:31:46 +0000 (UTC)
    > >Path:

    > cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfeed00.su
    > l.t-online.de!t-online.de!130.59.10.21.MISMATCH!irazu.switch.ch!switch.ch!ne
    > ws.maxwell.syr.edu!postnews1.google.com!not-for-mail
    > >Xref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:198618
    > >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > >
    > >I just reinstalled .NET 2003 (after repeated attempts to get ASP.NET
    > >Web Applications to work). I first did a complete uninstall of .NET
    > >2003, .NET Framework 1.1, and IIS. I also completely deleted
    > >c:\inetpub\wwwroot and rebooted before reinstalling.
    > >
    > >I created a new virtual directory from within IIS (e.g. MyWebTest).
    > >Then I tried to create a new Visual C# ASP.NET Web Application
    > >pointing to the location http://localhost/MyWebTest. I get an error:
    > >
    > >"The Web server reported the following error when attempting to create
    > >or open the Web project located at the following URL:
    > >'http://localhost/MyWebTest'. 'HTTP/1.1 500 Internal Server Error'.
    > >
    > >The Event log has:
    > >
    > >Failed to execute the request because the ASP.NET process identity
    > >does not have read permissions to the global assembly cache. Error:
    > >0x8013141a
    > >
    > >I could not see a way to change the permissions on the GAC folder
    > >(C:\Windows\assembly). As a test, I gave the ASPNET user Administrator
    > >privileges. That did not work - got the same error.
    > >
    > >Can anyone help me fix this? - Thanks
    > >
     
    JerryW, Dec 30, 2003
    #3
  4. Jerry,

    You have to unregister fusion.dll first.

    Jim Cheshire, MCSE, MCSD [MSFT]
    ASP.NET Developer Support

    This post is provided "as-is" and infers no rights.

    --------------------
    >From: (JerryW)
    >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >Subject: Re: ASP.NET process identity does not have read permissions to

    the global assembly cache
    >Date: 30 Dec 2003 04:58:12 -0800
    >Organization: http://groups.google.com
    >Lines: 66
    >Message-ID: <>
    >References: <>

    <$>
    >NNTP-Posting-Host: 24.91.252.243
    >Content-Type: text/plain; charset=ISO-8859-1
    >Content-Transfer-Encoding: 8bit
    >X-Trace: posting.google.com 1072789092 20099 127.0.0.1 (30 Dec 2003

    12:58:12 GMT)
    >X-Complaints-To:
    >NNTP-Posting-Date: Tue, 30 Dec 2003 12:58:12 +0000 (UTC)
    >Path:

    cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!cpmsftngxa09.phx.gbl!TK2MSFTNGP08.
    phx.gbl!newsfeed00.sul.t-online.de!t-online.de!newsfeed.icl.net!newsfeed.fjs
    erv.net!proxad.net!news-out.visi.com!hermes.visi.com!newsfeed2.dallas1.level
    3.net!news.level3.com!postnews1.google.com!not-for-mail
    >Xref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:198826
    >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >
    >Thanks Jim. How do you actually see/change permissions on the GAC? I
    >was trying to do this with Windows Explorer (Properties-Security and
    >see no Security tab).
    >
    >Jerry
    >
    >
    > (Jim Cheshire [MSFT]) wrote in message

    news:<$>...
    >> Hi Jerry,
    >>
    >> If you unregister fusion.dll from a command prompt, you will be able to

    see
    >> the permissions on the GAC.
    >>
    >> Jim Cheshire, MCSE, MCSD [MSFT]
    >> ASP.NET Developer Support
    >>
    >> This post is provided "as-is" and infers no rights.
    >>
    >> --------------------
    >> >From: (JerryW)
    >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >> >Subject: ASP.NET process identity does not have read permissions to the

    >> global assembly cache
    >> >Date: 29 Dec 2003 08:31:46 -0800
    >> >Organization: http://groups.google.com
    >> >Lines: 24
    >> >Message-ID: <>
    >> >NNTP-Posting-Host: 24.91.252.243
    >> >Content-Type: text/plain; charset=ISO-8859-1
    >> >Content-Transfer-Encoding: 8bit
    >> >X-Trace: posting.google.com 1072715506 4325 127.0.0.1 (29 Dec 2003

    >> 16:31:46 GMT)
    >> >X-Complaints-To:
    >> >NNTP-Posting-Date: Mon, 29 Dec 2003 16:31:46 +0000 (UTC)
    >> >Path:

    >>

    cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfeed00.su
    >>

    l.t-online.de!t-online.de!130.59.10.21.MISMATCH!irazu.switch.ch!switch.ch!ne
    >> ws.maxwell.syr.edu!postnews1.google.com!not-for-mail
    >> >Xref: cpmsftngxa07.phx.gbl

    microsoft.public.dotnet.framework.aspnet:198618
    >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >> >
    >> >I just reinstalled .NET 2003 (after repeated attempts to get ASP.NET
    >> >Web Applications to work). I first did a complete uninstall of .NET
    >> >2003, .NET Framework 1.1, and IIS. I also completely deleted
    >> >c:\inetpub\wwwroot and rebooted before reinstalling.
    >> >
    >> >I created a new virtual directory from within IIS (e.g. MyWebTest).
    >> >Then I tried to create a new Visual C# ASP.NET Web Application
    >> >pointing to the location http://localhost/MyWebTest. I get an error:
    >> >
    >> >"The Web server reported the following error when attempting to create
    >> >or open the Web project located at the following URL:
    >> >'http://localhost/MyWebTest'. 'HTTP/1.1 500 Internal Server Error'.
    >> >
    >> >The Event log has:
    >> >
    >> >Failed to execute the request because the ASP.NET process identity
    >> >does not have read permissions to the global assembly cache. Error:
    >> >0x8013141a
    >> >
    >> >I could not see a way to change the permissions on the GAC folder
    >> >(C:\Windows\assembly). As a test, I gave the ASPNET user Administrator
    >> >privileges. That did not work - got the same error.
    >> >
    >> >Can anyone help me fix this? - Thanks
    >> >

    >
     
    Jim Cheshire [MSFT], Dec 30, 2003
    #4
  5. JerryW

    JerryW Guest

    Sorry, didn't say - I did unregister fusion.dll first. In Windows
    Explorer I then right-mouse-click on C:\Windows\assembly and select
    Properties. The dialog has only a General tab - nothing else. I am
    running Windows XP Prof and am logged in as a user with Administrator
    privileges.

    JerryW

    (Jim Cheshire [MSFT]) wrote in message news:<>...
    > Jerry,
    >
    > You have to unregister fusion.dll first.
    >
    > Jim Cheshire, MCSE, MCSD [MSFT]
    > ASP.NET Developer Support
    >
    > This post is provided "as-is" and infers no rights.
    >
    > --------------------
    > >From: (JerryW)
    > >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > >Subject: Re: ASP.NET process identity does not have read permissions to

    > the global assembly cache
    > >Date: 30 Dec 2003 04:58:12 -0800
    > >Organization: http://groups.google.com
    > >Lines: 66
    > >Message-ID: <>
    > >References: <>

    > <$>
    > >NNTP-Posting-Host: 24.91.252.243
    > >Content-Type: text/plain; charset=ISO-8859-1
    > >Content-Transfer-Encoding: 8bit
    > >X-Trace: posting.google.com 1072789092 20099 127.0.0.1 (30 Dec 2003

    > 12:58:12 GMT)
    > >X-Complaints-To:
    > >NNTP-Posting-Date: Tue, 30 Dec 2003 12:58:12 +0000 (UTC)
    > >Path:

    > cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!cpmsftngxa09.phx.gbl!TK2MSFTNGP08.
    > phx.gbl!newsfeed00.sul.t-online.de!t-online.de!newsfeed.icl.net!newsfeed.fjs
    > erv.net!proxad.net!news-out.visi.com!hermes.visi.com!newsfeed2.dallas1.level
    > 3.net!news.level3.com!postnews1.google.com!not-for-mail
    > >Xref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:198826
    > >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > >
    > >Thanks Jim. How do you actually see/change permissions on the GAC? I
    > >was trying to do this with Windows Explorer (Properties-Security and
    > >see no Security tab).
    > >
    > >Jerry
    > >
    > >
    > > (Jim Cheshire [MSFT]) wrote in message

    > news:<$>...
    > >> Hi Jerry,
    > >>
    > >> If you unregister fusion.dll from a command prompt, you will be able to

    > see
    > >> the permissions on the GAC.
    > >>
    > >> Jim Cheshire, MCSE, MCSD [MSFT]
    > >> ASP.NET Developer Support
    > >>
    > >> This post is provided "as-is" and infers no rights.
    > >>
    > >> --------------------
    > >> >From: (JerryW)
    > >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > >> >Subject: ASP.NET process identity does not have read permissions to the

    > global assembly cache
    > >> >Date: 29 Dec 2003 08:31:46 -0800
    > >> >Organization: http://groups.google.com
    > >> >Lines: 24
    > >> >Message-ID: <>
    > >> >NNTP-Posting-Host: 24.91.252.243
    > >> >Content-Type: text/plain; charset=ISO-8859-1
    > >> >Content-Transfer-Encoding: 8bit
    > >> >X-Trace: posting.google.com 1072715506 4325 127.0.0.1 (29 Dec 2003

    > 16:31:46 GMT)
    > >> >X-Complaints-To:
    > >> >NNTP-Posting-Date: Mon, 29 Dec 2003 16:31:46 +0000 (UTC)
    > >> >Path:
    > >>

    > cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfeed00.su
    > >>

    > l.t-online.de!t-online.de!130.59.10.21.MISMATCH!irazu.switch.ch!switch.ch!ne
    > >> ws.maxwell.syr.edu!postnews1.google.com!not-for-mail
    > >> >Xref: cpmsftngxa07.phx.gbl

    > microsoft.public.dotnet.framework.aspnet:198618
    > >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > >> >
    > >> >I just reinstalled .NET 2003 (after repeated attempts to get ASP.NET
    > >> >Web Applications to work). I first did a complete uninstall of .NET
    > >> >2003, .NET Framework 1.1, and IIS. I also completely deleted
    > >> >c:\inetpub\wwwroot and rebooted before reinstalling.
    > >> >
    > >> >I created a new virtual directory from within IIS (e.g. MyWebTest).
    > >> >Then I tried to create a new Visual C# ASP.NET Web Application
    > >> >pointing to the location http://localhost/MyWebTest. I get an error:
    > >> >
    > >> >"The Web server reported the following error when attempting to create
    > >> >or open the Web project located at the following URL:
    > >> >'http://localhost/MyWebTest'. 'HTTP/1.1 500 Internal Server Error'.
    > >> >
    > >> >The Event log has:
    > >> >
    > >> >Failed to execute the request because the ASP.NET process identity
    > >> >does not have read permissions to the global assembly cache. Error:
    > >> >0x8013141a
    > >> >
    > >> >I could not see a way to change the permissions on the GAC folder
    > >> >(C:\Windows\assembly). As a test, I gave the ASPNET user Administrator
    > >> >privileges. That did not work - got the same error.
    > >> >
    > >> >Can anyone help me fix this? - Thanks
    > >> >

    > >
     
    JerryW, Dec 30, 2003
    #5
  6. Jerry,

    Are you running on an NTFS partition? Do you have Simple File Sharing
    enabled?

    Jim Cheshire, MCSE, MCSD [MSFT]
    Microsoft Developer Support
    ASP.NET


    This post is provided as-is with no warranties and confers no rights.


    --------------------
    >From: (JerryW)
    >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >Subject: Re: ASP.NET process identity does not have read permissions to

    the global assembly cache
    >Date: 30 Dec 2003 10:35:48 -0800
    >Organization: http://groups.google.com
    >Lines: 116
    >Message-ID: <>
    >References: <>

    <$>
    <>
    <>
    >NNTP-Posting-Host: 24.91.252.243
    >Content-Type: text/plain; charset=ISO-8859-1
    >Content-Transfer-Encoding: 8bit
    >X-Trace: posting.google.com 1072809348 11095 127.0.0.1 (30 Dec 2003

    18:35:48 GMT)
    >X-Complaints-To:
    >NNTP-Posting-Date: Tue, 30 Dec 2003 18:35:48 +0000 (UTC)
    >Path:

    cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!cpmsftngxa09.phx.gbl!TK2MSFTNGP08.
    phx.gbl!newsfeed00.sul.t-online.de!newsfeed01.sul.t-online.de!t-online.de!fu
    -berlin.de!postnews1.google.com!not-for-mail
    >Xref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:198920
    >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >
    >Sorry, didn't say - I did unregister fusion.dll first. In Windows
    >Explorer I then right-mouse-click on C:\Windows\assembly and select
    >Properties. The dialog has only a General tab - nothing else. I am
    >running Windows XP Prof and am logged in as a user with Administrator
    >privileges.
    >
    >JerryW
    >
    > (Jim Cheshire [MSFT]) wrote in message

    news:<>...
    >> Jerry,
    >>
    >> You have to unregister fusion.dll first.
    >>
    >> Jim Cheshire, MCSE, MCSD [MSFT]
    >> ASP.NET Developer Support
    >>
    >> This post is provided "as-is" and infers no rights.
    >>
    >> --------------------
    >> >From: (JerryW)
    >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >> >Subject: Re: ASP.NET process identity does not have read permissions to

    >> the global assembly cache
    >> >Date: 30 Dec 2003 04:58:12 -0800
    >> >Organization: http://groups.google.com
    >> >Lines: 66
    >> >Message-ID: <>
    >> >References: <>

    >> <$>
    >> >NNTP-Posting-Host: 24.91.252.243
    >> >Content-Type: text/plain; charset=ISO-8859-1
    >> >Content-Transfer-Encoding: 8bit
    >> >X-Trace: posting.google.com 1072789092 20099 127.0.0.1 (30 Dec 2003

    >> 12:58:12 GMT)
    >> >X-Complaints-To:
    >> >NNTP-Posting-Date: Tue, 30 Dec 2003 12:58:12 +0000 (UTC)
    >> >Path:

    >>

    cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!cpmsftngxa09.phx.gbl!TK2MSFTNGP08.
    >>

    phx.gbl!newsfeed00.sul.t-online.de!t-online.de!newsfeed.icl.net!newsfeed.fjs
    >>

    erv.net!proxad.net!news-out.visi.com!hermes.visi.com!newsfeed2.dallas1.level
    >> 3.net!news.level3.com!postnews1.google.com!not-for-mail
    >> >Xref: cpmsftngxa07.phx.gbl

    microsoft.public.dotnet.framework.aspnet:198826
    >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >> >
    >> >Thanks Jim. How do you actually see/change permissions on the GAC? I
    >> >was trying to do this with Windows Explorer (Properties-Security and
    >> >see no Security tab).
    >> >
    >> >Jerry
    >> >
    >> >
    >> > (Jim Cheshire [MSFT]) wrote in message

    >> news:<$>...
    >> >> Hi Jerry,
    >> >>
    >> >> If you unregister fusion.dll from a command prompt, you will be able

    to
    >> see
    >> >> the permissions on the GAC.
    >> >>
    >> >> Jim Cheshire, MCSE, MCSD [MSFT]
    >> >> ASP.NET Developer Support
    >> >>
    >> >> This post is provided "as-is" and infers no rights.
    >> >>
    >> >> --------------------
    >> >> >From: (JerryW)
    >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >> >> >Subject: ASP.NET process identity does not have read permissions to

    the
    >> global assembly cache
    >> >> >Date: 29 Dec 2003 08:31:46 -0800
    >> >> >Organization: http://groups.google.com
    >> >> >Lines: 24
    >> >> >Message-ID: <>
    >> >> >NNTP-Posting-Host: 24.91.252.243
    >> >> >Content-Type: text/plain; charset=ISO-8859-1
    >> >> >Content-Transfer-Encoding: 8bit
    >> >> >X-Trace: posting.google.com 1072715506 4325 127.0.0.1 (29 Dec 2003

    >> 16:31:46 GMT)
    >> >> >X-Complaints-To:
    >> >> >NNTP-Posting-Date: Mon, 29 Dec 2003 16:31:46 +0000 (UTC)
    >> >> >Path:
    >> >>

    >>

    cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfeed00.su
    >> >>

    >>

    l.t-online.de!t-online.de!130.59.10.21.MISMATCH!irazu.switch.ch!switch.ch!ne
    >> >> ws.maxwell.syr.edu!postnews1.google.com!not-for-mail
    >> >> >Xref: cpmsftngxa07.phx.gbl

    >> microsoft.public.dotnet.framework.aspnet:198618
    >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >> >> >
    >> >> >I just reinstalled .NET 2003 (after repeated attempts to get ASP.NET
    >> >> >Web Applications to work). I first did a complete uninstall of .NET
    >> >> >2003, .NET Framework 1.1, and IIS. I also completely deleted
    >> >> >c:\inetpub\wwwroot and rebooted before reinstalling.
    >> >> >
    >> >> >I created a new virtual directory from within IIS (e.g. MyWebTest).
    >> >> >Then I tried to create a new Visual C# ASP.NET Web Application
    >> >> >pointing to the location http://localhost/MyWebTest. I get an error:
    >> >> >
    >> >> >"The Web server reported the following error when attempting to

    create
    >> >> >or open the Web project located at the following URL:
    >> >> >'http://localhost/MyWebTest'. 'HTTP/1.1 500 Internal Server Error'.
    >> >> >
    >> >> >The Event log has:
    >> >> >
    >> >> >Failed to execute the request because the ASP.NET process identity
    >> >> >does not have read permissions to the global assembly cache. Error:
    >> >> >0x8013141a
    >> >> >
    >> >> >I could not see a way to change the permissions on the GAC folder
    >> >> >(C:\Windows\assembly). As a test, I gave the ASPNET user

    Administrator
    >> >> >privileges. That did not work - got the same error.
    >> >> >
    >> >> >Can anyone help me fix this? - Thanks
    >> >> >
    >> >

    >
     
    Jim Cheshire [MSFT], Dec 30, 2003
    #6
  7. JerryW

    JerryW Guest

    Thanks Jim. I am running on an NTFS partition. I did not have Simple
    File Sharing enabled. After enabling Simple File Sharing I did not see
    any difference in the Windows Explorer Properties. What does Simple
    File Sharing have to do with this or my original problem? Please
    explain.

    JerryW

    (Jim Cheshire [MSFT]) wrote in message news:<8a#>...
    > Jerry,
    >
    > Are you running on an NTFS partition? Do you have Simple File Sharing
    > enabled?
    >
    > Jim Cheshire, MCSE, MCSD [MSFT]
    > Microsoft Developer Support
    > ASP.NET
    >
    >
    > This post is provided as-is with no warranties and confers no rights.
    >
    >
    > --------------------
    > >From: (JerryW)
    > >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > >Subject: Re: ASP.NET process identity does not have read permissions to

    > the global assembly cache
    > >Date: 30 Dec 2003 10:35:48 -0800
    > >Organization: http://groups.google.com
    > >Lines: 116
    > >Message-ID: <>
    > >References: <>

    > <$>
    > <>
    > <>
    > >NNTP-Posting-Host: 24.91.252.243
    > >Content-Type: text/plain; charset=ISO-8859-1
    > >Content-Transfer-Encoding: 8bit
    > >X-Trace: posting.google.com 1072809348 11095 127.0.0.1 (30 Dec 2003

    > 18:35:48 GMT)
    > >X-Complaints-To:
    > >NNTP-Posting-Date: Tue, 30 Dec 2003 18:35:48 +0000 (UTC)
    > >Path:

    > cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!cpmsftngxa09.phx.gbl!TK2MSFTNGP08.
    > phx.gbl!newsfeed00.sul.t-online.de!newsfeed01.sul.t-online.de!t-online.de!fu
    > -berlin.de!postnews1.google.com!not-for-mail
    > >Xref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:198920
    > >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > >
    > >Sorry, didn't say - I did unregister fusion.dll first. In Windows
    > >Explorer I then right-mouse-click on C:\Windows\assembly and select
    > >Properties. The dialog has only a General tab - nothing else. I am
    > >running Windows XP Prof and am logged in as a user with Administrator
    > >privileges.
    > >
    > >JerryW
    > >
    > > (Jim Cheshire [MSFT]) wrote in message

    > news:<>...
    > >> Jerry,
    > >>
    > >> You have to unregister fusion.dll first.
    > >>
    > >> Jim Cheshire, MCSE, MCSD [MSFT]
    > >> ASP.NET Developer Support
    > >>
    > >> This post is provided "as-is" and infers no rights.
    > >>
    > >> --------------------
    > >> >From: (JerryW)
    > >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > >> >Subject: Re: ASP.NET process identity does not have read permissions to

    > the global assembly cache
    > >> >Date: 30 Dec 2003 04:58:12 -0800
    > >> >Organization: http://groups.google.com
    > >> >Lines: 66
    > >> >Message-ID: <>
    > >> >References: <>

    > <$>
    > >> >NNTP-Posting-Host: 24.91.252.243
    > >> >Content-Type: text/plain; charset=ISO-8859-1
    > >> >Content-Transfer-Encoding: 8bit
    > >> >X-Trace: posting.google.com 1072789092 20099 127.0.0.1 (30 Dec 2003

    > 12:58:12 GMT)
    > >> >X-Complaints-To:
    > >> >NNTP-Posting-Date: Tue, 30 Dec 2003 12:58:12 +0000 (UTC)
    > >> >Path:
    > >>

    > cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!cpmsftngxa09.phx.gbl!TK2MSFTNGP08.
    > >>

    > phx.gbl!newsfeed00.sul.t-online.de!t-online.de!newsfeed.icl.net!newsfeed.fjs
    > >>

    > erv.net!proxad.net!news-out.visi.com!hermes.visi.com!newsfeed2.dallas1.level
    > >> 3.net!news.level3.com!postnews1.google.com!not-for-mail
    > >> >Xref: cpmsftngxa07.phx.gbl

    > microsoft.public.dotnet.framework.aspnet:198826
    > >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > >> >
    > >> >Thanks Jim. How do you actually see/change permissions on the GAC? I
    > >> >was trying to do this with Windows Explorer (Properties-Security and
    > >> >see no Security tab).
    > >> >
    > >> >Jerry
    > >> >
    > >> >
    > >> > (Jim Cheshire [MSFT]) wrote in message

    > news:<$>...
    > >> >> Hi Jerry,
    > >> >>
    > >> >> If you unregister fusion.dll from a command prompt, you will be able

    > to
    > see
    > >> >> the permissions on the GAC.
    > >> >>
    > >> >> Jim Cheshire, MCSE, MCSD [MSFT]
    > >> >> ASP.NET Developer Support
    > >> >>
    > >> >> This post is provided "as-is" and infers no rights.
    > >> >>
    > >> >> --------------------
    > >> >> >From: (JerryW)
    > >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > >> >> >Subject: ASP.NET process identity does not have read permissions to

    > the
    > global assembly cache
    > >> >> >Date: 29 Dec 2003 08:31:46 -0800
    > >> >> >Organization: http://groups.google.com
    > >> >> >Lines: 24
    > >> >> >Message-ID: <>
    > >> >> >NNTP-Posting-Host: 24.91.252.243
    > >> >> >Content-Type: text/plain; charset=ISO-8859-1
    > >> >> >Content-Transfer-Encoding: 8bit
    > >> >> >X-Trace: posting.google.com 1072715506 4325 127.0.0.1 (29 Dec 2003

    > 16:31:46 GMT)
    > >> >> >X-Complaints-To:
    > >> >> >NNTP-Posting-Date: Mon, 29 Dec 2003 16:31:46 +0000 (UTC)
    > >> >> >Path:
    > >> >>
    > >>

    > cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfeed00.su
    > >> >>
    > >>

    > l.t-online.de!t-online.de!130.59.10.21.MISMATCH!irazu.switch.ch!switch.ch!ne
    > >> >> ws.maxwell.syr.edu!postnews1.google.com!not-for-mail
    > >> >> >Xref: cpmsftngxa07.phx.gbl

    > microsoft.public.dotnet.framework.aspnet:198618
    > >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > >> >> >
    > >> >> >I just reinstalled .NET 2003 (after repeated attempts to get ASP.NET
    > >> >> >Web Applications to work). I first did a complete uninstall of .NET
    > >> >> >2003, .NET Framework 1.1, and IIS. I also completely deleted
    > >> >> >c:\inetpub\wwwroot and rebooted before reinstalling.
    > >> >> >
    > >> >> >I created a new virtual directory from within IIS (e.g. MyWebTest).
    > >> >> >Then I tried to create a new Visual C# ASP.NET Web Application
    > >> >> >pointing to the location http://localhost/MyWebTest. I get an error:
    > >> >> >
    > >> >> >"The Web server reported the following error when attempting to

    > create
    > >> >> >or open the Web project located at the following URL:
    > >> >> >'http://localhost/MyWebTest'. 'HTTP/1.1 500 Internal Server Error'.
    > >> >> >
    > >> >> >The Event log has:
    > >> >> >
    > >> >> >Failed to execute the request because the ASP.NET process identity
    > >> >> >does not have read permissions to the global assembly cache. Error:
    > >> >> >0x8013141a
    > >> >> >
    > >> >> >I could not see a way to change the permissions on the GAC folder
    > >> >> >(C:\Windows\assembly). As a test, I gave the ASPNET user

    > Administrator
    > >> >> >privileges. That did not work - got the same error.
    > >> >> >
    > >> >> >Can anyone help me fix this? - Thanks
    > >> >> >
    > >> >

    > >
     
    JerryW, Dec 31, 2003
    #7
  8. Jerry,

    If Simple File Sharing is enabled, you won't have a Security tab.

    Jim Cheshire, MCSE, MCSD [MSFT]
    Microsoft Developer Support
    ASP.NET


    This post is provided as-is with no warranties and confers no rights.

    --------------------
    >From: (JerryW)
    >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >Subject: Re: ASP.NET process identity does not have read permissions to

    the global assembly cache
    >Date: 30 Dec 2003 18:43:54 -0800
    >Organization: http://groups.google.com
    >Lines: 177
    >Message-ID: <>
    >References: <>

    <$>
    <>
    <>
    <>
    <8a#>
    >NNTP-Posting-Host: 24.91.252.243
    >Content-Type: text/plain; charset=ISO-8859-1
    >Content-Transfer-Encoding: 8bit
    >X-Trace: posting.google.com 1072838635 11689 127.0.0.1 (31 Dec 2003

    02:43:55 GMT)
    >X-Complaints-To:
    >NNTP-Posting-Date: Wed, 31 Dec 2003 02:43:55 +0000 (UTC)
    >Path:

    cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfeed00.su
    l.t-online.de!t-online.de!newsfeed.icl.net!newsfeed.fjserv.net!news.maxwell.
    syr.edu!postnews1.google.com!not-for-mail
    >Xref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:199016
    >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >
    >Thanks Jim. I am running on an NTFS partition. I did not have Simple
    >File Sharing enabled. After enabling Simple File Sharing I did not see
    >any difference in the Windows Explorer Properties. What does Simple
    >File Sharing have to do with this or my original problem? Please
    >explain.
    >
    >JerryW
    >
    > (Jim Cheshire [MSFT]) wrote in message

    news:<8a#>...
    >> Jerry,
    >>
    >> Are you running on an NTFS partition? Do you have Simple File Sharing
    >> enabled?
    >>
    >> Jim Cheshire, MCSE, MCSD [MSFT]
    >> Microsoft Developer Support
    >> ASP.NET
    >>
    >>
    >> This post is provided as-is with no warranties and confers no rights.
    >>
    >>
    >> --------------------
    >> >From: (JerryW)
    >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >> >Subject: Re: ASP.NET process identity does not have read permissions to

    >> the global assembly cache
    >> >Date: 30 Dec 2003 10:35:48 -0800
    >> >Organization: http://groups.google.com
    >> >Lines: 116
    >> >Message-ID: <>
    >> >References: <>

    >> <$>
    >> <>
    >> <>
    >> >NNTP-Posting-Host: 24.91.252.243
    >> >Content-Type: text/plain; charset=ISO-8859-1
    >> >Content-Transfer-Encoding: 8bit
    >> >X-Trace: posting.google.com 1072809348 11095 127.0.0.1 (30 Dec 2003

    >> 18:35:48 GMT)
    >> >X-Complaints-To:
    >> >NNTP-Posting-Date: Tue, 30 Dec 2003 18:35:48 +0000 (UTC)
    >> >Path:

    >>

    cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!cpmsftngxa09.phx.gbl!TK2MSFTNGP08.
    >>

    phx.gbl!newsfeed00.sul.t-online.de!newsfeed01.sul.t-online.de!t-online.de!fu
    >> -berlin.de!postnews1.google.com!not-for-mail
    >> >Xref: cpmsftngxa07.phx.gbl

    microsoft.public.dotnet.framework.aspnet:198920
    >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >> >
    >> >Sorry, didn't say - I did unregister fusion.dll first. In Windows
    >> >Explorer I then right-mouse-click on C:\Windows\assembly and select
    >> >Properties. The dialog has only a General tab - nothing else. I am
    >> >running Windows XP Prof and am logged in as a user with Administrator
    >> >privileges.
    >> >
    >> >JerryW
    >> >
    >> > (Jim Cheshire [MSFT]) wrote in message

    >> news:<>...
    >> >> Jerry,
    >> >>
    >> >> You have to unregister fusion.dll first.
    >> >>
    >> >> Jim Cheshire, MCSE, MCSD [MSFT]
    >> >> ASP.NET Developer Support
    >> >>
    >> >> This post is provided "as-is" and infers no rights.
    >> >>
    >> >> --------------------
    >> >> >From: (JerryW)
    >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >> >> >Subject: Re: ASP.NET process identity does not have read permissions

    to
    >> the global assembly cache
    >> >> >Date: 30 Dec 2003 04:58:12 -0800
    >> >> >Organization: http://groups.google.com
    >> >> >Lines: 66
    >> >> >Message-ID: <>
    >> >> >References: <>

    >> <$>
    >> >> >NNTP-Posting-Host: 24.91.252.243
    >> >> >Content-Type: text/plain; charset=ISO-8859-1
    >> >> >Content-Transfer-Encoding: 8bit
    >> >> >X-Trace: posting.google.com 1072789092 20099 127.0.0.1 (30 Dec 2003

    >> 12:58:12 GMT)
    >> >> >X-Complaints-To:
    >> >> >NNTP-Posting-Date: Tue, 30 Dec 2003 12:58:12 +0000 (UTC)
    >> >> >Path:
    >> >>

    >>

    cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!cpmsftngxa09.phx.gbl!TK2MSFTNGP08.
    >> >>

    >>

    phx.gbl!newsfeed00.sul.t-online.de!t-online.de!newsfeed.icl.net!newsfeed.fjs
    >> >>

    >>

    erv.net!proxad.net!news-out.visi.com!hermes.visi.com!newsfeed2.dallas1.level
    >> >> 3.net!news.level3.com!postnews1.google.com!not-for-mail
    >> >> >Xref: cpmsftngxa07.phx.gbl

    >> microsoft.public.dotnet.framework.aspnet:198826
    >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >> >> >
    >> >> >Thanks Jim. How do you actually see/change permissions on the GAC? I
    >> >> >was trying to do this with Windows Explorer (Properties-Security and
    >> >> >see no Security tab).
    >> >> >
    >> >> >Jerry
    >> >> >
    >> >> >
    >> >> > (Jim Cheshire [MSFT]) wrote in message

    >> news:<$>...
    >> >> >> Hi Jerry,
    >> >> >>
    >> >> >> If you unregister fusion.dll from a command prompt, you will be

    able
    >> to
    >> see
    >> >> >> the permissions on the GAC.
    >> >> >>
    >> >> >> Jim Cheshire, MCSE, MCSD [MSFT]
    >> >> >> ASP.NET Developer Support
    >> >> >>
    >> >> >> This post is provided "as-is" and infers no rights.
    >> >> >>
    >> >> >> --------------------
    >> >> >> >From: (JerryW)
    >> >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >> >> >> >Subject: ASP.NET process identity does not have read permissions

    to
    >> the
    >> global assembly cache
    >> >> >> >Date: 29 Dec 2003 08:31:46 -0800
    >> >> >> >Organization: http://groups.google.com
    >> >> >> >Lines: 24
    >> >> >> >Message-ID: <>
    >> >> >> >NNTP-Posting-Host: 24.91.252.243
    >> >> >> >Content-Type: text/plain; charset=ISO-8859-1
    >> >> >> >Content-Transfer-Encoding: 8bit
    >> >> >> >X-Trace: posting.google.com 1072715506 4325 127.0.0.1 (29 Dec

    2003
    >> 16:31:46 GMT)
    >> >> >> >X-Complaints-To:
    >> >> >> >NNTP-Posting-Date: Mon, 29 Dec 2003 16:31:46 +0000 (UTC)
    >> >> >> >Path:
    >> >> >>
    >> >>

    >>

    cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfeed00.su
    >> >> >>
    >> >>

    >>

    l.t-online.de!t-online.de!130.59.10.21.MISMATCH!irazu.switch.ch!switch.ch!ne
    >> >> >> ws.maxwell.syr.edu!postnews1.google.com!not-for-mail
    >> >> >> >Xref: cpmsftngxa07.phx.gbl

    >> microsoft.public.dotnet.framework.aspnet:198618
    >> >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >> >> >> >
    >> >> >> >I just reinstalled .NET 2003 (after repeated attempts to get

    ASP.NET
    >> >> >> >Web Applications to work). I first did a complete uninstall of

    .NET
    >> >> >> >2003, .NET Framework 1.1, and IIS. I also completely deleted
    >> >> >> >c:\inetpub\wwwroot and rebooted before reinstalling.
    >> >> >> >
    >> >> >> >I created a new virtual directory from within IIS (e.g.

    MyWebTest).
    >> >> >> >Then I tried to create a new Visual C# ASP.NET Web Application
    >> >> >> >pointing to the location http://localhost/MyWebTest. I get an

    error:
    >> >> >> >
    >> >> >> >"The Web server reported the following error when attempting to

    >> create
    >> >> >> >or open the Web project located at the following URL:
    >> >> >> >'http://localhost/MyWebTest'. 'HTTP/1.1 500 Internal Server

    Error'.
    >> >> >> >
    >> >> >> >The Event log has:
    >> >> >> >
    >> >> >> >Failed to execute the request because the ASP.NET process identity
    >> >> >> >does not have read permissions to the global assembly cache.

    Error:
    >> >> >> >0x8013141a
    >> >> >> >
    >> >> >> >I could not see a way to change the permissions on the GAC folder
    >> >> >> >(C:\Windows\assembly). As a test, I gave the ASPNET user

    >> Administrator
    >> >> >> >privileges. That did not work - got the same error.
    >> >> >> >
    >> >> >> >Can anyone help me fix this? - Thanks
    >> >> >> >
    >> >> >
    >> >

    >
     
    Jim Cheshire [MSFT], Dec 31, 2003
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. JerryW
    Replies:
    2
    Views:
    3,834
    JerryW
    Dec 29, 2003
  2. c
    Replies:
    0
    Views:
    499
  3. Michael Neumann
    Replies:
    1
    Views:
    3,644
    Yuan Ren[MSFT]
    Jan 6, 2006
  4. Michael Neumann
    Replies:
    1
    Views:
    545
    Yuan Ren[MSFT]
    Jan 9, 2006
  5. Replies:
    3
    Views:
    29,717
    lsandler
    Feb 21, 2011
Loading...

Share This Page