ASP.NET stopped working

Discussion in 'ASP .Net' started by =?Utf-8?B?TmFkYXYgUG9wcGxld2VsbA==?=, Jun 10, 2005.

  1. Hi everybody,

    I've got a very strange problem:
    I'm developing asp.net applications with VS 2003.
    This morning suddenly I get this error message:

    Server Application Unavailable
    The web application you are attempting to access on this web server is
    currently unavailable. Please hit the "Refresh" button in your web browser
    to retry your request.

    Administrator Note: An error message detailing the cause of this specific
    request failure can be found in the application event log of the web server.
    Please review this log entry to discover what caused this error to occur.

    The event log shows:
    aspnet_wp.exe could not be started. The error code for the failure is
    80070545. This error can be caused when the worker process account has
    insufficient rights to read the .NET Framework files. Please ensure that the
    ..NET Framework is correctly installed and that the ACLs on the installation
    directory allow access to the configured account.

    my website is set to run under the ASPNET account,
    and I checked to make sure it has full permissions to
    C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\Temporary ASP.NET Files

    Nothing changed on my computer between yesterday & today,
    So I have no Idea why this would suddenly happen.

    My OS is Windows XP sp1.

    Thanks
    Nadav
     
    =?Utf-8?B?TmFkYXYgUG9wcGxld2VsbA==?=, Jun 10, 2005
    #1
    1. Advertising

  2. =?Utf-8?B?TmFkYXYgUG9wcGxld2VsbA==?=

    Guest

    Strange indeed. I bet you already tried a restart. Maybe windows downloaded
    a patch in the background? You can check this in the config screen for installed
    programs.


    Cheers,
    Tom Pester

    > Hi everybody,
    >
    > I've got a very strange problem:
    > I'm developing asp.net applications with VS 2003.
    > This morning suddenly I get this error message:
    > Server Application Unavailable The web application you are attempting
    > to access on this web server is currently unavailable. Please hit the
    > "Refresh" button in your web browser to retry your request.
    >
    > Administrator Note: An error message detailing the cause of this
    > specific request failure can be found in the application event log of
    > the web server. Please review this log entry to discover what caused
    > this error to occur.
    >
    > The event log shows:
    > aspnet_wp.exe could not be started. The error code for the failure is
    > 80070545. This error can be caused when the worker process account has
    > insufficient rights to read the .NET Framework files. Please ensure
    > that the
    > .NET Framework is correctly installed and that the ACLs on the
    > installation
    > directory allow access to the configured account.
    > my website is set to run under the ASPNET account,
    > and I checked to make sure it has full permissions to
    > C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\Temporary ASP.NET Files
    > Nothing changed on my computer between yesterday & today, So I have no
    > Idea why this would suddenly happen.
    >
    > My OS is Windows XP sp1.
    >
    > Thanks Nadav
    >
     
    , Jun 10, 2005
    #2
    1. Advertising

  3. Nadav,

    As mentioned above, a restart would be a good idea. You can even do an
    'iisreset' from the command prompt to simply reset the IIS service.
    This in turn should clear up any possible memory leaks that may have
    caused the service to either stop responding, or stop altogether.
    Usually it says the service is running in this instance, however, it is
    utilizing quite a bit of memory.

    If you still have the issue after an 'iisreset', a complete restart
    sounds like the best solution. It is often times frustrating when
    something works one day and simple ceases the next without any
    reasonable explanation. We have all experienced that before, so please
    keep us informed and we will try to aid you in your progress.

    Are you running indexing service by chance? I've experienced some odd
    behaviors at times when it locks files at certain intervals for
    indexing. If so, possibly stop the service for a termporary period and
    once again try to run the application.

    Aaron
     
    Aaron Corcoran, Jun 10, 2005
    #3
  4. Hi tom,
    I've did a restart, no change.
    My windows is set to download updates, but not to install them untill I
    manually do it, so it should not have updated anything.

    So for Now, I'm stuck.
    This is very irrigating. One of the reasons I haven't install SP2 was
    because I was afraid something like this would happen.
    And now it happened anyway.
    Nadav
     
    =?Utf-8?B?TmFkYXYgUG9wcGxld2VsbA==?=, Jun 14, 2005
    #4
  5. Hi Nadav,

    The problem you encountered is a common issue and many other ones also have
    encountered. Based on my experience, it is possibly caused by some
    anti-virus software or other 3rd party tools, is there any existing
    similiar sotwares running on your box?

    Don't worry, we can still try the following troubleshooting steps:
    1. using the
    aspnet_regiis -u
    aspnet_regiis -i

    commands to uninstall and reinstall the ASP.NET on your machine. Then, put
    a very simple helloworld aspx page (no codebehind) under your IIS's default
    site's root to see whether it works.

    2. If still getting the error ( and the same access permission error of
    worker process in eventlog), we can try running the page again and this
    time use the filemon tool to monitor the file accessing status. If there
    did exist any permission denied error of worker process when accessing any
    certain files, we can capture it in filemon.

    Please have a test to see whether it can help find any clues. If any other
    finding, please also feel free to pos there.

    Thanks,

    Steven Cheng
    Microsoft Online Support

    Get Secure! www.microsoft.com/security
    (This posting is provided "AS IS", with no warranties, and confers no
    rights.)
     
    Steven Cheng[MSFT], Jun 14, 2005
    #5
  6. Hi Steven,

    I unregistered & reregistered the asp.net. No change.

    I created a simple aspx page (an html page saved with .aspx extention).
    can't run it. get same problem.

    What exactly am I suppossed to look for with the filemon tool?

    Nadav
     
    =?Utf-8?B?TmFkYXYgUG9wcGxld2VsbA==?=, Jun 15, 2005
    #6
  7. Hi Aaron,

    I've stopped and started the Web Site from the IIS console,
    And I've restarted the computer. No change.

    I do NOT run Indexing service, so that's not the problem.

    Thanks Anyway,
    Nadav

    "Aaron Corcoran" wrote:


    > utilizing quite a bit of memory.
    >
    > If you still have the issue after an 'iisreset', a complete restart
    > sounds like the best solution. It is often times frustrating when
    > something works one day and simple ceases the next without any
    > reasonable explanation. We have all experienced that before, so please
    > keep us informed and we will try to aid you in your progress.
    >
    > Are you running indexing service by chance? I've experienced some odd
    > behaviors at times when it locks files at certain intervals for
    > indexing. If so, possibly stop the service for a termporary period and
    > once again try to run the application.
    >
    > Aaron
    >
    >
     
    =?Utf-8?B?TmFkYXYgUG9wcGxld2VsbA==?=, Jun 15, 2005
    #7
  8. Hi Nadav,

    Since the error message in your eventlog indicate that there're access
    denied error during your asp.net workerprocess's startup time, so I think
    we need to pay attention to those access failures on the ASP.NET/.net
    related configuration/ cacheing folder, such as the machine.config's file
    and ASP.NET's temporary file folder.

    Hope helps. Thanks,


    Steven Cheng
    Microsoft Online Support

    Get Secure! www.microsoft.com/security
    (This posting is provided "AS IS", with no warranties, and confers no
    rights.)
     
    Steven Cheng[MSFT], Jun 16, 2005
    #8
  9. Hi Steven,

    I've run filemon.

    the only error I get that seems to have any connection to our problem is

    20:43:56 inetinfo.exe:1364 OPEN C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspnet_wp.exe.Manifest NOT FOUND Options: Open Access: All
    but as far as I know aspnet_wp.exe never had a manifest file.
    I even looked at another computer in our company to see if there is an
    manifest file there and there isn't.
    So I don't know what it going on here.

    Nadav

    "Steven Cheng[MSFT]" wrote:

    > Hi Nadav,
    >
    > Since the error message in your eventlog indicate that there're access
    > denied error during your asp.net workerprocess's startup time, so I think
    > we need to pay attention to those access failures on the ASP.NET/.net
    > related configuration/ cacheing folder, such as the machine.config's file
    > and ASP.NET's temporary file folder.
    >
    > Hope helps. Thanks,
    >
    >
    > Steven Cheng
    > Microsoft Online Support
    >
    > Get Secure! www.microsoft.com/security
    > (This posting is provided "AS IS", with no warranties, and confers no
    > rights.)
    >
    >
     
    =?Utf-8?B?TmFkYXYgUG9wcGxld2VsbA==?=, Jun 16, 2005
    #9
  10. Thanks for your response Nadav,

    So is the
    ===========
    aspnet_wp.exe could not be started. The error code for the failure is
    80070545. This error can be caused when the worker process account has
    insufficient rights to read the .NET Framework files. Please ensure that
    the
    NET Framework is correctly installed and that the ACLs on the installation
    directory allow access to the configured account.
    ============
    event entriy still occurring in your dev box's eventlog or is there any
    other access denied info? If so, I think it is still likely a security
    setting issue. We can try checking the security setting by the following
    means:

    1. Locate the .net framework's machine.config file on your xp box (under
    the .net framework's installation folder) and then lookup the
    <processModel> setting in machine.config and check what's your current
    setting for the "userName" and "password" attributes, by default they
    should be "Machine" and "AutoGenerate", if you're specifying a custom
    account, that could be the problem.

    2. If the above setting is as default setting( using userName="Machine" and
    password="AutoGenerate"), please try changing it to userName="SYSTEM"
    password remain "AutoGenerate". Save the machine.config and perform a
    "IISreset" for your box to let the modification take effect. After that,
    try running your application or that simple helloworld page(under default
    site root) again to see whether you still get Server Application
    Unavailable or access denied event.

    If there're any thing unclear, please feel free to post here. Thanks,


    Steven Cheng
    Microsoft Online Support

    Get Secure! www.microsoft.com/security
    (This posting is provided "AS IS", with no warranties, and confers no
    rights.)
     
    Steven Cheng[MSFT], Jun 20, 2005
    #10
  11. Hi Steven,

    It Works!
    changing the userName setting to "SYSTEM" solved the problem!

    thanks! this thing have been driving me crazy...

    Nadav
     
    =?Utf-8?B?TmFkYXYgUG9wcGxld2VsbA==?=, Jun 20, 2005
    #11
  12. Hi Nadav,

    Really good news! However, I don't think this has resolved your problem
    thoroughly since using SYSTEM is not a recommeded means which grant the
    ASP.NET process too much privileges and permissions. We just use this to
    confirm that this is a security setting issue. So if you really want to
    resolve the problem thoroughly, I think we still need to checking the
    default "Machine" setting which use the machine\aspnet account as the
    process identity. You can switch back the <processModel> 's setting to
    machine and then testing through filemon to see whether you've missed any
    access failures. Also, here are two tech articles which help you get what
    permissions and privilleges the ASP.NET process account need:

    #How To Create a Custom Account to Run ASP.NET
    http://msdn.microsoft.com/library/default.asp?url=/library/en-us/secmod/html
    /secmod15.asp

    #Process and request identity in ASP.NET
    http://support.microsoft.com/?id=317012

    Hope also helps. Good luck!

    Steven Cheng
    Microsoft Online Support

    Get Secure! www.microsoft.com/security
    (This posting is provided "AS IS", with no warranties, and confers no
    rights.)
     
    Steven Cheng[MSFT], Jun 20, 2005
    #12
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Mark E

    ASP.NET pages stopped working

    Mark E, Jul 24, 2003, in forum: ASP .Net
    Replies:
    2
    Views:
    430
    Mark E
    Jul 24, 2003
  2. =?Utf-8?B?TWlrZQ==?=

    Help ASP.NET app suddenly stopped working

    =?Utf-8?B?TWlrZQ==?=, Feb 1, 2005, in forum: ASP .Net
    Replies:
    1
    Views:
    397
    =?Utf-8?B?TWlrZQ==?=
    Feb 2, 2005
  3. J Rieggle
    Replies:
    1
    Views:
    470
    Curt_C [MVP]
    Jul 21, 2005
  4. Chris
    Replies:
    1
    Views:
    1,656
  5. landers
    Replies:
    1
    Views:
    419
    landers
    Oct 12, 2006
Loading...

Share This Page