asp.net *very* slow initial load.

Discussion in 'ASP General' started by Ian Murphy, Jan 19, 2005.

  1. Ian Murphy

    Ian Murphy Guest

    Can anyone tell me where I can find information regarding a problem I am
    having with w2003 ii6 and asp.net. The first page load each morning can run
    to 1/2hr, which as you can imagine is not exactly making anyone happy.

    There doesn't appear to be a newsgroup dedicated to asp.net, though I may
    have been looking in all the wrong places.. so many groups.

    I've found some info on the web related to the problem but nothing which
    discusses what may be going on, nor how to diagnose it.

    Ian
     
    Ian Murphy, Jan 19, 2005
    #1
    1. Advertising

  2. Ian Murphy wrote:
    > Can anyone tell me where I can find information regarding a problem I
    > am having with w2003 ii6 and asp.net.


    ***canned dotnet reply************************************
    There was no way for you to know it, but this is a classic asp newsgroup.
    While you may be lucky enough to find a dotnet-savvy person here who can
    answer your question, you can eliminate the luck factor by posting your
    question to a newsgroup where the dotnet-savvy people hang out. I suggest
    microsoft.public.dotnet.framework.aspnet.
    ********************************************************
    HTH,
    Bob Barrows
    --
    Microsoft MVP -- ASP/ASP.NET
    Please reply to the newsgroup. The email account listed in my From
    header is my spam trap, so I don't check it very often. You will get a
    quicker response by posting to the newsgroup.
     
    Bob Barrows [MVP], Jan 19, 2005
    #2
    1. Advertising

  3. Ian Murphy

    Rob Meade Guest

    "Ian Murphy" wrote ...

    > Can anyone tell me where I can find information regarding a problem I am
    > having with w2003 ii6 and asp.net. The first page load each morning can

    run
    > to 1/2hr, which as you can imagine is not exactly making anyone happy.


    Hi Ian,

    I wouldn't call myself "dotnet-savvy" - however I have experienced a similar
    problem myself, having built a pretty simple website (infact all the .net
    does is renders html at this stage, nothing more clever than that) - the
    first load after a given period of time always takes considerably longer -
    from what I've found out in the past...

    First load after a build/rebuild takes long because of the rebuild it does
    when run

    In addition - in my case, if the site is not a popular one, it simply
    doesn't have enough hits (in my case) to keep what I can only assume is a
    cached version....so after this period of time I'm back to it having to do
    whatever it is that its doing....it could well be that you are experiencing
    the same problem, magnified perhaps by a more complicated application. Of
    course in my case, once I have got past the initial load, all subsequent
    hits for a period of time as fast as fek (but then its only rendering
    html)...

    Sorry if this isn't a great deal of help - but thought it worth posting
    anyway - as I say - I'm not that "dotnet-savvy" :eek:)

    Regards

    Rob
     
    Rob Meade, Jan 19, 2005
    #3
  4. Ian Murphy

    Rob Meade Guest

    Sorry, should have also said...

    I've often found some help in this group:

    microsoft.public.dotnet.framework.aspnet (the name perhaps doesn't suggest
    coding help I must admit)

    Regards

    Rob
     
    Rob Meade, Jan 19, 2005
    #4
  5. Ian Murphy

    Roland Hall Guest

    "Bob Barrows [MVP]" wrote in message
    news:%23%23z7bnj$...
    : Ian Murphy wrote:
    : > Can anyone tell me where I can find information regarding a problem I
    : > am having with w2003 ii6 and asp.net.
    :
    : ***canned dotnet reply************************************
    : There was no way for you to know it, but this is a classic asp newsgroup.
    : While you may be lucky enough to find a dotnet-savvy person here who can
    : answer your question, you can eliminate the luck factor by posting your
    : question to a newsgroup where the dotnet-savvy people hang out. I suggest
    : microsoft.public.dotnet.framework.aspnet.
    : ******************************************************
    : HTH,
    : Bob Barrows

    They should be able to see it now.
     
    Roland Hall, Jan 20, 2005
    #5
  6. Ian Murphy

    Ian Murphy Guest

    Thanks, I'll try out the dotnet.framework.aspnet group.

    regards

    Ian
     
    Ian Murphy, Jan 20, 2005
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Ian Murphy

    *very* slow initial page load

    Ian Murphy, Jan 20, 2005, in forum: ASP .Net
    Replies:
    13
    Views:
    9,949
    mwalshe2000
    Jun 17, 2008
  2. Med

    Initial Load slow on IIS6

    Med, Nov 3, 2008, in forum: ASP .Net
    Replies:
    5
    Views:
    2,466
    George
    Nov 3, 2008
  3. Alf P. Steinbach /Usenet

    Slow -- VERY slow brain

    Alf P. Steinbach /Usenet, Jun 16, 2011, in forum: C++
    Replies:
    17
    Views:
    520
    Noah Roberts
    Jun 29, 2011
  4. Med
    Replies:
    1
    Views:
    137
    Bob Barrows [MVP]
    Nov 3, 2008
  5. Nick Green
    Replies:
    4
    Views:
    195
    Nick Green
    Nov 18, 2009
Loading...

Share This Page