ASP page can't post to IIS 5.0 Server

Discussion in 'ASP General' started by Hunter Pieper, Aug 30, 2004.

  1. Hello,

    We are trying to get an .asp page to post to an access
    database. the page is viewable, and the form boxes can be
    filled in. Upon submission of the data a confirmation
    page is then to show.

    What happens is the data is inserted into the page, but
    upon submission an HTTP 500 Internal server error appears.

    if we uncheck show friendly http errors in IE there is
    still no more info to go on.

    My question is then, where to begin?

    I suspect perhaps a security setting, but which?

    How to get more error info?

    Any ideas are appreciated.

    Regards

    Hunter
     
    Hunter Pieper, Aug 30, 2004
    #1
    1. Advertising

  2. After unchecking friendly errors, what exactly do you see in your browser?
    If you're truly seeing nothing of use, go into the IIS management console,
    pull up the properties of your site or application, go to the Home Directory
    tab, click the Configuration button under "Application Settings," go to the
    App Debugging tab, and verify that "Send detailed ASP error messages to
    client" radio button is selected.

    Ray at work

    "Hunter Pieper" <> wrote in message
    news:306d01c48ed5$60890ff0$...
    > Hello,
    >
    > We are trying to get an .asp page to post to an access
    > database. the page is viewable, and the form boxes can be
    > filled in. Upon submission of the data a confirmation
    > page is then to show.
    >
    > What happens is the data is inserted into the page, but
    > upon submission an HTTP 500 Internal server error appears.
    >
    > if we uncheck show friendly http errors in IE there is
    > still no more info to go on.
    >
    > My question is then, where to begin?
    >
    > I suspect perhaps a security setting, but which?
    >
    > How to get more error info?
    >
    > Any ideas are appreciated.
    >
    > Regards
    >
    > Hunter
     
    Ray Costanzo [MVP], Aug 30, 2004
    #2
    1. Advertising

  3. It only says:

    HTTP 404 - File not found
    Internet Information Services

    Which really narrows it down.

    Regards

    Hunter


    >-----Original Message-----
    >After unchecking friendly errors, what exactly do you see

    in your browser?
    >If you're truly seeing nothing of use, go into the IIS

    management console,
    >pull up the properties of your site or application, go to

    the Home Directory
    >tab, click the Configuration button under "Application

    Settings," go to the
    >App Debugging tab, and verify that "Send detailed ASP

    error messages to
    >client" radio button is selected.
    >
    >Ray at work
    >
    >"Hunter Pieper" <> wrote in

    message
    >news:306d01c48ed5$60890ff0$...
    >> Hello,
    >>
    >> We are trying to get an .asp page to post to an access
    >> database. the page is viewable, and the form boxes can

    be
    >> filled in. Upon submission of the data a confirmation
    >> page is then to show.
    >>
    >> What happens is the data is inserted into the page, but
    >> upon submission an HTTP 500 Internal server error

    appears.
    >>
    >> if we uncheck show friendly http errors in IE there is
    >> still no more info to go on.
    >>
    >> My question is then, where to begin?
    >>
    >> I suspect perhaps a security setting, but which?
    >>
    >> How to get more error info?
    >>
    >> Any ideas are appreciated.
    >>
    >> Regards
    >>
    >> Hunter

    >
    >
    >.
    >
     
    Hunter Pieper, Aug 30, 2004
    #3
  4. Your 500 error turns into a 404 after unchecking friendly errors? :| Are
    you sure you have the URL right? What about a static .htm page in the same
    directory? Create test.htm and test.asp in the same directory, with these
    contents:

    test.htm:
    <html><body>I'm in test.htm</body></html>

    test.asp:
    Response.Write "<html><body>I'm in test.asp</body></html>"


    Can you load either page?

    Ray at work

    "Hunter Pieper" <> wrote in message
    news:2fc101c48edd$a31b04b0$...
    > It only says:
    >
    > HTTP 404 - File not found
    > Internet Information Services
    >
    > Which really narrows it down.
    >
    > Regards
    >
    > Hunter
    >
    >
    >>-----Original Message-----
    >>After unchecking friendly errors, what exactly do you see

    > in your browser?
    >>If you're truly seeing nothing of use, go into the IIS

    > management console,
    >>pull up the properties of your site or application, go to

    > the Home Directory
    >>tab, click the Configuration button under "Application

    > Settings," go to the
    >>App Debugging tab, and verify that "Send detailed ASP

    > error messages to
    >>client" radio button is selected.
    >>
    >>Ray at work
    >>
    >>"Hunter Pieper" <> wrote in

    > message
    >>news:306d01c48ed5$60890ff0$...
    >>> Hello,
    >>>
    >>> We are trying to get an .asp page to post to an access
    >>> database. the page is viewable, and the form boxes can

    > be
    >>> filled in. Upon submission of the data a confirmation
    >>> page is then to show.
    >>>
    >>> What happens is the data is inserted into the page, but
    >>> upon submission an HTTP 500 Internal server error

    > appears.
    >>>
    >>> if we uncheck show friendly http errors in IE there is
    >>> still no more info to go on.
    >>>
    >>> My question is then, where to begin?
    >>>
    >>> I suspect perhaps a security setting, but which?
    >>>
    >>> How to get more error info?
    >>>
    >>> Any ideas are appreciated.
    >>>
    >>> Regards
    >>>
    >>> Hunter

    >>
    >>
    >>.
    >>
     
    Ray Costanzo [MVP], Aug 30, 2004
    #4
  5. Hunter Pieper

    Jeff Cochran Guest

    On Mon, 30 Aug 2004 15:06:44 -0700, "Hunter Pieper"
    <> wrote:

    >It only says:
    >
    >HTTP 404 - File not found
    >Internet Information Services
    >
    >Which really narrows it down.


    It actually does. Since you had a 500 error and now it's a 404, then
    the probl;em is now different. Check and see if the file is actually
    there to be found by the account accessing it.

    Then, when you get that fixed, repost the full error for the 500
    error.

    Jeff



    >>-----Original Message-----
    >>After unchecking friendly errors, what exactly do you see

    >in your browser?
    >>If you're truly seeing nothing of use, go into the IIS

    >management console,
    >>pull up the properties of your site or application, go to

    >the Home Directory
    >>tab, click the Configuration button under "Application

    >Settings," go to the
    >>App Debugging tab, and verify that "Send detailed ASP

    >error messages to
    >>client" radio button is selected.
    >>
    >>Ray at work
    >>
    >>"Hunter Pieper" <> wrote in

    >message
    >>news:306d01c48ed5$60890ff0$...
    >>> Hello,
    >>>
    >>> We are trying to get an .asp page to post to an access
    >>> database. the page is viewable, and the form boxes can

    >be
    >>> filled in. Upon submission of the data a confirmation
    >>> page is then to show.
    >>>
    >>> What happens is the data is inserted into the page, but
    >>> upon submission an HTTP 500 Internal server error

    >appears.
    >>>
    >>> if we uncheck show friendly http errors in IE there is
    >>> still no more info to go on.
    >>>
    >>> My question is then, where to begin?
    >>>
    >>> I suspect perhaps a security setting, but which?
    >>>
    >>> How to get more error info?
    >>>
    >>> Any ideas are appreciated.
    >>>
    >>> Regards
    >>>
    >>> Hunter

    >>
    >>
    >>.
    >>
     
    Jeff Cochran, Aug 31, 2004
    #5
  6. I figured it out.

    I had the URLScan asapi filter running. I had removed it
    earlier in the day, but I had forgotten to restart the IIS
    server.

    It took a while for my brains to start working; so it was
    later in the day when I finally remembered, to recheck the
    URLScan log. At which time I noticed it was denying
    access, and that a restart was necessary to get the
    desired effect.

    Damn.

    Thanks for the help though, and sorry for the trouble.

    Hunter





    >-----Original Message-----
    >Your 500 error turns into a 404 after unchecking friendly

    errors? :| Are
    >you sure you have the URL right? What about a

    static .htm page in the same
    >directory? Create test.htm and test.asp in the same

    directory, with these
    >contents:
    >
    >test.htm:
    ><html><body>I'm in test.htm</body></html>
    >
    >test.asp:
    >Response.Write "<html><body>I'm in test.asp</body></html>"
    >
    >
    >Can you load either page?
    >
    >Ray at work
    >
    >"Hunter Pieper" <> wrote in

    message
    >news:2fc101c48edd$a31b04b0$...
    >> It only says:
    >>
    >> HTTP 404 - File not found
    >> Internet Information Services
    >>
    >> Which really narrows it down.
    >>
    >> Regards
    >>
    >> Hunter
    >>
    >>
    >>>-----Original Message-----
    >>>After unchecking friendly errors, what exactly do you

    see
    >> in your browser?
    >>>If you're truly seeing nothing of use, go into the IIS

    >> management console,
    >>>pull up the properties of your site or application, go

    to
    >> the Home Directory
    >>>tab, click the Configuration button under "Application

    >> Settings," go to the
    >>>App Debugging tab, and verify that "Send detailed ASP

    >> error messages to
    >>>client" radio button is selected.
    >>>
    >>>Ray at work
    >>>
    >>>"Hunter Pieper" <> wrote in

    >> message
    >>>news:306d01c48ed5$60890ff0$...
    >>>> Hello,
    >>>>
    >>>> We are trying to get an .asp page to post to an access
    >>>> database. the page is viewable, and the form boxes

    can
    >> be
    >>>> filled in. Upon submission of the data a confirmation
    >>>> page is then to show.
    >>>>
    >>>> What happens is the data is inserted into the page,

    but
    >>>> upon submission an HTTP 500 Internal server error

    >> appears.
    >>>>
    >>>> if we uncheck show friendly http errors in IE there is
    >>>> still no more info to go on.
    >>>>
    >>>> My question is then, where to begin?
    >>>>
    >>>> I suspect perhaps a security setting, but which?
    >>>>
    >>>> How to get more error info?
    >>>>
    >>>> Any ideas are appreciated.
    >>>>
    >>>> Regards
    >>>>
    >>>> Hunter
    >>>
    >>>
    >>>.
    >>>

    >
    >
    >.
    >
     
    Hunter Pieper, Aug 31, 2004
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?QW5hbmRoaQ==?=

    Can asp and asp.net reside in same IIS server

    =?Utf-8?B?QW5hbmRoaQ==?=, Apr 5, 2007, in forum: ASP .Net
    Replies:
    11
    Views:
    524
    Mark Rae
    Apr 5, 2007
  2. John Kennedy
    Replies:
    5
    Views:
    263
    Carl Prothman [MVP]
    Aug 14, 2003
  3. John Kennedy
    Replies:
    5
    Views:
    469
    Carl Prothman [MVP]
    Aug 14, 2003
  4. luu duong
    Replies:
    2
    Views:
    378
    luu duong
    Oct 8, 2003
  5. J. Muenchbourg
    Replies:
    0
    Views:
    408
    J. Muenchbourg
    Aug 6, 2003
Loading...

Share This Page