ASP problem

Discussion in 'ASP General' started by Faisal, Aug 28, 2004.

  1. Faisal

    Faisal Guest

    when running an asp page, after i do any change in the
    content. it not reflect when i referesh the page.

    it is windows 2000 and IIS 5.0
    pls assist.
    Faisal, Aug 28, 2004
    #1
    1. Advertising

  2. Faisal

    Evertjan. Guest

    Faisal wrote on 28 aug 2004 in microsoft.public.inetserver.asp.general:

    > when running an asp page, after i do any change in the
    > content. it not reflect when i referesh the page.
    >


    Start page with, [and clear your browser cache]:

    <% Response.Expires = 0 %>

    --
    Evertjan.
    The Netherlands.
    (Please change the x'es to dots in my emailaddress,
    but let us keep the discussions in the newsgroup)
    Evertjan., Aug 28, 2004
    #2
    1. Advertising

  3. turn off caching on the server.

    "Evertjan." <> wrote in message
    news:Xns95538C38CE734eejj99@194.109.133.29...
    > Faisal wrote on 28 aug 2004 in microsoft.public.inetserver.asp.general:
    >
    > > when running an asp page, after i do any change in the
    > > content. it not reflect when i referesh the page.
    > >

    >
    > Start page with, [and clear your browser cache]:
    >
    > <% Response.Expires = 0 %>
    >
    > --
    > Evertjan.
    > The Netherlands.
    > (Please change the x'es to dots in my emailaddress,
    > but let us keep the discussions in the newsgroup)
    >
    Pauline Parrot, Aug 29, 2004
    #3
  4. Faisal

    fasal Guest

    any other clue?
    >-----Original Message-----
    >turn off caching on the server.
    >
    >"Evertjan." <> wrote in

    message
    >news:Xns95538C38CE734eejj99@194.109.133.29...
    >> Faisal wrote on 28 aug 2004 in

    microsoft.public.inetserver.asp.general:
    >>
    >> > when running an asp page, after i do any change in

    the
    >> > content. it not reflect when i referesh the page.
    >> >

    >>
    >> Start page with, [and clear your browser cache]:
    >>
    >> <% Response.Expires = 0 %>
    >>
    >> --
    >> Evertjan.
    >> The Netherlands.
    >> (Please change the x'es to dots in my emailaddress,
    >> but let us keep the discussions in the newsgroup)
    >>

    >
    >
    >.
    >
    fasal, Aug 29, 2004
    #4
  5. Faisal

    Evertjan. Guest

    Pauline Parrot wrote on 29 aug 2004 in
    microsoft.public.inetserver.asp.general:
    > "Evertjan." <> wrote in message
    > news:Xns95538C38CE734eejj99@194.109.133.29...
    >> Faisal wrote on 28 aug 2004 in microsoft.public.inetserver.asp.general:
    >>
    >> > when running an asp page, after i do any change in the
    >> > content. it not reflect when i referesh the page.
    >> >

    >>
    >> Start page with, [and clear your browser cache]:
    >>
    >> <% Response.Expires = 0 %>


    > turn off caching on the server.


    [please do not toppost]

    Often not an option on a rented virtual server.

    [The OP seems to have his own.]

    --
    Evertjan.
    The Netherlands.
    (Please change the x'es to dots in my emailaddress,
    but let us keep the discussions in the newsgroup)
    Evertjan., Aug 29, 2004
    #5
  6. Faisal

    Harag Guest

    On Sun, 29 Aug 2004 00:28:18 -0700, "fasal"
    <> wrote:

    >any other clue?
    >>-----Original Message-----
    >>turn off caching on the server.
    >>
    >>"Evertjan." <> wrote in

    >message
    >>news:Xns95538C38CE734eejj99@194.109.133.29...
    >>> Faisal wrote on 28 aug 2004 in

    >microsoft.public.inetserver.asp.general:
    >>>
    >>> > when running an asp page, after i do any change in

    >the
    >>> > content. it not reflect when i referesh the page.
    >>> >
    >>>
    >>> Start page with, [and clear your browser cache]:
    >>>
    >>> <% Response.Expires = 0 %>
    >>>
    >>> --
    >>> Evertjan.
    >>> The Netherlands.
    >>> (Please change the x'es to dots in my emailaddress,
    >>> but let us keep the discussions in the newsgroup)
    >>>

    >>
    >>
    >>.
    >>



    <%
    Response.Expires = 0
    Response.Expiresabsolute = Now() - 1
    Response.AddHeader "pragma","no-cache"
    Response.AddHeader "cache-control","private"
    Response.CacheControl = "no-cache"
    %>

    Put the above at the top of the ASP file.


    Also please do NOT top post on this group.

    HTH

    Al.
    Harag, Aug 29, 2004
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Ben
    Replies:
    3
    Views:
    1,125
  2. Andrea Raimondi
    Replies:
    1
    Views:
    449
  3. R.A.M.
    Replies:
    1
    Views:
    3,229
    =?Utf-8?B?Y2xpY2tvbg==?=
    Mar 29, 2006
  4. Daves
    Replies:
    2
    Views:
    730
    Patrice
    May 31, 2006
  5. David A. Beck
    Replies:
    10
    Views:
    1,006
    Scott McNair
    Apr 13, 2004
Loading...

Share This Page