aspnet_wp unable to make remote connection in .net framework 2.0

Discussion in 'ASP .Net Web Services' started by StealthEX, Jul 11, 2006.

  1. StealthEX

    StealthEX Guest

    Hi,
    I have a .net 2.0 web service that acts as a messaging hub that takes a SOAP
    request from a single source and then sparks of a bunch of requests to
    multiple web services. This worked fine in .net 1.1 but now we've
    re-engineered it and written it using .net 2.0 and now it doesn't work. We
    have nailed the problem and it seems to lie in the fact that the when
    aspnet_wp makes a request to an external host, it tries to go via a
    non-existent proxy server. How can I force it to bypass any proxy and connect
    directly? The internet settings are all correct - is there something in
    ASP.NET 2.0 that adds extra restrictions to the ASPNET user (as I said, it
    works fine in 1.1).
    StealthEX, Jul 11, 2006
    #1
    1. Advertising

  2. StealthEX

    StealthEX Guest

    Don't ask me specifics, but there are changes in system.net in .net 2.0 from
    1.1 so this is why you are experiencing a difference. It looks like your web
    service is trying to use the default proxy and in .net 2.0 it digs through
    your registry and its obviously picking up this proxy that you say doesn't
    actually exist.
    To force it to use a direct connection add the following into your
    web.config and it will prevent any unecessary proxy detection.

    <system.net>
    <defaultProxy>
    <proxy usesystemdefault="False"/>
    </defaultProxy>
    </system.net>

    Hope it helps!

    "StealthEX" wrote:

    > Hi,
    > I have a .net 2.0 web service that acts as a messaging hub that takes a SOAP
    > request from a single source and then sparks of a bunch of requests to
    > multiple web services. This worked fine in .net 1.1 but now we've
    > re-engineered it and written it using .net 2.0 and now it doesn't work. We
    > have nailed the problem and it seems to lie in the fact that the when
    > aspnet_wp makes a request to an external host, it tries to go via a
    > non-existent proxy server. How can I force it to bypass any proxy and connect
    > directly? The internet settings are all correct - is there something in
    > ASP.NET 2.0 that adds extra restrictions to the ASPNET user (as I said, it
    > works fine in 1.1).
    StealthEX, Jul 12, 2006
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Marisha
    Replies:
    0
    Views:
    1,210
    Marisha
    Mar 27, 2006
  2. Monty
    Replies:
    3
    Views:
    4,089
    Monty
    Sep 29, 2006
  3. Homer
    Replies:
    2
    Views:
    16,479
    Homer
    Aug 13, 2007
  4. Ilya
    Replies:
    0
    Views:
    127
  5. Tom McDonald
    Replies:
    1
    Views:
    162
    Tom McDonald
    Dec 20, 2003
Loading...

Share This Page