ATLAS and controls emitting Javascript

Discussion in 'ASP .Net' started by julia.hayward@cadcorp.com, Jan 5, 2007.

  1. Guest

    Hi all,

    I have a custom control which emits a bit of Javascript into its page
    as part of its Render() method; this is then executed by the browser as
    soon as the page is loaded. This all works fine in ASP.NET.

    However, when the control is in an Atlas UpdatePanel, when the panel
    update is triggered the control emits the Javascript, but it's not
    executed.

    Any ideas if this is a simple fix, or do I need to make the control
    render something different? (Bear with me, it will take a while to slim
    it down to an example I can post!)

    Best wishes,
    Julia
    , Jan 5, 2007
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. John Livermore

    Client side validators not emitting

    John Livermore, Jul 18, 2003, in forum: ASP .Net
    Replies:
    1
    Views:
    376
    John Livermore
    Jul 18, 2003
  2. Klaus Johannes Rusch

    Re: Emitting   to HTML Output

    Klaus Johannes Rusch, Jun 24, 2003, in forum: XML
    Replies:
    5
    Views:
    3,000
    Micah Cowan
    Jun 27, 2003
  3. Andy Jefferies

    Re: Emitting   to HTML Output

    Andy Jefferies, Jun 25, 2003, in forum: XML
    Replies:
    0
    Views:
    1,321
    Andy Jefferies
    Jun 25, 2003
  4. Peter C. Chapin

    Re: Emitting   to HTML Output

    Peter C. Chapin, Jun 26, 2003, in forum: XML
    Replies:
    10
    Views:
    3,541
    Micah Cowan
    Jun 28, 2003
  5. JV

    control emitting javascript for document.onload

    JV, Apr 1, 2005, in forum: ASP .Net Building Controls
    Replies:
    1
    Views:
    118
Loading...

Share This Page