AttributeError: cannot find method in module?

Discussion in 'Python' started by Erlend Fuglum, Jun 6, 2004.

  1. I have tried and tried, but cannot figure out the source of the
    following error:

    AttributeError: 'module' object has no attribute 'menyHMTL'
    __doc__ = 'Attribute not found.'
    __getitem__ = <bound method AttributeError.__getitem__ of
    <exceptions.AttributeError instance at 0x8187984>>
    __init__ = <bound method AttributeError.__init__ of
    <exceptions.AttributeError instance at 0x8187984>>
    __module__ = 'exceptions'
    __str__ = <bound method AttributeError.__str__ of
    <exceptions.AttributeError instance at 0x8187984>>
    args = ("'module' object has no attribute 'menyHMTL'",)

    Some more information:
    'menyHTML' is a function in a module named 'menymodul' which imports
    all fine. There is no other file named menymodul, and no variable
    named menymodul - so the naming should not be disturbed.

    Importing menymodul and using the function works fine from another
    module, just not from this one.

    What is it that I am not getting here?
    How can this be solved?

    Erlend
     
    Erlend Fuglum, Jun 6, 2004
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.

Share This Page