Auth_User blank. Please help

Discussion in 'ASP General' started by Guest, Apr 22, 2005.

  1. Guest

    Guest Guest

    I am trying to use AUTH_USER from request.servervariables but the field is
    blank. I am using Windoze server 2003 with IIS5. I know there is a fix
    because I did it a long time ago with our old NT server running IIS4 but I
    cant remember how I got it to work. We are all authenticated users on our
    Domain so this is available, I am able to get IP info and such. I seem to
    remember some kind of ASP code that did the fix by altering the way the web
    server displays info. Does anyone know this fix?
     
    Guest, Apr 22, 2005
    #1
    1. Advertising

  2. Guest

    Patrice Guest

    AFAIK there is nothing to "fix".

    Are you sure that you web site is not currently set to accept anonymous
    requests ?

    Patrice

    --

    "<VITA>" <> a écrit dans le message de
    news:...
    > I am trying to use AUTH_USER from request.servervariables but the field is
    > blank. I am using Windoze server 2003 with IIS5. I know there is a fix
    > because I did it a long time ago with our old NT server running IIS4 but I
    > cant remember how I got it to work. We are all authenticated users on our
    > Domain so this is available, I am able to get IP info and such. I seem to
    > remember some kind of ASP code that did the fix by altering the way the

    web
    > server displays info. Does anyone know this fix?
    >
    >
     
    Patrice, Apr 22, 2005
    #2
    1. Advertising

  3. Turn off anonymous access for the page, directory, or application in IIS.

    Ray at work

    "<VITA>" <> wrote in message
    news:...
    > I am trying to use AUTH_USER from request.servervariables but the field is
    > blank. I am using Windoze server 2003 with IIS5. I know there is a fix
    > because I did it a long time ago with our old NT server running IIS4 but I
    > cant remember how I got it to work. We are all authenticated users on our
    > Domain so this is available, I am able to get IP info and such. I seem to
    > remember some kind of ASP code that did the fix by altering the way the

    web
    > server displays info. Does anyone know this fix?
    >
    >
     
    Ray Costanzo [MVP], Apr 22, 2005
    #3
  4. <VITA> wrote:
    > I am trying to use AUTH_USER from request.servervariables but the
    > field is blank. I am using Windoze server 2003 with IIS5. I know
    > there is a fix because I did it a long time ago with our old NT
    > server running IIS4 but I cant remember how I got it to work. We are
    > all authenticated users on our Domain so this is available, I am able
    > to get IP info and such. I seem to remember some kind of ASP code
    > that did the fix by altering the way the web server displays info.
    > Does anyone know this fix?


    Go into site properties and turn off Anonymous Access
    --
    Microsoft MVP - ASP/ASP.NET
    Please reply to the newsgroup. This email account is my spam trap so I
    don't check it very often. If you must reply off-line, then remove the
    "NO SPAM"
     
    Bob Barrows [MVP], Apr 22, 2005
    #4
  5. Guest

    Guest Guest

    That did it thanx all.

    "Patrice" <> wrote in message
    news:eJ8Q$...
    > AFAIK there is nothing to "fix".
    >
    > Are you sure that you web site is not currently set to accept anonymous
    > requests ?
    >
    > Patrice
    >
    > --
    >
    > "<VITA>" <> a écrit dans le message de
    > news:...
    >> I am trying to use AUTH_USER from request.servervariables but the field
    >> is
    >> blank. I am using Windoze server 2003 with IIS5. I know there is a fix
    >> because I did it a long time ago with our old NT server running IIS4 but
    >> I
    >> cant remember how I got it to work. We are all authenticated users on our
    >> Domain so this is available, I am able to get IP info and such. I seem to
    >> remember some kind of ASP code that did the fix by altering the way the

    > web
    >> server displays info. Does anyone know this fix?
    >>
    >>

    >
    >
     
    Guest, Apr 22, 2005
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?RGF2ZQ==?=

    AUTH_USER & User.Identity.Name?

    =?Utf-8?B?RGF2ZQ==?=, Oct 1, 2004, in forum: ASP .Net
    Replies:
    4
    Views:
    1,689
    William F. Robertson, Jr.
    Oct 1, 2004
  2. Jim in Arizona

    Request.ServerVariables("AUTH_USER")??

    Jim in Arizona, Jun 7, 2005, in forum: ASP .Net
    Replies:
    4
    Views:
    12,389
    Jim in Arizona
    Jun 8, 2005
  3. z f

    auth_user is lying ?

    z f, Oct 30, 2005, in forum: ASP .Net
    Replies:
    2
    Views:
    1,328
  4. Curtis Patrick
    Replies:
    0
    Views:
    758
    Curtis Patrick
    Nov 3, 2003
  5. Mark Rae
    Replies:
    0
    Views:
    10,596
    Mark Rae
    Jul 26, 2006
Loading...

Share This Page