Autocomplete Works in older Web site version, not new

Discussion in 'ASP .Net' started by thubba2000@gmail.com, May 19, 2006.

  1. Guest

    We have a web application developed using IBuySpy. In older versions,
    Autocomplete on all web forms works. In our latest version, it stopped
    working on all clients.

    I have gone through all the groups and tried a bunch of things. Two
    main areas I keep seeing are,

    1. Browser Settings not set correctly.
    2. Ability to turn off Autocomplete for a control and a form.

    My browser settings are fine as far as I can tell. When I hit an older
    version of the application, Autocomplete works. I've cleared all my
    form and password history, hit it again, and it saves it. On the Login
    page, it detects I entered a password and asks me if I want to save it.
    Works great.

    On the new version, Autocomplete never saves any previous entries and
    doesn't popup the "Save Password" dialog.

    I've checked the code and we have no references to the AutoComplete
    attribute on forms or input controls. Just to make sure .Net doesn't
    add anything behind the scenes, I view source for the web site and no
    references to AutoComplete.

    Between versions we did redesign the login page and moved it from a
    User control to an standalone ASPX page. But I cannot figure out what I
    left out or what I added that would turn off Autocomplete for the
    entire site.

    I do believe it is a site thing because other users are experiencing
    the exact same thing. Works in old version, doesn't in new.

    Any help would be appreciated.
     
    , May 19, 2006
    #1
    1. Advertising

  2. thubba Guest

    I stumbled across a way to make the AutoComplete work. In the older
    version, we have an asp image button that has a little arrow and "Sign
    In" text in it... That works fine, it makes the AutoComplete work. In
    the new version, we split the image button into two... With the way our
    politicians are going these days, English will be a second language :)
    so we jumped the gun and made our application language indepenent... So
    now the Arrow is still an ASP Image button but the "Sign In" is a ASP
    Link Button... The text being loaded from a resource file.. I kept
    pressing the Link Button and nothing... No AutoComplete saved.. I
    happened to hit the arrow (Image button) one time, and now it works
    great.

    I would be interested if somebody has a logical explanation... I know
    it doesn't seem real but I had another user try it and it works for
    them also.
     
    thubba, May 19, 2006
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Dean R. Henderson
    Replies:
    1
    Views:
    390
    Dean R. Henderson
    Apr 25, 2005
  2. Ryan Stewart
    Replies:
    11
    Views:
    1,002
    Ryan Stewart
    Jan 26, 2004
  3. V Green
    Replies:
    0
    Views:
    903
    V Green
    Feb 5, 2008
  4. PA Bear [MS MVP]
    Replies:
    0
    Views:
    1,018
    PA Bear [MS MVP]
    Feb 5, 2008
  5. Peter K
    Replies:
    2
    Views:
    325
    Peter K
    May 29, 2008
Loading...

Share This Page