Avoid having a SQL express for web parts and avoid personalization

Discussion in 'ASP .Net' started by Roger23, Oct 12, 2006.

  1. Roger23

    Roger23 Guest

    I have a requirement where I need to remove or disable the entire
    personalization feature of my web application. I am not allowed to have
    a SQL express on my web server and I am not allowed to have any SQL
    Express or any SQL server for that matter. how do i disable the entire
    personalization of my application. i tried:

    <webParts >
    <personalization defaultProvider="">
    <providers>
    <clear/>
    </providers>
    </personalization>
    </webParts>

    I tired so many permutations and combinations with the above settings
    and still it expects a connectionstring no matter what. I weould prefer
    not to tinker with the config files in the framework directory. Can I
    not get the same behavior of ASP.NET 1.1? your help is much appreciated.
    Roger23, Oct 12, 2006
    #1
    1. Advertising

  2. webparts is built on personalization, and is the only supported way to use
    personalization. using the webpartmanager you can disable personalization.
    add to each page:

    <asp:webpartmanager runat=server id=myid personalization-enable=false>

    this allows the web part to not use personalization. if webparts still tries
    to connect, then you will have to provide a dummy peronalization provider.

    -- bruce (sqlwork.com)

    "Roger23" <> wrote in message
    news:...
    >I have a requirement where I need to remove or disable the entire
    > personalization feature of my web application. I am not allowed to have
    > a SQL express on my web server and I am not allowed to have any SQL
    > Express or any SQL server for that matter. how do i disable the entire
    > personalization of my application. i tried:
    >
    > <webParts >
    > <personalization defaultProvider="">
    > <providers>
    > <clear/>
    > </providers>
    > </personalization>
    > </webParts>
    >
    > I tired so many permutations and combinations with the above settings
    > and still it expects a connectionstring no matter what. I weould prefer
    > not to tinker with the config files in the framework directory. Can I
    > not get the same behavior of ASP.NET 1.1? your help is much appreciated.
    >
    bruce barker \(sqlwork.com\), Oct 12, 2006
    #2
    1. Advertising

  3. Roger23

    Roger23 Guest

    thanks for the reply. i was trying to remove web parts altogether in my
    app. i did and when i removed my connectionstring it was complaining. I
    removed the webpart manager from my master page and now its ok. i dont
    have to give a conn str anymore. thanks for your time!
    bruce barker (sqlwork.com) wrote:
    > webparts is built on personalization, and is the only supported way to use
    > personalization. using the webpartmanager you can disable personalization.
    > add to each page:
    >
    > <asp:webpartmanager runat=server id=myid personalization-enable=false>
    >
    > this allows the web part to not use personalization. if webparts still tries
    > to connect, then you will have to provide a dummy peronalization provider.
    >
    > -- bruce (sqlwork.com)
    >
    > "Roger23" <> wrote in message
    > news:...
    > >I have a requirement where I need to remove or disable the entire
    > > personalization feature of my web application. I am not allowed to have
    > > a SQL express on my web server and I am not allowed to have any SQL
    > > Express or any SQL server for that matter. how do i disable the entire
    > > personalization of my application. i tried:
    > >
    > > <webParts >
    > > <personalization defaultProvider="">
    > > <providers>
    > > <clear/>
    > > </providers>
    > > </personalization>
    > > </webParts>
    > >
    > > I tired so many permutations and combinations with the above settings
    > > and still it expects a connectionstring no matter what. I weould prefer
    > > not to tinker with the config files in the framework directory. Can I
    > > not get the same behavior of ASP.NET 1.1? your help is much appreciated.
    > >
    Roger23, Oct 12, 2006
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Mohamed Zaki
    Replies:
    1
    Views:
    477
    clintonG
    Dec 21, 2005
  2. Replies:
    1
    Views:
    326
    clintonG
    Aug 9, 2006
  3. Electrified Research
    Replies:
    3
    Views:
    560
    Electrified Research
    Sep 23, 2006
  4. Replies:
    3
    Views:
    584
    Keith Thompson
    Mar 31, 2007
  5. Jake Henderson

    Visual Web Developer 2005 Express and SQL 2005 Express

    Jake Henderson, Mar 10, 2006, in forum: ASP .Net Web Services
    Replies:
    0
    Views:
    214
    Jake Henderson
    Mar 10, 2006
Loading...

Share This Page