"Bad file descriptor" with Webrick/Instiki service

Discussion in 'Ruby' started by Daniel Berger, Aug 29, 2004.

  1. Hi all,

    Ruby 1.8.2 R7
    Windows 2000

    I setup Instiki as a service on my home Windows box. For the most
    part, it seems to work just fine. Every once and a while, however, it
    flakes out and I get this error:

    Internal Server Error
    Bad File Descriptor
    WEBrick/1.3.1 (Ruby/1.8.2/2004-07-29) at localhost:2500.

    It appears only sporadically and seems to be harmless - going back and
    forward again in the browser usually fixes it.

    Any ideas? What little I saw in the .command_log wasn't helpful.

    Regards,

    Dan
     
    Daniel Berger, Aug 29, 2004
    #1
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Geoff Cox

    why "bad file descriptor"?

    Geoff Cox, Dec 4, 2005, in forum: Perl
    Replies:
    1
    Views:
    8,983
    Geoff Cox
    Dec 5, 2005
  2. Kevin
    Replies:
    4
    Views:
    1,272
    David Bolen
    Jul 7, 2003
  3. drs
    Replies:
    0
    Views:
    477
  4. Luc Saffre
    Replies:
    6
    Views:
    690
    Luc Saffre
    Jan 24, 2004
  5. Replies:
    9
    Views:
    998
    Abhijit Soman
    Jan 6, 2005
  6. rbt
    Replies:
    4
    Views:
    1,242
  7. Peña, Botp
    Replies:
    1
    Views:
    279
    David Heinemeier Hansson
    Sep 19, 2004
  8. Yary H
    Replies:
    0
    Views:
    225
    Yary H
    Oct 3, 2004
Loading...