Blank page running ASP page on Windows Vista

Discussion in 'ASP General' started by JL, Jan 29, 2007.

  1. JL

    JL Guest

    Hello,

    I've a strange problem with Windows Vista, running an ASP page on local
    machine (http://localhost/test.asp), the page does not give me any error but
    the asp code is not executed (simple code : <% response.write("hello") %> ),
    it show me a blank page, I think I've put all the setttings correctly, but
    maybe I must do something obvious to fix that.

    Anyone can help me ??

    tnx !
    JL, Jan 29, 2007
    #1
    1. Advertising

  2. JL wrote:
    > Hello,
    >
    > I've a strange problem with Windows Vista, running an ASP page on
    > local machine (http://localhost/test.asp), the page does not give me
    > any error but the asp code is not executed (simple code : <%
    > response.write("hello") %> ), it show me a blank page, I think I've
    > put all the setttings correctly, but maybe I must do something
    > obvious to fix that.
    >
    > Anyone can help me ??
    >

    Same as the previous poster probably:
    http://classicasp.aspfaq.com/general/why-does-iis-hang-and/or-stop-serving-asp-pages.html

    --
    Microsoft MVP -- ASP/ASP.NET
    Please reply to the newsgroup. The email account listed in my From
    header is my spam trap, so I don't check it very often. You will get a
    quicker response by posting to the newsgroup.
    Bob Barrows [MVP], Jan 29, 2007
    #2
    1. Advertising

  3. JL

    JL Guest

    Hi Bob,

    thankyou dor your fast answer, the problem is that I dont have the
    synciwam.vbs file under AdminScripts folder, maybe bcos it's Win Vista ? or
    should it be there ?
    The other step :
    "After the above failed, one thing that has worked for some people is to
    change the Application Protection level of the Default Web Site to Low. This
    is found by right-clicking the application, choosing Properties, and moving
    to the bottom of the Home Directory tab. "

    I cannot change it as it only an asp page under wwwroot folder.

    other hints ?

    many thanks !

    "Bob Barrows [MVP]" <> wrote in message
    news:%233TM$...
    > JL wrote:
    >> Hello,
    >>
    >> I've a strange problem with Windows Vista, running an ASP page on
    >> local machine (http://localhost/test.asp), the page does not give me
    >> any error but the asp code is not executed (simple code : <%
    >> response.write("hello") %> ), it show me a blank page, I think I've
    >> put all the setttings correctly, but maybe I must do something
    >> obvious to fix that.
    >>
    >> Anyone can help me ??
    >>

    > Same as the previous poster probably:
    > http://classicasp.aspfaq.com/general/why-does-iis-hang-and/or-stop-serving-asp-pages.html
    >
    > --
    > Microsoft MVP -- ASP/ASP.NET
    > Please reply to the newsgroup. The email account listed in my From
    > header is my spam trap, so I don't check it very often. You will get a
    > quicker response by posting to the newsgroup.
    >
    >
    JL, Jan 29, 2007
    #3
  4. I have not installed Vista yet so I cannot be sure. Don't you have IIS
    Manager to look at the website properties?
    JL wrote:
    > Hi Bob,
    >
    > thankyou dor your fast answer, the problem is that I dont have the
    > synciwam.vbs file under AdminScripts folder, maybe bcos it's Win
    > Vista ? or should it be there ?
    > The other step :
    > "After the above failed, one thing that has worked for some people is
    > to change the Application Protection level of the Default Web Site to
    > Low. This is found by right-clicking the application, choosing
    > Properties, and moving to the bottom of the Home Directory tab. "
    >
    > I cannot change it as it only an asp page under wwwroot folder.
    >
    > other hints ?
    >
    > many thanks !
    >
    > "Bob Barrows [MVP]" <> wrote in message
    > news:%233TM$...
    >> JL wrote:
    >>> Hello,
    >>>
    >>> I've a strange problem with Windows Vista, running an ASP page on
    >>> local machine (http://localhost/test.asp), the page does not give me
    >>> any error but the asp code is not executed (simple code : <%
    >>> response.write("hello") %> ), it show me a blank page, I think I've
    >>> put all the setttings correctly, but maybe I must do something
    >>> obvious to fix that.
    >>>
    >>> Anyone can help me ??
    >>>

    >> Same as the previous poster probably:
    >>

    http://classicasp.aspfaq.com/general/why-does-iis-hang-and/or-stop-serving-asp-pages.html
    >>
    >> --
    >> Microsoft MVP -- ASP/ASP.NET
    >> Please reply to the newsgroup. The email account listed in my From
    >> header is my spam trap, so I don't check it very often. You will get
    >> a quicker response by posting to the newsgroup.


    --
    Microsoft MVP -- ASP/ASP.NET
    Please reply to the newsgroup. The email account listed in my From
    header is my spam trap, so I don't check it very often. You will get a
    quicker response by posting to the newsgroup.
    Bob Barrows [MVP], Jan 29, 2007
    #4
  5. JL

    JL Guest

    Yes, I have the IIS Manager, but it's a litle different than II6 and I
    cannot find where to modify the application protection for applications or
    files in the default web site.


    "Bob Barrows [MVP]" <> wrote in message
    news:...
    >I have not installed Vista yet so I cannot be sure. Don't you have IIS
    > Manager to look at the website properties?
    > JL wrote:
    >> Hi Bob,
    >>
    >> thankyou dor your fast answer, the problem is that I dont have the
    >> synciwam.vbs file under AdminScripts folder, maybe bcos it's Win
    >> Vista ? or should it be there ?
    >> The other step :
    >> "After the above failed, one thing that has worked for some people is
    >> to change the Application Protection level of the Default Web Site to
    >> Low. This is found by right-clicking the application, choosing
    >> Properties, and moving to the bottom of the Home Directory tab. "
    >>
    >> I cannot change it as it only an asp page under wwwroot folder.
    >>
    >> other hints ?
    >>
    >> many thanks !
    >>
    >> "Bob Barrows [MVP]" <> wrote in message
    >> news:%233TM$...
    >>> JL wrote:
    >>>> Hello,
    >>>>
    >>>> I've a strange problem with Windows Vista, running an ASP page on
    >>>> local machine (http://localhost/test.asp), the page does not give me
    >>>> any error but the asp code is not executed (simple code : <%
    >>>> response.write("hello") %> ), it show me a blank page, I think I've
    >>>> put all the setttings correctly, but maybe I must do something
    >>>> obvious to fix that.
    >>>>
    >>>> Anyone can help me ??
    >>>>
    >>> Same as the previous poster probably:
    >>>

    > http://classicasp.aspfaq.com/general/why-does-iis-hang-and/or-stop-serving-asp-pages.html
    >>>
    >>> --
    >>> Microsoft MVP -- ASP/ASP.NET
    >>> Please reply to the newsgroup. The email account listed in my From
    >>> header is my spam trap, so I don't check it very often. You will get
    >>> a quicker response by posting to the newsgroup.

    >
    > --
    > Microsoft MVP -- ASP/ASP.NET
    > Please reply to the newsgroup. The email account listed in my From
    > header is my spam trap, so I don't check it very often. You will get a
    > quicker response by posting to the newsgroup.
    >
    >
    JL, Jan 29, 2007
    #5
  6. It's probably a mattter of enabling the ASP service. See this for a hint:
    http://support.microsoft.com/default.aspx/kb/315122


    JL wrote:
    > Yes, I have the IIS Manager, but it's a litle different than II6 and I
    > cannot find where to modify the application protection for
    > applications or files in the default web site.
    >
    >
    > "Bob Barrows [MVP]" <> wrote in message
    > news:...
    >> I have not installed Vista yet so I cannot be sure. Don't you have
    >> IIS Manager to look at the website properties?
    >> JL wrote:
    >>> Hi Bob,
    >>>
    >>> thankyou dor your fast answer, the problem is that I dont have the
    >>> synciwam.vbs file under AdminScripts folder, maybe bcos it's Win
    >>> Vista ? or should it be there ?
    >>> The other step :
    >>> "After the above failed, one thing that has worked for some people
    >>> is to change the Application Protection level of the Default Web Site
    >>> to Low. This is found by right-clicking the application, choosing
    >>> Properties, and moving to the bottom of the Home Directory tab. "
    >>>
    >>> I cannot change it as it only an asp page under wwwroot folder.
    >>>
    >>> other hints ?
    >>>
    >>> many thanks !
    >>>
    >>> "Bob Barrows [MVP]" <> wrote in message
    >>> news:%233TM$...
    >>>> JL wrote:
    >>>>> Hello,
    >>>>>
    >>>>> I've a strange problem with Windows Vista, running an ASP page on
    >>>>> local machine (http://localhost/test.asp), the page does not give
    >>>>> me any error but the asp code is not executed (simple code : <%
    >>>>> response.write("hello") %> ), it show me a blank page, I think
    >>>>> I've put all the setttings correctly, but maybe I must do something
    >>>>> obvious to fix that.
    >>>>>
    >>>>> Anyone can help me ??
    >>>>>
    >>>> Same as the previous poster probably:
    >>>>

    >> http://classicasp.aspfaq.com/general/why-does-iis-hang-and/or-stop-serving-asp-pages.html
    >>>>
    >>>> --
    >>>> Microsoft MVP -- ASP/ASP.NET
    >>>> Please reply to the newsgroup. The email account listed in my From
    >>>> header is my spam trap, so I don't check it very often. You will
    >>>> get a quicker response by posting to the newsgroup.

    >>
    >> --
    >> Microsoft MVP -- ASP/ASP.NET
    >> Please reply to the newsgroup. The email account listed in my From
    >> header is my spam trap, so I don't check it very often. You will get
    >> a quicker response by posting to the newsgroup.


    --
    Microsoft MVP - ASP/ASP.NET
    Please reply to the newsgroup. This email account is my spam trap so I
    don't check it very often. If you must reply off-line, then remove the
    "NO SPAM"
    Bob Barrows [MVP], Jan 29, 2007
    #6
  7. JL

    JL Guest

    Hi Bob,

    could be that, but I cannot find where to enable this service on IIS7, I
    think just adding ASP as feature through "Default programs" (option of
    vista) is enough.

    Thanks again !

    "Bob Barrows [MVP]" <> wrote in message
    news:%...
    > It's probably a mattter of enabling the ASP service. See this for a hint:
    > http://support.microsoft.com/default.aspx/kb/315122
    >
    >
    > JL wrote:
    >> Yes, I have the IIS Manager, but it's a litle different than II6 and I
    >> cannot find where to modify the application protection for
    >> applications or files in the default web site.
    >>
    >>
    >> "Bob Barrows [MVP]" <> wrote in message
    >> news:...
    >>> I have not installed Vista yet so I cannot be sure. Don't you have
    >>> IIS Manager to look at the website properties?
    >>> JL wrote:
    >>>> Hi Bob,
    >>>>
    >>>> thankyou dor your fast answer, the problem is that I dont have the
    >>>> synciwam.vbs file under AdminScripts folder, maybe bcos it's Win
    >>>> Vista ? or should it be there ?
    >>>> The other step :
    >>>> "After the above failed, one thing that has worked for some people
    >>>> is to change the Application Protection level of the Default Web Site
    >>>> to Low. This is found by right-clicking the application, choosing
    >>>> Properties, and moving to the bottom of the Home Directory tab. "
    >>>>
    >>>> I cannot change it as it only an asp page under wwwroot folder.
    >>>>
    >>>> other hints ?
    >>>>
    >>>> many thanks !
    >>>>
    >>>> "Bob Barrows [MVP]" <> wrote in message
    >>>> news:%233TM$...
    >>>>> JL wrote:
    >>>>>> Hello,
    >>>>>>
    >>>>>> I've a strange problem with Windows Vista, running an ASP page on
    >>>>>> local machine (http://localhost/test.asp), the page does not give
    >>>>>> me any error but the asp code is not executed (simple code : <%
    >>>>>> response.write("hello") %> ), it show me a blank page, I think
    >>>>>> I've put all the setttings correctly, but maybe I must do something
    >>>>>> obvious to fix that.
    >>>>>>
    >>>>>> Anyone can help me ??
    >>>>>>
    >>>>> Same as the previous poster probably:
    >>>>>
    >>> http://classicasp.aspfaq.com/general/why-does-iis-hang-and/or-stop-serving-asp-pages.html
    >>>>>
    >>>>> --
    >>>>> Microsoft MVP -- ASP/ASP.NET
    >>>>> Please reply to the newsgroup. The email account listed in my From
    >>>>> header is my spam trap, so I don't check it very often. You will
    >>>>> get a quicker response by posting to the newsgroup.
    >>>
    >>> --
    >>> Microsoft MVP -- ASP/ASP.NET
    >>> Please reply to the newsgroup. The email account listed in my From
    >>> header is my spam trap, so I don't check it very often. You will get
    >>> a quicker response by posting to the newsgroup.

    >
    > --
    > Microsoft MVP - ASP/ASP.NET
    > Please reply to the newsgroup. This email account is my spam trap so I
    > don't check it very often. If you must reply off-line, then remove the
    > "NO SPAM"
    >
    JL, Jan 30, 2007
    #7
  8. I don't think that's it, but I'm sorry I can't help.
    Let's try crossposting this to .inetserver.iis and see if anyone there
    can help.


    JL wrote:
    > Hi Bob,
    >
    > could be that, but I cannot find where to enable this service on
    > IIS7, I think just adding ASP as feature through "Default programs"
    > (option of vista) is enough.
    >
    > Thanks again !
    >
    > "Bob Barrows [MVP]" <> wrote in message
    > news:%...
    >> It's probably a mattter of enabling the ASP service. See this for a
    >> hint: http://support.microsoft.com/default.aspx/kb/315122
    >>
    >>
    >> JL wrote:
    >>> Yes, I have the IIS Manager, but it's a litle different than II6
    >>> and I cannot find where to modify the application protection for
    >>> applications or files in the default web site.
    >>>
    >>>
    >>> "Bob Barrows [MVP]" <> wrote in message
    >>> news:...
    >>>> I have not installed Vista yet so I cannot be sure. Don't you have
    >>>> IIS Manager to look at the website properties?
    >>>> JL wrote:
    >>>>> Hi Bob,
    >>>>>
    >>>>> thankyou dor your fast answer, the problem is that I dont have the
    >>>>> synciwam.vbs file under AdminScripts folder, maybe bcos it's Win
    >>>>> Vista ? or should it be there ?
    >>>>> The other step :
    >>>>> "After the above failed, one thing that has worked for some people
    >>>>> is to change the Application Protection level of the Default Web
    >>>>> Site to Low. This is found by right-clicking the application,
    >>>>> choosing Properties, and moving to the bottom of the Home
    >>>>> Directory tab. "
    >>>>>
    >>>>> I cannot change it as it only an asp page under wwwroot folder.
    >>>>>
    >>>>> other hints ?
    >>>>>
    >>>>> many thanks !
    >>>>>
    >>>>> "Bob Barrows [MVP]" <> wrote in message
    >>>>> news:%233TM$...
    >>>>>> JL wrote:
    >>>>>>> Hello,
    >>>>>>>
    >>>>>>> I've a strange problem with Windows Vista, running an ASP page
    >>>>>>> on local machine (http://localhost/test.asp), the page does not
    >>>>>>> give me any error but the asp code is not executed (simple code
    >>>>>>> : <% response.write("hello") %> ), it show me a blank page, I
    >>>>>>> think I've put all the setttings correctly, but maybe I must do
    >>>>>>> something obvious to fix that.
    >>>>>>>
    >>>>>>> Anyone can help me ??
    >>>>>>>
    >>>>>> Same as the previous poster probably:
    >>>>>>
    >>>>

    http://classicasp.aspfaq.com/general/why-does-iis-hang-and/or-stop-serving-asp-pages.html
    >>>>>>



    --
    Microsoft MVP -- ASP/ASP.NET
    Please reply to the newsgroup. The email account listed in my From
    header is my spam trap, so I don't check it very often. You will get a
    quicker response by posting to the newsgroup.
    Bob Barrows [MVP], Jan 30, 2007
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jon Turlington
    Replies:
    12
    Views:
    528
    Stefan Schmiedl
    Feb 6, 2007
  2. Michael
    Replies:
    5
    Views:
    876
    Bjoern Schliessmann
    Nov 3, 2007
  3. Jurjen de Groot
    Replies:
    1
    Views:
    391
    Jurjen de Groot
    Nov 8, 2007
  4. Mchizi_Crazy
    Replies:
    2
    Views:
    273
    Sumitava Mukherjee
    Sep 9, 2008
  5. ryan
    Replies:
    0
    Views:
    239
Loading...

Share This Page