Broken Pipe error in HTTP-Access2 when used in Rails

Discussion in 'Ruby' started by nicholas.henry, May 21, 2006.

  1. Hello folks:

    I'm using Ruby-Google in a Rails application. A couple minutes after my
    first request (which executes successfully) I will make a second
    request to Google and I get the following error (plus my trace):

    Errno::EPIPE: Broken pipe
    from
    /usr/local/lib/ruby/site_ruby/1.8/http-access2/http.rb:179:in `write'
    from
    /usr/local/lib/ruby/site_ruby/1.8/http-access2/http.rb:179:in `<<'
    from
    /usr/local/lib/ruby/site_ruby/1.8/http-access2/http.rb:179:in `dump'
    from
    /usr/local/lib/ruby/site_ruby/1.8/http-access2/http.rb:386:in `dump'
    from /usr/local/lib/ruby/site_ruby/1.8/http-access2.rb:1213:in
    `query'
    from /usr/local/lib/ruby/site_ruby/1.8/http-access2.rb:1211:in
    `timeout'
    from /usr/local/lib/ruby/1.8/timeout.rb:55:in `timeout'
    from /usr/local/lib/ruby/site_ruby/1.8/http-access2.rb:1211:in
    `query'
    from /usr/local/lib/ruby/site_ruby/1.8/http-access2.rb:892:in
    `query'
    from /usr/local/lib/ruby/site_ruby/1.8/http-access2.rb:434:in
    `do_get_block'
    from /usr/local/lib/ruby/site_ruby/1.8/http-access2.rb:370:in
    `conn_request'
    from /usr/local/lib/ruby/site_ruby/1.8/http-access2.rb:285:in
    `request'
    from /usr/local/lib/ruby/site_ruby/1.8/http-access2.rb:264:in
    `post'
    from /usr/local/lib/ruby/1.8/soap/streamHandler.rb:170:in
    `send_post'
    from /usr/local/lib/ruby/1.8/soap/streamHandler.rb:109:in
    `send'
    from /usr/local/lib/ruby/1.8/soap/rpc/proxy.rb:170:in `route'
    from /usr/local/lib/ruby/1.8/soap/rpc/proxy.rb:141:in `call'
    from /usr/local/lib/ruby/1.8/soap/rpc/driver.rb:178:in `call'
    from /usr/local/lib/ruby/1.8/soap/rpc/driver.rb:232:in
    `doSpellingSuggestion'
    from /usr/local/lib/ruby/1.8/soap/rpc/driver.rb:227:in
    `doSpellingSuggestion'
    from /usr/local/lib/ruby/site_ruby/1.8/google.rb:330:in `spell'
    from (irb):12
    from :0

    I'm not sure why this occurs -- any help would be much appreciated?

    Cheers,
    Nicholas
     
    nicholas.henry, May 21, 2006
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Andi Scharfstein

    http-access2 POSTing

    Andi Scharfstein, Oct 2, 2003, in forum: Ruby
    Replies:
    9
    Views:
    187
    NAKAMURA, Hiroshi
    Oct 4, 2003
  2. nkb

    http-access2 error

    nkb, Sep 17, 2004, in forum: Ruby
    Replies:
    5
    Views:
    156
    NAKAMURA, Hiroshi
    Sep 18, 2004
  3. Paul  Wolpe
    Replies:
    0
    Views:
    171
    Paul Wolpe
    Oct 17, 2005
  4. Ara.T.Howard

    http-access2 help

    Ara.T.Howard, Nov 3, 2005, in forum: Ruby
    Replies:
    3
    Views:
    180
    Ara.T.Howard
    Nov 3, 2005
  5. Ara.T.Howard

    [BUG/PATCH] http-access2

    Ara.T.Howard, Nov 4, 2005, in forum: Ruby
    Replies:
    4
    Views:
    126
Loading...

Share This Page