Build openssl-0.9.8e with Cygwin problem

Discussion in 'C++' started by Allen, Jun 5, 2007.

  1. Allen

    Allen Guest

    I use current Cygwin to build openssl-0.9.8e for Vxworks on Windows XP
    platform.

    Run ./Configure no-asm no-threads --openssldir d:/openssl vxworks-
    ppc405 is Ok.
    And then run make from bash console.

    It tells the follow error for compiling each .c file.

    d:\tornado2.2\host\x86-win32\bin\ccppc.exe: *** conflicting versions
    of cygwin1.dll detected. Use only the most recent version.

    I download Cygwin yesterday. It is current version.

    Please help me out. I have spent 3 days to build openssl for vxworks.

    Thank you.
     
    Allen, Jun 5, 2007
    #1
    1. Advertising

  2. Allen

    Lionel B Guest

    Re: [OT] Build openssl-0.9.8e with Cygwin problem

    On Tue, 05 Jun 2007 05:33:14 -0700, Allen wrote:

    > I use current Cygwin to build openssl-0.9.8e for Vxworks on Windows XP
    > platform.
    >
    > Run ./Configure no-asm no-threads --openssldir d:/openssl vxworks-
    > ppc405 is Ok.
    > And then run make from bash console.
    >
    > It tells the follow error for compiling each .c file.
    >
    > d:\tornado2.2\host\x86-win32\bin\ccppc.exe: *** conflicting versions of
    > cygwin1.dll detected. Use only the most recent version.
    >
    > I download Cygwin yesterday. It is current version.


    This is off-topic here (this group deals only with C++ *language* issues)
    - you should really ask this on an openssl and/or Cygwin forum.

    However... IIRC there are many 3rd party applications that use Cygwin
    utilities and install their own version of cygwin1.dll. Search for files
    of that name on your system and try renaming any you find that are not in
    the Cygwin install directory (this may well break something else, I
    guess...).

    --
    Lionel B
     
    Lionel B, Jun 5, 2007
    #2
    1. Advertising

  3. Allen

    Allen Guest

    On 6 5 , 8 46 , Lionel B <> wrote:
    > On Tue, 05 Jun 2007 05:33:14 -0700, Allen wrote:
    > > I use current Cygwin to build openssl-0.9.8e for Vxworks on Windows XP
    > > platform.

    >
    > > Run ./Configure no-asm no-threads --openssldir d:/openssl vxworks-
    > > ppc405 is Ok.
    > > And then run make from bash console.

    >
    > > It tells the follow error for compiling each .c file.

    >
    > > d:\tornado2.2\host\x86-win32\bin\ccppc.exe: *** conflicting versions of
    > > cygwin1.dll detected. Use only the most recent version.

    >
    > > I download Cygwin yesterday. It is current version.

    >
    > This is off-topic here (this group deals only with C++ *language* issues)
    > - you should really ask this on an openssl and/or Cygwin forum.
    >
    > However... IIRC there are many 3rd party applications that use Cygwin
    > utilities and install their own version of cygwin1.dll. Search for files
    > of that name on your system and try renaming any you find that are not in
    > the Cygwin install directory (this may well break something else, I
    > guess...).
    >
    > --
    > Lionel B


    Sorry. I should sent to com.os.vxworks group.
    Thank you for your reply.
     
    Allen, Jun 5, 2007
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    0
    Views:
    462
  2. Replies:
    0
    Views:
    434
  3. WELCOME to

    , Sep 3, 2003, in forum: Python
    Replies:
    1
    Views:
    514
    Robin Becker
    Sep 5, 2003
  4. Nicolas Lehuen
    Replies:
    3
    Views:
    721
    Nicolas Lehuen
    Jan 28, 2004
  5. Redd Vinylene
    Replies:
    6
    Views:
    306
    Jakub Pawlowicz
    Nov 18, 2008
Loading...

Share This Page