Can I Have Your Permission Please?

Discussion in 'ASP .Net' started by wASP, Jul 10, 2005.

  1. wASP

    wASP Guest

    Hi,

    Apparently, I have a permissions issue. I am logged in as administrator,
    and my C: drive is accessible. Under the "Security" tab for Properties
    for Inetpub, for my "Internet Guest Account," the "Allow" boxes
    for [read & execute], [list folder contents], and [Read] are checked
    - BUT they are greyed out - I cannot clear them - and nothing else
    is checked.

    Now that I look further, the same thing is the case for every folder
    in the root that I examined.

    I'm a newbie starting up with ASP.NET,
    and I'm getting off to a wonderful start
    - and when I tell you "wonderful" I'm being sarcastic.

    My OS is Win 2000 SP4.

    I've gotten IIS installed, along with the .NET framework.

    I have the .NET Framework 1.1 configuration tool in Administrative tools,
    along with the Wizards. I have opened the configuration tool,
    but I have no idea as to what I'm looking at.

    My code is about as simple as it can get:
    ===============================================
    <%@ Page Language="C#" %>

    <script runat="server">
    void page_load(object obj, EventArgs e)
    { lblMessage.Text = "Hello World";
    }
    </script>

    <html><body>
    <asp:Label id="lblMessage" runat="server"/>
    </body></html>
    ===============================================

    ... right from the book.

    I put the file into my webroot directory:
    C:\Inetpub\wwwroot\

    ... and this URL into the IE6 address bar:
    http://localhost/HelloWorld01.aspx

    When I hit "GO" I get the following error message:
    ===================================================================

    Server Error in '/' Application.
    --------------------------------------------------------------------------------

    Server cannot access application directory 'c:\inetpub\wwwroot\'.
    The directory does not exist or is not accessible because of security settings.
    Description: An unhandled exception occurred during the execution of the current
    web request. Please review the stack trace for more information about the error
    and where it originated in the code.

    Exception Details: System.Web.HttpException: Server cannot access application
    directory 'c:\inetpub\wwwroot\'. The directory does not exist or is not accessible
    because of security settings.


    Source Error:

    An unhandled exception was generated during the execution of the current web request.
    Information regarding the origin and location of the exception can be identified using
    the exception stack trace below.


    Stack Trace:

    [HttpException (0x80004005): Server cannot access application directory
    'c:\inetpub\wwwroot\'.
    The directory does not exist or is not accessible because of security settings.]
    System.Web.HttpRuntime.EnsureAccessToApplicationDirectory() +72
    System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +263

    [HttpException (0x80004005): ASP.NET Initialization Error]
    System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +983
    System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +128

    --------------------------------------------------------------------------------
    Version Information: Microsoft .NET Framework Version:1.1.4322.2032; ASP.NET
    Version:1.1.4322.2032

    ===================================================================


    BEFORE anyone asks, I cleaned out the cash for the browser ...

    C:\Documents and Settings\Administrator\Local Settings\Temporary Internet Files\
    (for IE6)

    ... and it still doesn't work.


    So this is going just "wonderfully". :-(


    Does anyone know what I can do to solve this permissions issue?


    Thanks In Advance!

    - wASP
     
    wASP, Jul 10, 2005
    #1
    1. Advertising

  2. wASP

    wASP Guest

    Hi again,

    I've found the following kb article:
    http://support.microsoft.com/kb/316721

    I did the following, as instructed by the article:
    ::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
    RESOLUTION
    To add read, execute, and list access for the ASPNET account
    on the root Web site or on any virtual directory, follow these steps:
    1. In Windows Explorer, browse to the folder that contains
    the root Web site (which is C:\Inetpub\Wwwroot by default)
    or the virtual directory.

    2. Right-click the folder, and then click Properties.

    3. On the Security tab, click Add.

    4. Type ComputerName\ASPNET (for example, on a computer named Webdev,
    type Webdev\ASPNET), and then click OK.

    5. Allow the following permissions for the ASPNET account:
    • Read & Execute
    • List Folder Contents
    • Read

    6. Click OK to close the Properties dialog box and to save the changes.


    NOTE: You do not need to perform these steps if the Everyone group or the
    Users group has read access to the root Web site or virtual directory.
    ::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::



    What happens now, when I load the address in the address bar of IE6
    (http://localhost/HelloWorld01.aspx), then click on GO,
    I get a box prompting me for a username, password, and domain.

    This is progress - I think - but what do I do to get it to stop
    prompting me for this and execute the friggin' code?


    Thanks In Advance!

    -wASP
    =======================================================================



    On Sun, 10 Jul 2005 01:26:46 -0500, wASP <wylbur[at]ev1[dot]net> wrote:

    >
    >Hi,
    >
    >Apparently, I have a permissions issue. I am logged in as administrator,
    >and my C: drive is accessible. Under the "Security" tab for Properties
    >for Inetpub, for my "Internet Guest Account," the "Allow" boxes
    >for [read & execute], [list folder contents], and [Read] are checked
    > - BUT they are greyed out - I cannot clear them - and nothing else
    >is checked.
    >
    >Now that I look further, the same thing is the case for every folder
    >in the root that I examined.
    >
    >I'm a newbie starting up with ASP.NET,
    >and I'm getting off to a wonderful start
    > - and when I tell you "wonderful" I'm being sarcastic.
    >
    >My OS is Win 2000 SP4.
    >
    >I've gotten IIS installed, along with the .NET framework.
    >
    >I have the .NET Framework 1.1 configuration tool in Administrative tools,
    >along with the Wizards. I have opened the configuration tool,
    >but I have no idea as to what I'm looking at.
    >
    >My code is about as simple as it can get:
    >===============================================
    ><%@ Page Language="C#" %>
    >
    ><script runat="server">
    >void page_load(object obj, EventArgs e)
    >{ lblMessage.Text = "Hello World";
    >}
    ></script>
    >
    ><html><body>
    > <asp:Label id="lblMessage" runat="server"/>
    ></body></html>
    >===============================================
    >
    > ... right from the book.
    >
    >I put the file into my webroot directory:
    >C:\Inetpub\wwwroot\
    >
    > ... and this URL into the IE6 address bar:
    >http://localhost/HelloWorld01.aspx
    >
    >When I hit "GO" I get the following error message:
    >===================================================================
    >
    >Server Error in '/' Application.
    >--------------------------------------------------------------------------------
    >
    >Server cannot access application directory 'c:\inetpub\wwwroot\'.
    >The directory does not exist or is not accessible because of security settings.
    >Description: An unhandled exception occurred during the execution of the current
    >web request. Please review the stack trace for more information about the error
    >and where it originated in the code.
    >
    >Exception Details: System.Web.HttpException: Server cannot access application
    >directory 'c:\inetpub\wwwroot\'. The directory does not exist or is not accessible
    >because of security settings.
    >
    >
    >Source Error:
    >
    >An unhandled exception was generated during the execution of the current web request.
    >Information regarding the origin and location of the exception can be identified using
    >the exception stack trace below.
    >
    >
    >Stack Trace:
    >
    >[HttpException (0x80004005): Server cannot access application directory
    >'c:\inetpub\wwwroot\'.
    >The directory does not exist or is not accessible because of security settings.]
    > System.Web.HttpRuntime.EnsureAccessToApplicationDirectory() +72
    > System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +263
    >
    >[HttpException (0x80004005): ASP.NET Initialization Error]
    > System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +983
    > System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +128
    >
    >--------------------------------------------------------------------------------
    >Version Information: Microsoft .NET Framework Version:1.1.4322.2032; ASP.NET
    >Version:1.1.4322.2032
    >
    >===================================================================
    >
    >
    >BEFORE anyone asks, I cleaned out the cash for the browser ...
    >
    >C:\Documents and Settings\Administrator\Local Settings\Temporary Internet Files\
    >(for IE6)
    >
    > ... and it still doesn't work.
    >
    >
    >So this is going just "wonderfully". :-(
    >
    >
    >Does anyone know what I can do to solve this permissions issue?
    >
    >
    >Thanks In Advance!
    >
    >- wASP


    - wASP
     
    wASP, Jul 10, 2005
    #2
    1. Advertising

  3. wASP <wylbur[at]ev1[dot]net> wrote:

    > ...
    > What happens now, when I load the address in the address bar of IE6
    > (http://localhost/HelloWorld01.aspx), then click on GO,
    > I get a box prompting me for a username, password, and domain.
    >
    > This is progress - I think - but what do I do to get it to stop
    > prompting me for this and execute the friggin' code?


    Assuming anonymous access is acceptable ....

    Right-click "My Computer" and select manage

    Navigate to "Services..." ---> "IIS" ---> <your site>

    Rightclick <your site> and select properties ....

    Click tab: "directory permissions"

    Click "edit" button

    Remove any ticks (check marks) against the authentication options.

    Ensure Anonymous is ticked (checked)


    --
    William Tasso
     
    William Tasso, Jul 10, 2005
    #3
  4. wASP

    wASP Guest

    On Sun, 10 Jul 2005 18:06:36 +0100, "William Tasso" <> wrote:

    >wASP <wylbur[at]ev1[dot]net> wrote:
    >
    >> ...
    >> What happens now, when I load the address in the address bar of IE6
    >> (http://localhost/HelloWorld01.aspx), then click on GO,
    >> I get a box prompting me for a username, password, and domain.
    >>
    >> This is progress - I think - but what do I do to get it to stop
    >> prompting me for this and execute the friggin' code?

    >
    >Assuming anonymous access is acceptable ....
    >
    >Right-click "My Computer" and select manage
    >
    >Navigate to "Services..." ---> "IIS" ---> <your site>
    >
    >Rightclick <your site> and select properties ....
    >
    >Click tab: "directory permissions"


    Actually, it's "directory security" (in Win2k) - but I know what you mean.


    >Click "edit" button
    >
    >Remove any ticks (check marks) against the authentication options.
    >
    >Ensure Anonymous is ticked (checked)



    THAT solved it - it's official: You're a genius!


    Thank you William Tasso!


    - wASP
     
    wASP, Jul 10, 2005
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. KK
    Replies:
    2
    Views:
    595
    Big Brian
    Oct 14, 2003
  2. mark4asp
    Replies:
    2
    Views:
    620
    Jasbird
    Nov 11, 2006
  3. Mark Shapiro
    Replies:
    3
    Views:
    559
    Mark Shapiro
    Oct 8, 2011
  4. c676228
    Replies:
    3
    Views:
    176
    c676228
    Sep 14, 2006
  5. Tae Wong
    Replies:
    0
    Views:
    94
    Tae Wong
    Oct 12, 2013
Loading...

Share This Page