Can`t debug asp.net application

Discussion in 'ASP .Net' started by Serg, Nov 24, 2004.

  1. Serg

    Serg Guest

    I have created simplest asp.net application. And it starts normally. But i
    can`t debug it.
    I am always getting an error:
    "You do not have permisssion to debug the server. Verify that you are member
    of the DebuggerUsers "
    But I am a member of Debugger Users group and I am a local admin.
    I have checked *.aspx it is settled to
    ....Framework\v2.0.40607\aspnet_isapi.dll
    I have enabled anonymous access and enabled integrated wind auth.
    I have enabled ASP server-side script debugging and ASP client-side script
    debugging

    What anything else can it be?

    I am using win2003server.
    Did anybody had experienced this? Please help.
    thanks in adv
    Serg
     
    Serg, Nov 24, 2004
    #1
    1. Advertising

  2. I had a similar problem on a computer with both VS 2k5 and VS 2k3 installed.

    If you are developing for ASP.NET 2.0 (Whidbey) then you have a different
    problem but if you are writing an app for ASP.NET 1.1 (in 2003) you will want
    to set the ASP.NET framework property to "v1.1.xxxxx" in IIS (right-click on
    the application, click on properties, go to the ASP.NET tab). I found that my
    applications default to the v2.0 framework and that won't let v1.1 apps debug.

    "Serg" wrote:

    > I have created simplest asp.net application. And it starts normally. But i
    > can`t debug it.
    > I am always getting an error:
    > "You do not have permisssion to debug the server. Verify that you are member
    > of the DebuggerUsers "
    > But I am a member of Debugger Users group and I am a local admin.
    > I have checked *.aspx it is settled to
    > ....Framework\v2.0.40607\aspnet_isapi.dll
    > I have enabled anonymous access and enabled integrated wind auth.
    > I have enabled ASP server-side script debugging and ASP client-side script
    > debugging
    >
    > What anything else can it be?
    >
    > I am using win2003server.
    > Did anybody had experienced this? Please help.
    > thanks in adv
    > Serg
    >
    >
    >
     
    =?Utf-8?B?UGF0cmlkZ2U=?=, Nov 24, 2004
    #2
    1. Advertising

  3. Serg

    Serg Guest

    Thanks for reply
    I am using VS2003
    I have tried both Framework versions 1.1 and 2.0
    I had reconfigured my DefaultWebSite and my Application to Framework
    1.1.4322
    It does not have any affect.
    I can successfuly start app without debugging but can`t debug with the same
    error.



    "Patridge" <> wrote in message
    news:...
    > I had a similar problem on a computer with both VS 2k5 and VS 2k3

    installed.
    >
    > If you are developing for ASP.NET 2.0 (Whidbey) then you have a different
    > problem but if you are writing an app for ASP.NET 1.1 (in 2003) you will

    want
    > to set the ASP.NET framework property to "v1.1.xxxxx" in IIS (right-click

    on
    > the application, click on properties, go to the ASP.NET tab). I found that

    my
    > applications default to the v2.0 framework and that won't let v1.1 apps

    debug.
    >
    > "Serg" wrote:
    >
    > > I have created simplest asp.net application. And it starts normally. But

    i
    > > can`t debug it.
    > > I am always getting an error:
    > > "You do not have permisssion to debug the server. Verify that you are

    member
    > > of the DebuggerUsers "
    > > But I am a member of Debugger Users group and I am a local admin.
    > > I have checked *.aspx it is settled to
    > > ....Framework\v2.0.40607\aspnet_isapi.dll
    > > I have enabled anonymous access and enabled integrated wind auth.
    > > I have enabled ASP server-side script debugging and ASP client-side

    script
    > > debugging
    > >
    > > What anything else can it be?
    > >
    > > I am using win2003server.
    > > Did anybody had experienced this? Please help.
    > > thanks in adv
    > > Serg
    > >
    > >
    > >
     
    Serg, Nov 24, 2004
    #3
  4. Serg

    Jeff Dillon Guest

    If Anonymous is on, then the app is running under the ASPNET account (or
    possibly Network Service). These accounts (and add IUSR_ while you're
    there) should also be in the Debuggers group.

    Or simply turn off Anonymous. This works great if you are debugging sitting
    at the server console. If your web server is not your desktop, then try
    turning on Basic. Then the application will be running under your user
    context.

    Jeff
    "Serg" <> wrote in message
    news:...
    > I have created simplest asp.net application. And it starts normally. But i
    > can`t debug it.
    > I am always getting an error:
    > "You do not have permisssion to debug the server. Verify that you are

    member
    > of the DebuggerUsers "
    > But I am a member of Debugger Users group and I am a local admin.
    > I have checked *.aspx it is settled to
    > ...Framework\v2.0.40607\aspnet_isapi.dll
    > I have enabled anonymous access and enabled integrated wind auth.
    > I have enabled ASP server-side script debugging and ASP client-side script
    > debugging
    >
    > What anything else can it be?
    >
    > I am using win2003server.
    > Did anybody had experienced this? Please help.
    > thanks in adv
    > Serg
    >
    >
     
    Jeff Dillon, Nov 24, 2004
    #4
  5. Serg

    Serg Guest

    Thanks Jeff
    Both ways are workable.
    I have chosen second.


    "Jeff Dillon" <> wrote in message
    news:...
    > If Anonymous is on, then the app is running under the ASPNET account (or
    > possibly Network Service). These accounts (and add IUSR_ while you're
    > there) should also be in the Debuggers group.
    >
    > Or simply turn off Anonymous. This works great if you are debugging

    sitting
    > at the server console. If your web server is not your desktop, then try
    > turning on Basic. Then the application will be running under your user
    > context.
    >
    > Jeff
    > "Serg" <> wrote in message
    > news:...
    > > I have created simplest asp.net application. And it starts normally. But

    i
    > > can`t debug it.
    > > I am always getting an error:
    > > "You do not have permisssion to debug the server. Verify that you are

    > member
    > > of the DebuggerUsers "
    > > But I am a member of Debugger Users group and I am a local admin.
    > > I have checked *.aspx it is settled to
    > > ...Framework\v2.0.40607\aspnet_isapi.dll
    > > I have enabled anonymous access and enabled integrated wind auth.
    > > I have enabled ASP server-side script debugging and ASP client-side

    script
    > > debugging
    > >
    > > What anything else can it be?
    > >
    > > I am using win2003server.
    > > Did anybody had experienced this? Please help.
    > > thanks in adv
    > > Serg
    > >
    > >

    >
    >
     
    Serg, Nov 25, 2004
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?U1hM?=
    Replies:
    1
    Views:
    1,988
    Brian K. Williams
    Feb 20, 2004
  2. =?Utf-8?B?QWFyb24gQ2FsaQ==?=

    Unable to Debug ASP.NET application when disconnected from the net

    =?Utf-8?B?QWFyb24gQ2FsaQ==?=, Jun 17, 2004, in forum: ASP .Net
    Replies:
    0
    Views:
    311
    =?Utf-8?B?QWFyb24gQ2FsaQ==?=
    Jun 17, 2004
  3. =?Utf-8?B?QWFyb24gQ2FsaQ==?=

    Unable to Debug ASP.NET application when disconnected from the net

    =?Utf-8?B?QWFyb24gQ2FsaQ==?=, Jun 17, 2004, in forum: ASP .Net
    Replies:
    1
    Views:
    307
    Trevor Benedict R
    Jun 18, 2004
  4. =?Utf-8?B?bXN1aw==?=
    Replies:
    3
    Views:
    465
    =?Utf-8?B?bXN1aw==?=
    Aug 11, 2004
  5. Jose Luis

    Can't debug my ASP .NET web application

    Jose Luis, Jan 12, 2005, in forum: ASP .Net
    Replies:
    1
    Views:
    362
    John F
    Jan 12, 2005
Loading...

Share This Page