Cannot access webservices from windows application

Discussion in 'ASP .Net Web Services' started by Paul, Aug 17, 2006.

  1. Paul

    Paul Guest

    I am using .NET 1.1 with SP1 under windows xp with a dialup connection
    and I cannot access ANY webservices on the internet. I can access them
    if they are on the localhost via IIS. I have searched the web for
    others that are experiencing this problem and people have suggested
    changing the .NET FrameWork settings but not which ones.
    Any suggestions would really be appreciated.
    Thanks
    Paul
     
    Paul, Aug 17, 2006
    #1
    1. Advertising

  2. Paul

    Josh Twist Guest

    What are you trying to access the Web Service with? Your browser? A
    customer .NET 1.1 win app?

    If it's the latter, first try accessing the web services using your
    browser, (try the WSDL). Check that it's not windows firewall stopping
    you getting there.

    Also, exactly what happens when you try to access a web service? Do you
    get an error? What's the details?

    Josh


    Paul wrote:
    > I am using .NET 1.1 with SP1 under windows xp with a dialup connection
    > and I cannot access ANY webservices on the internet. I can access them
    > if they are on the localhost via IIS. I have searched the web for
    > others that are experiencing this problem and people have suggested
    > changing the .NET FrameWork settings but not which ones.
    > Any suggestions would really be appreciated.
    > Thanks
    > Paul
     
    Josh Twist, Aug 18, 2006
    #2
    1. Advertising

  3. Paul

    Paul Guest

    Thanks for the reply Josh.
    To answer your question: I just now tried to run a simple win app
    provided with the google api and I get

    "An unhandled exception of type 'System.Net.WebException' occurred in
    system.dll. Additional information: The underlying connection was
    closed: Unable to connect to the remote server."

    I made a web app that makes the exact same call as that tried in the
    win app and it works fine.

    I have tried everything I can think of.
    1) Disabled my firewall.
    2) Disabled virus software
    3) Lifted all restrictions on internet zone secutity

    I have seen this problem complained about before in newsgroups but no
    solution found.

    Thanks again
    Paul




    Josh Twist wrote:
    > What are you trying to access the Web Service with? Your browser? A
    > customer .NET 1.1 win app?
    >
    > If it's the latter, first try accessing the web services using your
    > browser, (try the WSDL). Check that it's not windows firewall stopping
    > you getting there.
    >
    > Also, exactly what happens when you try to access a web service? Do you
    > get an error? What's the details?
    >
    > Josh
    >
    >
    > Paul wrote:
    > > I am using .NET 1.1 with SP1 under windows xp with a dialup connection
    > > and I cannot access ANY webservices on the internet. I can access them
    > > if they are on the localhost via IIS. I have searched the web for
    > > others that are experiencing this problem and people have suggested
    > > changing the .NET FrameWork settings but not which ones.
    > > Any suggestions would really be appreciated.
    > > Thanks
    > > Paul
     
    Paul, Aug 18, 2006
    #3
  4. Paul,

    Just trying a couple of things. Have you made sure you do not require
    any WebCredentials?

    http://msdn.microsoft.com/library/d...olsWebClientProtocolClassCredentialsTopic.asp

    Secondly, I am assuming the proxy class works fine in web forms but not
    win forms? Or are you using web references to create them?


    Paul wrote:
    > Thanks for the reply Josh.
    > To answer your question: I just now tried to run a simple win app
    > provided with the google api and I get
    >
    > "An unhandled exception of type 'System.Net.WebException' occurred in
    > system.dll. Additional information: The underlying connection was
    > closed: Unable to connect to the remote server."
    >
    > I made a web app that makes the exact same call as that tried in the
    > win app and it works fine.
    >
    > I have tried everything I can think of.
    > 1) Disabled my firewall.
    > 2) Disabled virus software
    > 3) Lifted all restrictions on internet zone secutity
    >
    > I have seen this problem complained about before in newsgroups but no
    > solution found.
    >
    > Thanks again
    > Paul
    >
    >
    >
    >
    > Josh Twist wrote:
    > > What are you trying to access the Web Service with? Your browser? A
    > > customer .NET 1.1 win app?
    > >
    > > If it's the latter, first try accessing the web services using your
    > > browser, (try the WSDL). Check that it's not windows firewall stopping
    > > you getting there.
    > >
    > > Also, exactly what happens when you try to access a web service? Do you
    > > get an error? What's the details?
    > >
    > > Josh
    > >
    > >
    > > Paul wrote:
    > > > I am using .NET 1.1 with SP1 under windows xp with a dialup connection
    > > > and I cannot access ANY webservices on the internet. I can access them
    > > > if they are on the localhost via IIS. I have searched the web for
    > > > others that are experiencing this problem and people have suggested
    > > > changing the .NET FrameWork settings but not which ones.
    > > > Any suggestions would really be appreciated.
    > > > Thanks
    > > > Paul
     
    Sarat Pediredla, Aug 20, 2006
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. news.microsoft.com
    Replies:
    4
    Views:
    5,004
    =?Utf-8?B?Q2hpbm1heQ==?=
    Jan 10, 2005
  2. Ram
    Replies:
    2
    Views:
    7,249
    Paul Glavich [MVP ASP.NET]
    Jun 30, 2005
  3. ary
    Replies:
    0
    Views:
    689
  4. tshad
    Replies:
    0
    Views:
    135
    tshad
    Feb 27, 2006
  5. guru
    Replies:
    4
    Views:
    373
    J. Gleixner
    Feb 18, 2009
Loading...

Share This Page