Cannot debug web application "Cannot create/shadow copy ..."

Discussion in 'ASP .Net' started by Waldy, Aug 1, 2007.

  1. Waldy

    Waldy Guest

    Hi there,
    does anyone know the cause of this problem. When I press F5
    to debug a C# web application, I get an error message that begins "Cannot
    create/shadow copy " then various different file names. Sometimes I can
    debug, other times I get the message above.

    Regards,

    Steve W.
     
    Waldy, Aug 1, 2007
    #1
    1. Advertising

  2. On Aug 1, 3:26 pm, "Waldy" <> wrote:
    > Hi there,
    > does anyone know the cause of this problem. When I press F5
    > to debug a C# web application, I get an error message that begins "Cannot
    > create/shadow copy " then various different file names. Sometimes I can
    > debug, other times I get the message above.
    >
    > Regards,
    >
    > Steve W.


    try to "Clean Solutions" before you build it.
    http://www.connect.microsoft.com/VisualStudio/feedback/Workaround.aspx?FeedbackID=227522
     
    Alexey Smirnov, Aug 1, 2007
    #2
    1. Advertising

  3. On Aug 1, 3:57 pm, Alexey Smirnov <> wrote:
    > On Aug 1, 3:26 pm, "Waldy" <> wrote:
    >
    > > Hi there,
    > > does anyone know the cause of this problem. When I press F5
    > > to debug a C# web application, I get an error message that begins "Cannot
    > > create/shadow copy " then various different file names. Sometimes I can
    > > debug, other times I get the message above.

    >
    > > Regards,

    >
    > > Steve W.

    >
    > try to "Clean Solutions" before you build it.http://www.connect.microsoft.com/VisualStudio/feedback/Workaround.asp...


    and there is also a web.config key that might fix it

    <hostingEnvironment shadowCopyBinAssemblies="false" />

    http://bloggingabout.net/blogs/rick...-info-here-when-that-file-already-exists.aspx
     
    Alexey Smirnov, Aug 1, 2007
    #3
  4. Waldy

    HockeyFan Guest

    I get this from time to time. Clean Solution usually fixes it. It
    shouldn't be a problem for you.
     
    HockeyFan, Aug 1, 2007
    #4
  5. Waldy

    Waldy Guest

    Doing a Clean has no effect. I have to stop the ASP.Net Web Development
    server every time it happens, which is starting to get on my nerves. I'll
    try the config setting.

    "Alexey Smirnov" <> wrote in message
    news:...
    > On Aug 1, 3:57 pm, Alexey Smirnov <> wrote:
    >> On Aug 1, 3:26 pm, "Waldy" <> wrote:
    >>
    >> > Hi there,
    >> > does anyone know the cause of this problem. When I press
    >> > F5
    >> > to debug a C# web application, I get an error message that begins
    >> > "Cannot
    >> > create/shadow copy " then various different file names. Sometimes I
    >> > can
    >> > debug, other times I get the message above.

    >>
    >> > Regards,

    >>
    >> > Steve W.

    >>
    >> try to "Clean Solutions" before you build
    >> it.http://www.connect.microsoft.com/VisualStudio/feedback/Workaround.asp...

    >
    > and there is also a web.config key that might fix it
    >
    > <hostingEnvironment shadowCopyBinAssemblies="false" />
    >
    > http://bloggingabout.net/blogs/rick...-info-here-when-that-file-already-exists.aspx
    >
     
    Waldy, Aug 3, 2007
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. RonL
    Replies:
    0
    Views:
    748
  2. Frank Rizzo

    Weird Cannot create/shadow copy error

    Frank Rizzo, Apr 25, 2006, in forum: ASP .Net
    Replies:
    0
    Views:
    4,910
    Frank Rizzo
    Apr 25, 2006
  3. =?Utf-8?B?UGF0cmljayBG?=

    Cannot create/shadow copy ?

    =?Utf-8?B?UGF0cmljayBG?=, Aug 9, 2006, in forum: ASP .Net
    Replies:
    0
    Views:
    2,619
    =?Utf-8?B?UGF0cmljayBG?=
    Aug 9, 2006
  4. André
    Replies:
    3
    Views:
    1,596
  5. =?Utf-8?B?QWxoYW1icmEgRWlkb3MgS2lxdWVuZXQ=?=

    Cannot Create/Shadow Copy Error

    =?Utf-8?B?QWxoYW1icmEgRWlkb3MgS2lxdWVuZXQ=?=, Apr 17, 2007, in forum: ASP .Net
    Replies:
    0
    Views:
    393
    =?Utf-8?B?QWxoYW1icmEgRWlkb3MgS2lxdWVuZXQ=?=
    Apr 17, 2007
Loading...

Share This Page