Can't debug simple C# Web Service

Discussion in 'ASP .Net Web Services' started by Craig, Jun 14, 2005.

  1. Craig

    Craig Guest

    First, a confession. I am developing with an old version of VS .NET:

    VS .NET 2002 (7.0.9955).

    I am trying to start a *very* simple Web Service in debug mode. I'm getting
    this message:

    "Error while trying to run project: Unable to start debugging on the web
    server. You do not have permissions to debug the server.

    Verify that you are a member of the 'Debugger Users' group on the server.
    Would you like to disable future attempts to debug ASP.NET pages for this
    project?"

    The server is the localhost (Windows XP Service Pack 2).

    I'm signed on as a local user (rather than a domain user name) and my user
    name is in the Debugger Users group.

    Under the project properties the Debuggers settings are:

    Enable ASP Debugging: False
    Enable ASP.NET Debugging: True
    Enable Unmanaged Debugging: False
    Enable SQL Debugging: False

    Any ideas?

    Craig
    Craig, Jun 14, 2005
    #1
    1. Advertising

  2. Craig

    Brock Allen Guest

    You also need web.config to allow debugging:

    <system.web>
    <compilation debug="true" />
    </system.web>


    -Brock
    DevelopMentor
    http://staff.develop.com/ballen



    > First, a confession. I am developing with an old version of VS .NET:
    >
    > VS .NET 2002 (7.0.9955).
    >
    > I am trying to start a *very* simple Web Service in debug mode. I'm
    > getting this message:
    >
    > "Error while trying to run project: Unable to start debugging on the
    > web server. You do not have permissions to debug the server.
    >
    > Verify that you are a member of the 'Debugger Users' group on the
    > server. Would you like to disable future attempts to debug ASP.NET
    > pages for this project?"
    >
    > The server is the localhost (Windows XP Service Pack 2).
    >
    > I'm signed on as a local user (rather than a domain user name) and my
    > user name is in the Debugger Users group.
    >
    > Under the project properties the Debuggers settings are:
    >
    > Enable ASP Debugging: False
    > Enable ASP.NET Debugging: True
    > Enable Unmanaged Debugging: False
    > Enable SQL Debugging: False
    > Any ideas?
    >
    > Craig
    >
    Brock Allen, Jun 14, 2005
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. George
    Replies:
    1
    Views:
    303
  2. RonL
    Replies:
    0
    Views:
    730
  3. André
    Replies:
    3
    Views:
    1,562
  4. Leo Violette
    Replies:
    0
    Views:
    1,003
    Leo Violette
    Apr 17, 2009
  5. Jacob N.
    Replies:
    0
    Views:
    84
    Jacob N.
    Dec 29, 2010
Loading...

Share This Page