Can't hit the site by name but I can hit by IP

Discussion in 'ASP .Net' started by CK, Oct 19, 2006.

  1. CK

    CK Guest

    Hi All,
    I have a sharepoint site on a box. I can hit the box by going to the ip
    address http://10.0.0.1/default.aspx but I can not hit it by name. The
    password dialong box comes up and it rejects my domain password. Says you
    are not authorized. When I use the IP the password dialong box comes up and
    it accepts my credentials and lets me proceed to the site. What am I missing
    here? Any help is greatly appreciated.

    TIA,
    ~CK
     
    CK, Oct 19, 2006
    #1
    1. Advertising

  2. This looks like a name resolution issue. When going to the machine name
    are you going to the same IP address.

    ping by name make sure IP address is correct.


    CK wrote:
    > Hi All,
    > I have a sharepoint site on a box. I can hit the box by going to the ip
    > address http://10.0.0.1/default.aspx but I can not hit it by name. The
    > password dialong box comes up and it rejects my domain password. Says you
    > are not authorized. When I use the IP the password dialong box comes up and
    > it accepts my credentials and lets me proceed to the site. What am I missing
    > here? Any help is greatly appreciated.
    >
    > TIA,
    > ~CK
    >
    >
     
    Jerry Rasmussen, Oct 19, 2006
    #2
    1. Advertising

  3. CK

    CK Guest

    Yes from a command prompt pinging the IP and Pinging the machine name both
    go to the same computer. Both cases respond to the ping as well.


    "Jerry Rasmussen" <> wrote in message
    news:...
    > This looks like a name resolution issue. When going to the machine name
    > are you going to the same IP address.
    >
    > ping by name make sure IP address is correct.
    >
    >
    > CK wrote:
    >> Hi All,
    >> I have a sharepoint site on a box. I can hit the box by going to the ip
    >> address http://10.0.0.1/default.aspx but I can not hit it by name. The
    >> password dialong box comes up and it rejects my domain password. Says you
    >> are not authorized. When I use the IP the password dialong box comes up
    >> and it accepts my credentials and lets me proceed to the site. What am I
    >> missing here? Any help is greatly appreciated.
    >>
    >> TIA,
    >> ~CK
     
    CK, Oct 19, 2006
    #3
  4. is their more than one site hosted on this computer?

    Also what names are listed in the alternate access mappings?



    CK wrote:
    > Yes from a command prompt pinging the IP and Pinging the machine name both
    > go to the same computer. Both cases respond to the ping as well.
    >
    >
    > "Jerry Rasmussen" <> wrote in message
    > news:...
    >> This looks like a name resolution issue. When going to the machine name
    >> are you going to the same IP address.
    >>
    >> ping by name make sure IP address is correct.
    >>
    >>
    >> CK wrote:
    >>> Hi All,
    >>> I have a sharepoint site on a box. I can hit the box by going to the ip
    >>> address http://10.0.0.1/default.aspx but I can not hit it by name. The
    >>> password dialong box comes up and it rejects my domain password. Says you
    >>> are not authorized. When I use the IP the password dialong box comes up
    >>> and it accepts my credentials and lets me proceed to the site. What am I
    >>> missing here? Any help is greatly appreciated.
    >>>
    >>> TIA,
    >>> ~CK

    >
    >
     
    Jerry Rasmussen, Oct 19, 2006
    #4
  5. CK

    CK Guest

    There is default website and Sharepoint Admin website.

    Where do I set the alternate access mappings. I am not familiar with that.

    Thanks Jerry for your help.

    ~CK

    "Jerry Rasmussen" <> wrote in message
    news:...
    > is their more than one site hosted on this computer?
    >
    > Also what names are listed in the alternate access mappings?
    >
    >
    >
    > CK wrote:
    >> Yes from a command prompt pinging the IP and Pinging the machine name
    >> both go to the same computer. Both cases respond to the ping as well.
    >>
    >>
    >> "Jerry Rasmussen" <> wrote in message
    >> news:...
    >>> This looks like a name resolution issue. When going to the machine name
    >>> are you going to the same IP address.
    >>>
    >>> ping by name make sure IP address is correct.
    >>>
    >>>
    >>> CK wrote:
    >>>> Hi All,
    >>>> I have a sharepoint site on a box. I can hit the box by going to the ip
    >>>> address http://10.0.0.1/default.aspx but I can not hit it by name. The
    >>>> password dialong box comes up and it rejects my domain password. Says
    >>>> you are not authorized. When I use the IP the password dialong box
    >>>> comes up and it accepts my credentials and lets me proceed to the site.
    >>>> What am I missing here? Any help is greatly appreciated.
    >>>>
    >>>> TIA,
    >>>> ~CK

    >>
     
    CK, Oct 19, 2006
    #5
  6. Is this 03 or 07? If it is 03, good rule of thumb is to add it to the Hosts
    file. Also, check the Central Administration and check the Name of the Portal
    that was created - often the mismatch (i.e. if it was created and named with
    the IP address) is the problem - this is the same issue if using HTTPS vs.
    HTTP - if the site is defined as HTTP://something then you turn on HTTPS, the
    site is not always found.

    --
    David M. Sterling
    www.sterling-consulting.com


    "Jerry Rasmussen" wrote:

    > is their more than one site hosted on this computer?
    >
    > Also what names are listed in the alternate access mappings?
    >
    >
    >
    > CK wrote:
    > > Yes from a command prompt pinging the IP and Pinging the machine name both
    > > go to the same computer. Both cases respond to the ping as well.
    > >
    > >
    > > "Jerry Rasmussen" <> wrote in message
    > > news:...
    > >> This looks like a name resolution issue. When going to the machine name
    > >> are you going to the same IP address.
    > >>
    > >> ping by name make sure IP address is correct.
    > >>
    > >>
    > >> CK wrote:
    > >>> Hi All,
    > >>> I have a sharepoint site on a box. I can hit the box by going to the ip
    > >>> address http://10.0.0.1/default.aspx but I can not hit it by name. The
    > >>> password dialong box comes up and it rejects my domain password. Says you
    > >>> are not authorized. When I use the IP the password dialong box comes up
    > >>> and it accepts my credentials and lets me proceed to the site. What am I
    > >>> missing here? Any help is greatly appreciated.
    > >>>
    > >>> TIA,
    > >>> ~CK

    > >
    > >

    >
     
    =?Utf-8?B?RGF2aWQgU3Rlcmxpbmc=?=, Oct 19, 2006
    #6
  7. Sounds like your TCP/IP stack is corrupt.

    You may work around it by

    1. putting an entry in your hosts file which points your domain name to the IP
    ( a hack workaround... )

    2. Repairing your TCP/IP stack

    If you're using Windows XP, or Windows 2003 Server, repairing the TCP/IP stack isn't complicated.

    From a command window, run :

    netsh int ip reset c:\log.txt

    You can also run the commands in sequence :

    cmd
    netsh
    int
    ip
    reset c:\log.txt

    That will repair your TCP/IP stack.


    Make sure that whatever log name you use and wherever it is on the disk,
    that the file exists and you have SOMETHING there. That's important!

    Read the log afterwads, so you can see the changes that were made.
    It makes for interesting reading ( only for geeky guys... )

    :)





    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ===================================

    "CK" <> wrote in message
    news:p%OZg.17938$...
    > Yes from a command prompt pinging the IP and Pinging the machine name both go to the same
    > computer. Both cases respond to the ping as well.



    > "Jerry Rasmussen" <> wrote in message
    > news:...
    >> This looks like a name resolution issue. When going to the machine name are you going to the
    >> same IP address.
    >>
    >> ping by name make sure IP address is correct.
    >>
    >>
    >> CK wrote:
    >>> Hi All,
    >>> I have a sharepoint site on a box. I can hit the box by going to the ip address
    >>> http://10.0.0.1/default.aspx but I can not hit it by name. The password dialong box comes up and
    >>> it rejects my domain password. Says you are not authorized. When I use the IP the password
    >>> dialong box comes up and it accepts my credentials and lets me proceed to the site. What am I
    >>> missing here? Any help is greatly appreciated.
    >>>
    >>> TIA,
    >>> ~CK

    >
    >
     
    Juan T. Llibre, Oct 19, 2006
    #7
  8. I should have added a caveat, and it is that this procedure
    will reset *all* your TCP/IP connection settings.

    That means you will have to reconfigure your machine's IP, default gateway, dns servers, etc.
    If you are not familiar with those settings...do NOT do this.

    Have your network manager reset your TCP/IP stack for you.





    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ===================================
    "Juan T. Llibre" <> wrote in message
    news:...
    > Sounds like your TCP/IP stack is corrupt.
    >
    > You may work around it by
    >
    > 1. putting an entry in your hosts file which points your domain name to the IP
    > ( a hack workaround... )
    >
    > 2. Repairing your TCP/IP stack
    >
    > If you're using Windows XP, or Windows 2003 Server, repairing the TCP/IP stack isn't complicated.
    >
    > From a command window, run :
    >
    > netsh int ip reset c:\log.txt
    >
    > You can also run the commands in sequence :
    >
    > cmd
    > netsh
    > int
    > ip
    > reset c:\log.txt
    >
    > That will repair your TCP/IP stack.
    >
    >
    > Make sure that whatever log name you use and wherever it is on the disk,
    > that the file exists and you have SOMETHING there. That's important!
    >
    > Read the log afterwads, so you can see the changes that were made.
    > It makes for interesting reading ( only for geeky guys... )
    >
    > :)
    >
    >
    >
    >
    >
    > Juan T. Llibre, asp.net MVP
    > asp.net faq : http://asp.net.do/faq/
    > foros de asp.net, en español : http://asp.net.do/foros/
    > ===================================
    >
    > "CK" <> wrote in message
    > news:p%OZg.17938$...
    >> Yes from a command prompt pinging the IP and Pinging the machine name both go to the same
    >> computer. Both cases respond to the ping as well.

    >
    >
    >> "Jerry Rasmussen" <> wrote in message
    >> news:...
    >>> This looks like a name resolution issue. When going to the machine name are you going to the
    >>> same IP address.
    >>>
    >>> ping by name make sure IP address is correct.
    >>>
    >>>
    >>> CK wrote:
    >>>> Hi All,
    >>>> I have a sharepoint site on a box. I can hit the box by going to the ip address
    >>>> http://10.0.0.1/default.aspx but I can not hit it by name. The password dialong box comes up
    >>>> and it rejects my domain password. Says you are not authorized. When I use the IP the password
    >>>> dialong box comes up and it accepts my credentials and lets me proceed to the site. What am I
    >>>> missing here? Any help is greatly appreciated.
    >>>>
    >>>> TIA,
    >>>> ~CK

    >>
    >>

    >
    >
     
    Juan T. Llibre, Oct 19, 2006
    #8
  9. Hi Dave/Jerry,

    I work w/ CK and I'm the one that setup the portal site that CK is referring
    to. Here is a little bit more info:

    I'm unable to access the portal site by requesting the portal by name in IE;
    however, if I request the page by IP or by name in Firefox I can successfully
    retrieve the page.

    One other things that I noticed:

    -- Whenever I grant permission to access the site, the Send Email portion of
    the process lists the IP address of the site rather than the site name.

    -- If i request the page by IP in IE and create a sub-site, the FullUrl in
    the Sites table will come be written w/ the IP address rather than the portal
    name. If the user access the IP created site as:
    http://portalName/sites/<created> they're able to retrieve the page

    -- I've added a user as a Reader. This user was able to access the site by
    http://portalName/default.aspx. If they tried http://portalName, they are
    denied access. I added another user to the Reader group and they were not
    able to access the site w/ either address.

    My setup is in a domain w/ SP 03 tied to SQL server 2005 (on another box).

    Any tips or help would be greatly appreciated!

    Thanks,


    JM

    "David Sterling" wrote:

    > Is this 03 or 07? If it is 03, good rule of thumb is to add it to the Hosts
    > file. Also, check the Central Administration and check the Name of the Portal
    > that was created - often the mismatch (i.e. if it was created and named with
    > the IP address) is the problem - this is the same issue if using HTTPS vs.
    > HTTP - if the site is defined as HTTP://something then you turn on HTTPS, the
    > site is not always found.
    >
    > --
    > David M. Sterling
    > www.sterling-consulting.com
    >
    >
    > "Jerry Rasmussen" wrote:
    >
    > > is their more than one site hosted on this computer?
    > >
    > > Also what names are listed in the alternate access mappings?
    > >
    > >
    > >
    > > CK wrote:
    > > > Yes from a command prompt pinging the IP and Pinging the machine name both
    > > > go to the same computer. Both cases respond to the ping as well.
    > > >
    > > >
    > > > "Jerry Rasmussen" <> wrote in message
    > > > news:...
    > > >> This looks like a name resolution issue. When going to the machine name
    > > >> are you going to the same IP address.
    > > >>
    > > >> ping by name make sure IP address is correct.
    > > >>
    > > >>
    > > >> CK wrote:
    > > >>> Hi All,
    > > >>> I have a sharepoint site on a box. I can hit the box by going to the ip
    > > >>> address http://10.0.0.1/default.aspx but I can not hit it by name. The
    > > >>> password dialong box comes up and it rejects my domain password. Says you
    > > >>> are not authorized. When I use the IP the password dialong box comes up
    > > >>> and it accepts my credentials and lets me proceed to the site. What am I
    > > >>> missing here? Any help is greatly appreciated.
    > > >>>
    > > >>> TIA,
    > > >>> ~CK
    > > >
    > > >

    > >
     
    =?Utf-8?B?Sk0=?=, Oct 19, 2006
    #9
  10. I should have asked up front which version you were using. I've had
    MOSS 2007 on my mind so much lately. I have not used SP03 in sometime I
    think it would be best if I step out of this conversation at this point.
    JM wrote:
    > Hi Dave/Jerry,
    >
    > I work w/ CK and I'm the one that setup the portal site that CK is referring
    > to. Here is a little bit more info:
    >
    > I'm unable to access the portal site by requesting the portal by name in IE;
    > however, if I request the page by IP or by name in Firefox I can successfully
    > retrieve the page.
    >
    > One other things that I noticed:
    >
    > -- Whenever I grant permission to access the site, the Send Email portion of
    > the process lists the IP address of the site rather than the site name.
    >
    > -- If i request the page by IP in IE and create a sub-site, the FullUrl in
    > the Sites table will come be written w/ the IP address rather than the portal
    > name. If the user access the IP created site as:
    > http://portalName/sites/<created> they're able to retrieve the page
    >
    > -- I've added a user as a Reader. This user was able to access the site by
    > http://portalName/default.aspx. If they tried http://portalName, they are
    > denied access. I added another user to the Reader group and they were not
    > able to access the site w/ either address.
    >
    > My setup is in a domain w/ SP 03 tied to SQL server 2005 (on another box).
    >
    > Any tips or help would be greatly appreciated!
    >
    > Thanks,
    >
    >
    > JM
    >
    > "David Sterling" wrote:
    >
    >> Is this 03 or 07? If it is 03, good rule of thumb is to add it to the Hosts
    >> file. Also, check the Central Administration and check the Name of the Portal
    >> that was created - often the mismatch (i.e. if it was created and named with
    >> the IP address) is the problem - this is the same issue if using HTTPS vs.
    >> HTTP - if the site is defined as HTTP://something then you turn on HTTPS, the
    >> site is not always found.
    >>
    >> --
    >> David M. Sterling
    >> www.sterling-consulting.com
    >>
    >>
    >> "Jerry Rasmussen" wrote:
    >>
    >>> is their more than one site hosted on this computer?
    >>>
    >>> Also what names are listed in the alternate access mappings?
    >>>
    >>>
    >>>
    >>> CK wrote:
    >>>> Yes from a command prompt pinging the IP and Pinging the machine name both
    >>>> go to the same computer. Both cases respond to the ping as well.
    >>>>
    >>>>
    >>>> "Jerry Rasmussen" <> wrote in message
    >>>> news:...
    >>>>> This looks like a name resolution issue. When going to the machine name
    >>>>> are you going to the same IP address.
    >>>>>
    >>>>> ping by name make sure IP address is correct.
    >>>>>
    >>>>>
    >>>>> CK wrote:
    >>>>>> Hi All,
    >>>>>> I have a sharepoint site on a box. I can hit the box by going to the ip
    >>>>>> address http://10.0.0.1/default.aspx but I can not hit it by name. The
    >>>>>> password dialong box comes up and it rejects my domain password. Says you
    >>>>>> are not authorized. When I use the IP the password dialong box comes up
    >>>>>> and it accepts my credentials and lets me proceed to the site. What am I
    >>>>>> missing here? Any help is greatly appreciated.
    >>>>>>
    >>>>>> TIA,
    >>>>>> ~CK
    >>>>
     
    Jerry Rasmussen, Oct 19, 2006
    #10
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Earl Teigrob
    Replies:
    7
    Views:
    470
    Scott M.
    Feb 16, 2004
  2. Replies:
    1
    Views:
    471
    Craig Deelsnyder
    Apr 12, 2006
  3. Replies:
    7
    Views:
    734
    bruce barker
    Mar 19, 2008
  4. Abraham Vionas
    Replies:
    11
    Views:
    150
    Laurent Julliard
    Nov 23, 2004
  5. Replies:
    6
    Views:
    211
Loading...

Share This Page