CDO.Message

Discussion in 'ASP General' started by Mark, Jan 29, 2009.

  1. Mark

    Mark Guest

    We send emails to our empolyees and recently, the emails have started
    to change characters into different ones. I've looked in various
    groups, hard to search on the issue.

    For example, we send:

    français

    but it shows up in our email as

    français

    other characters too, like ’ shows up as ’ and so on

    It is stored correctly in the database, and if we query and display it
    in a web browser it shows correctly. So clearly something in the mail
    reader has changed, but we need to have it display it correctly. I've
    tried (and maybe I'm doing it wrong) to add

    <META http-equiv=Content-Type content=""text/html; charset=UTF-8"">

    at the start of the email, no luck. What can we do to ensure this
    stops?

    Thanks for any help.
    Mark, Jan 29, 2009
    #1
    1. Advertising

  2. Mark

    Terje Guest

    CDO sucks big time. The encoding problems are ridiculous. And what a
    stupid object model is this crap?

    oFields.Item("http://schemas.microsoft.com/cdo/configuration/sendusing")
    = cdoSendUsingPort

    terje
    Terje, Jan 29, 2009
    #2
    1. Advertising

  3. Mark

    Neil Gould Guest

    Mark wrote:
    > We send emails to our empolyees and recently, the emails have started
    > to change characters into different ones. I've looked in various
    > groups, hard to search on the issue.
    >
    > For example, we send:
    >
    > français
    >
    > but it shows up in our email as
    >
    > français
    >
    > other characters too, like ’ shows up as ’ and so on
    >
    > It is stored correctly in the database, and if we query and display it
    > in a web browser it shows correctly. So clearly something in the mail
    > reader has changed, but we need to have it display it correctly. I've
    > tried (and maybe I'm doing it wrong) to add
    >
    > <META http-equiv=Content-Type content=""text/html; charset=UTF-8"">
    >
    > at the start of the email, no luck. What can we do to ensure this
    > stops?
    >
    > Thanks for any help.
    >

    Perhaps someone will have a better answer for you, but AFAIK, one can't
    override the client settings with ASP, and that is where such changes occur.

    Best,

    Neil
    Neil Gould, Jan 30, 2009
    #3
  4. "Mark" <> wrote in message
    news:...
    We send emails to our empolyees and recently, the emails have started
    to change characters into different ones. I've looked in various
    groups, hard to search on the issue.

    For example, we send:

    français

    but it shows up in our email as

    français

    other characters too, like ’ shows up as ’ and so on

    It is stored correctly in the database, and if we query and display it
    in a web browser it shows correctly. So clearly something in the mail
    reader has changed, but we need to have it display it correctly. I've
    tried (and maybe I'm doing it wrong) to add

    <META http-equiv=Content-Type content=""text/html; charset=UTF-8"">

    at the start of the email, no luck. What can we do to ensure this
    stops?
    <<<<<<<<<<<<<<<<<<<<<<

    Can you show us some of your code. What you are seeing is UTF-8 encoded
    characters being read by the client as if they were Windows-1252 characters.
    This usually happens because the CharSet on the message isn't specifying
    UTF-8 as the encoding.



    --
    Anthony Jones - MVP ASP/ASP.NET
    Anthony Jones, Feb 4, 2009
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Anthony Fine
    Replies:
    3
    Views:
    3,182
    Jure Spik
    Feb 12, 2004
  2. Cyndia A.
    Replies:
    0
    Views:
    630
    Cyndia A.
    Jan 14, 2004
  3. Lars-Erik Aabech

    Could not access 'CDO.Message' object

    Lars-Erik Aabech, Mar 3, 2004, in forum: ASP .Net
    Replies:
    3
    Views:
    2,784
    Henrik_the_boss
    Mar 4, 2004
  4. Guest
    Replies:
    2
    Views:
    876
    dave wanta
    Jul 11, 2003
  5. Replies:
    0
    Views:
    278
Loading...

Share This Page