Clientside validation not working.

Discussion in 'ASP .Net' started by Dennis Calla, Jan 13, 2005.

  1. Dennis Calla

    Dennis Calla Guest

    I recently moved my app to a hosted environment and the validation
    stopped working (i had it on my own webserver). I put an alert in the
    validation javascript file so I know it is being called. When a control
    fails validation the page dose not post back as expected. But when the
    control is valid the postback still is not happening. I put the alert in
    the Page_ClientValidate() function and the variable Page_IsValid is true
    when the control should be valid and false when it's invalid. Still no
    postback. I can provide more info if necessary.

    *** Sent via Developersdex http://www.developersdex.com ***
    Don't just participate in USENET...get rewarded for it!
     
    Dennis Calla, Jan 13, 2005
    #1
    1. Advertising

  2. Dennis Calla

    Peter Blum Guest

    There is a bug in the client-side scripts of ASP.NET 1.1 SP 1. Please see
    this thread:
    http://www.asp.net/Forums/ShowPost.aspx?tabindex=1&PostID=739537

    --- Peter Blum
    www.PeterBlum.com
    Email:
    Creator of "Professional Validation And More" at
    http://www.peterblum.com/vam/home.aspx

    "Dennis Calla" <> wrote in message
    news:efaC97Y%...
    >
    > I recently moved my app to a hosted environment and the validation
    > stopped working (i had it on my own webserver). I put an alert in the
    > validation javascript file so I know it is being called. When a control
    > fails validation the page dose not post back as expected. But when the
    > control is valid the postback still is not happening. I put the alert in
    > the Page_ClientValidate() function and the variable Page_IsValid is true
    > when the control should be valid and false when it's invalid. Still no
    > postback. I can provide more info if necessary.
    >
    > *** Sent via Developersdex http://www.developersdex.com ***
    > Don't just participate in USENET...get rewarded for it!
     
    Peter Blum, Jan 13, 2005
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Dave Bartlett

    outputcache - clientside caching not working?

    Dave Bartlett, May 26, 2004, in forum: ASP .Net
    Replies:
    1
    Views:
    447
    Natty Gur
    May 26, 2004
  2. Eddie Dodd

    Clientside validation not working

    Eddie Dodd, May 26, 2004, in forum: ASP .Net
    Replies:
    4
    Views:
    470
    Eddie Dodd
    May 27, 2004
  3. Paul
    Replies:
    1
    Views:
    2,093
    Scott Allen
    May 25, 2005
  4. TCook
    Replies:
    0
    Views:
    321
    TCook
    Aug 13, 2006
  5. TCook
    Replies:
    0
    Views:
    169
    TCook
    Aug 13, 2006
Loading...

Share This Page