Code review

E

Ebenezer

I'd like to request comments on the code in the archive on
this page -- http://webEbenezer.net/build_integration.html .
As you may know, I'm working on an on line code generator
that writes C++ marshalling code based on user input. I use
a three-tier architecture as follows:


C++ Middleware Writer (CMW) -- this is a server ... closed source


C++ Middleware Writer Ambassador (CMWA) -- this is a server ... open
source


"direct" program -- this program runs once and exits ... open source


The two open source tiers are in the archive mentioned above along
with supporting files. One of the files in the archive,
msg_shepherd.hh, is output from the CMW. That file is based on
another file in the archive called direct.mdl as well as some include
files.


One thing that I expect will be brought up is that the software
mixes naming conventions. I haven't picked one and been
consistent with it as is sometimes advised. I agree with that advice
for the most part, but have been lazy about following it so far.

There's a mediateResponse function in the CMWA that may
result in comments. Some knowledge of the CMW is needed ---
if the returned transaction number is zero, the value of the request
result (reqResult) will be false. I can only think of things like
sun storms that would cause this to be violated. But it wouldn't
be difficult to add code that checks if returnedTransactionNbr is
zero and reqResult is true and throws an exception.


In the "direct" program the function that connects to the
ambassador uses 127.0.0.1. That needs to be worked on.

The software in the archive has been tested on Linux and Windows.
I'd appreciate advice on improving the existing code as well as
suggestions of new functionality. There are about 3800 lines of
code in the archive. I realize people are busy and most can't
review all of it. If you would review a function or a class that
would be helpful. Thanks in advance.


Brian Wood
Ebenezer Enterprises
http://webEbenezer.net
(651) 251-9384
 
E

Ebenezer

I'd like to request comments on the code in the archive on
this page --http://webEbenezer.net/build_integration.html.
As you may know, I'm working on an on line code generator
that writes C++ marshalling code based on user input.   I use
a three-tier architecture as follows:

C++ Middleware Writer (CMW)  --  this is a server ... closed source

C++ Middleware Writer Ambassador (CMWA) -- this is a server ... open
source

"direct" program  -- this program runs once and exits ... open source

The two open source tiers are in the archive mentioned above along
with supporting files.  One of the files in the archive,
msg_shepherd.hh, is output from the CMW.  That file is based on
another file in the archive called direct.mdl as well as some include
files.

I was reviewing the code some recently and have a question about
changing my API. In msg_shepherd.hh, there's a function with this
signature:

void
Send(SendCompressedBuffer& buf, const std::vector<cmw_account_info>&
abt1);

I'm considering making the buffer parameter the last one rather
than the first one. My current approach is similar to the
interface of write. Thinking about how fwrite's interface is
different from write's interface made me wonder if I should
change the interface now before it becomes more difficult to
do so in the future. The fwrite interface seems to have a
"who, what, when, where, why, how" approach. The "how" being
via the file handle or buffer in my case. What do you suggest?
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads


Members online

Forum statistics

Threads
473,743
Messages
2,569,478
Members
44,898
Latest member
BlairH7607

Latest Threads

Top