Codepage problems with ASP.net in IIS

Discussion in 'ASP General' started by hb, Jan 17, 2006.

  1. hb

    hb Guest

    Hi,

    I have a flat html file which is in the utf-8 codepage. The file is
    created with Word.
    This code is at the beginning of the page:
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
    <html>
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
    <link href="css/stylesheet.css" rel="stylesheet" type="text/css">
    </head>

    In my web application I use the <globalization
    requestEncoding="utf-8" responseEncoding="utf-8" /> settings in the
    web.config file.

    However, when I view this html page with IE of mozilla words like
    clïent (with a double dot on the i) are shown as something like
    Cliënt. When I open the html page as a file from e.g. c:\ in both IE
    as well as mozilla the words are shown correctly.

    My conclusion is that IIS or ASP.Net causes this problem. Are there any
    other settings I have to make in the web.config, IIS or where ever?

    Any suggestions are welcome.
     
    hb, Jan 17, 2006
    #1
    1. Advertisements

  2. hb

    Paxton Guest

    hb wrote:
    > Hi,
    >
    > I have a flat html file which is in the utf-8 codepage. The file is
    > created with Word.
    > This code is at the beginning of the page:
    > <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
    > <html>
    > <head>
    > <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
    > <link href="css/stylesheet.css" rel="stylesheet" type="text/css">
    > </head>
    >
    > In my web application I use the <globalization
    > requestEncoding="utf-8" responseEncoding="utf-8" /> settings in the
    > web.config file.
    >
    > However, when I view this html page with IE of mozilla words like
    > cl?ent (with a double dot on the i) are shown as something like
    > Cliënt. When I open the html page as a file from e.g. c:\ in both IE
    > as well as mozilla the words are shown correctly.
    >
    > My conclusion is that IIS or ASP.Net causes this problem. Are there any
    > other settings I have to make in the web.config, IIS or where ever?
    >
    > Any suggestions are welcome.


    A quick google for "codepage web.config file" gave me this in the
    second result:

    pg_CodePage

    This is an optional entry which can be used to define the code page
    when the web pages are read. If this setting is left out, then a
    standard code page of 1252 is used which should be correct for Western
    character sets.

    If you wish to use a different code page, the value is integer of the
    form value="950".

    In some circumstances you may see ? characters when the pages are
    indexed. This is an indication that the code page is incorrect.

    If this doesn't solve your problem, you are probably better off asking
    in one of the dotnet groups, such as
    microsoft.public.dotnet.framework.aspnet

    /P.
     
    Paxton, Jan 17, 2006
    #2
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Matthew Louden
    Replies:
    3
    Views:
    6,319
    Sherif ElMetainy
    Nov 7, 2003
  2. JMaelstrom

    IIS 6 vs IIS 5 ASP.NET Performance Issues

    JMaelstrom, Dec 9, 2003, in forum: ASP .Net
    Replies:
    2
    Views:
    4,887
    shan420
    Apr 30, 2010
  3. =?Utf-8?B?Sm9obiBNY0d1aXJl?=

    ASP.Net Performance better with IIS 6.0 in IIS 5.0 isolation mode

    =?Utf-8?B?Sm9obiBNY0d1aXJl?=, Apr 14, 2005, in forum: ASP .Net
    Replies:
    1
    Views:
    905
    Alvin Bruney [MVP - ASP.NET]
    Apr 15, 2005
  4. Jon Davis
    Replies:
    3
    Views:
    780
    Jon Davis
    Jun 21, 2007
  5. John Kennedy
    Replies:
    5
    Views:
    503
    Carl Prothman [MVP]
    Aug 14, 2003
  6. John Kennedy
    Replies:
    5
    Views:
    647
    Carl Prothman [MVP]
    Aug 14, 2003
  7. Guennadi V. Vanine
    Replies:
    0
    Views:
    470
    Guennadi V. Vanine
    Aug 21, 2003
  8. Replies:
    9
    Views:
    315
Loading...