compiling problems on cygwin

Discussion in 'Ruby' started by Shashank Date, Feb 17, 2004.

  1. Rubyists,

    I am trying to compile ruby-1.8.1 using cygwin and I get this error during
    make:

    make[1]: Entering directory `/cygdrive/c/Documents and Settings/Shashank
    Date/cygwin/ruby-1.8.1/ext/bigdecimal'
    make[1]: *** No rule to make target `/cygdrive/c/Documents', needed by
    `bigdecimal.o'. Stop.
    make[1]: Leaving directory `/cygdrive/c/Documents and Settings/Shashank
    Date/cygwin/ruby-1.8.1/ext/bigdecimal'
    make: *** [all] Error 1

    Any suggestions?
    -- shanko
    Shashank Date, Feb 17, 2004
    #1
    1. Advertising

  2. On Wednesday, February 18, 2004, 1:39:56 AM, Shashank wrote:

    > Rubyists,


    > I am trying to compile ruby-1.8.1 using cygwin and I get this error during
    > make:


    > make[1]: Entering directory `/cygdrive/c/Documents and Settings/Shashank
    > Date/cygwin/ruby-1.8.1/ext/bigdecimal'
    > make[1]: *** No rule to make target `/cygdrive/c/Documents', needed by
    > `bigdecimal.o'. Stop.
    > make[1]: Leaving directory `/cygdrive/c/Documents and Settings/Shashank
    > Date/cygwin/ruby-1.8.1/ext/bigdecimal'
    > make: *** [all] Error 1


    > Any suggestions?
    > -- shanko



    Looks like it's the space in the path that's doing it. Eliminate that
    and try again.

    FWIW I built the latest 1.8 from CVS on Cygwin very recently, no
    problem.

    Cheers,
    Gavin
    Gavin Sinclair, Feb 17, 2004
    #2
    1. Advertising

  3. "Gavin Sinclair" <> schrieb im Newsbeitrag
    news:...
    > On Wednesday, February 18, 2004, 1:39:56 AM, Shashank wrote:
    >
    > > Rubyists,

    >
    > > I am trying to compile ruby-1.8.1 using cygwin and I get this error

    during
    > > make:

    >
    > > make[1]: Entering directory `/cygdrive/c/Documents and

    Settings/Shashank
    > > Date/cygwin/ruby-1.8.1/ext/bigdecimal'
    > > make[1]: *** No rule to make target `/cygdrive/c/Documents', needed by
    > > `bigdecimal.o'. Stop.
    > > make[1]: Leaving directory `/cygdrive/c/Documents and

    Settings/Shashank
    > > Date/cygwin/ruby-1.8.1/ext/bigdecimal'
    > > make: *** [all] Error 1

    >
    > > Any suggestions?
    > > -- shanko

    >
    >
    > Looks like it's the space in the path that's doing it. Eliminate that
    > and try again.


    IMHO rather the build system should be made space safe...

    robert
    Robert Klemme, Feb 17, 2004
    #3
  4. "Gavin Sinclair" <> wrote in message
    > Looks like it's the space in the path that's doing it. Eliminate that
    > and try again.


    But of course ! Spotted that a few minutes after posting ... sorry for the
    noise.

    -- shanko
    Shashank Date, Feb 18, 2004
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    0
    Views:
    426
  2. Replies:
    0
    Views:
    426
  3. WELCOME to

    , Sep 3, 2003, in forum: Python
    Replies:
    1
    Views:
    509
    Robin Becker
    Sep 5, 2003
  4. Replies:
    0
    Views:
    410
  5. Martin Magnusson

    Problems compiling PIL under Cygwin

    Martin Magnusson, Apr 4, 2005, in forum: Python
    Replies:
    1
    Views:
    508
    Jason Tishler
    Apr 4, 2005
Loading...

Share This Page