CompositeControl is loosing Properties when using Template

Discussion in 'ASP .Net Web Controls' started by Shimon Sim, Mar 27, 2007.

  1. Shimon Sim

    Shimon Sim Guest

    I created customer CompositeControl
    I have few properties like Title, ImageUrl and some others
    I also have two Template properties. HeaderTemplate and ContentTemplate.

    The idea is if user doesn't use Templated properties Control users Title to
    generate title and creates some default content. If user users Templates
    control users templates.

    I run into a problem that if user users a template (any) all regular
    properties are not read and are null.

    I have no clue why that could happen.
    Any ideas?
    Thanks you,
    Shimon.
    Shimon Sim, Mar 27, 2007
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Mantorok

    Adding validators to CompositeControl

    Mantorok, Jun 15, 2006, in forum: ASP .Net
    Replies:
    1
    Views:
    634
    Mantorok
    Jun 15, 2006
  2. Mantorok
    Replies:
    2
    Views:
    1,372
    Mantorok
    Jun 22, 2006
  3. Steve Richter

    problems using CompositeControl base class

    Steve Richter, Jun 2, 2007, in forum: ASP .Net
    Replies:
    0
    Views:
    325
    Steve Richter
    Jun 2, 2007
  4. Mark Norgate

    Properties loosing their values, and TagPrefix

    Mark Norgate, Sep 1, 2003, in forum: ASP .Net Web Controls
    Replies:
    0
    Views:
    134
    Mark Norgate
    Sep 1, 2003
  5. Wayne Brantley

    Properties do not reliably persist using CompositeControl

    Wayne Brantley, Dec 7, 2006, in forum: ASP .Net Web Controls
    Replies:
    2
    Views:
    114
    Walter Wang [MSFT]
    Dec 12, 2006
Loading...

Share This Page