Configuration Error

Discussion in 'ASP .Net' started by Terry Holland, Oct 6, 2005.

  1. I posted a follow up to an earlier post but did not receive response so here
    it is again (with original post and response)

    > This could be because you are running the index service over this web
    > application. try to stop indexing this application (from IIS management
    > console, clear "Index this resource") or stop the index service to test if
    > you still get error or not.


    I removed this option but still get the error. The error always seems to
    indicate that Access Denied to on of the assemblies that my project
    references. It is not always the same one.

    > Another cause for this could be because anti virus that blocks the ASP.NET
    > temporary folder.


    How would I get around this if this is the cause?

    ##########################
    Response from original post
    ##########################
    Hi Terry,

    This could be because you are running the index service over this web
    application. try to stop indexing this application (from IIS management
    console, clear "Index this resource") or stop the index service to test if
    you still get error or not.

    Another cause for this could be because anti virus that blocks the ASP.NET
    temporary folder.

    HTH
    Mohamed Sharaf
    MEA Developer Support Center
    ITWorx on behalf Microsoft EMEA GTSC
    --------------------
    | From: "Terry Holland" <>
    | Subject: Configuration Error
    | Date: Mon, 26 Sep 2005 15:56:45 +0100
    | Lines: 29
    | X-Priority: 3
    | X-MSMail-Priority: Normal
    | X-Newsreader: Microsoft Outlook Express 6.00.2800.1506
    | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1506
    | Message-ID: <>
    | Newsgroups: microsoft.public.dotnet.framework.aspnet
    | NNTP-Posting-Host: host127.multiserv.com 194.200.135.127
    | Path: TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP11.phx.gbl
    | Xref: TK2MSFTNGXA01.phx.gbl
    microsoft.public.dotnet.framework.aspnet:127057
    | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    |
    | I'm getting an intermittant error on my development machine when I run my
    | ASP.Net app. If I reboot then things are fine for a couple of times then
    | error appears again. If I use a diff development machine I do not get the
    | error.
    |
    | Any ideas?
    |
    |
    | The error message that I get is:
    |
    | Configuration Error
    | Description: An error occurred during the processing of a configuration
    file
    | required to service this request. Please review the specific error details
    | below and modify your configuration file appropriately.
    |
    | Parser Error Message: Access is denied: 'CSLA'.
    |
    | Source Error:
    |
    | Line 196: <add assembly="System.EnterpriseServices, Version=1.0.5000.0,
    | Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
    | Line 197: <add assembly="System.Web.Mobile, Version=1.0.5000.0,
    | Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
    | Line 198: <add assembly="*"/>
    | Line 199: </assemblies>
    | Line 200: </compilation>
    |
    |
    |
    |
     
    Terry Holland, Oct 6, 2005
    #1
    1. Advertising

  2. Since this is one machine, I would even consider blowing that machine away
    and doing a fresh install. Unless it is affecting multiple machines, it is
    likely to take less time to start flat than solve the issue. It would be
    useful to have a solution in the corpus of the knowledge base, but being the
    guinea pig that solves the problem is not always a lot of fun.

    Let me relate: We have one developer machine that does not register button
    clicks (ASP.NET) and cause a postback. The rest of the machines work
    correctly. Thus far, the networking guys have spent the last few days trying
    to fix the problem. In addition, there is developer downtime. The total cost
    is 8 hours * numDays *((hourlyrate1 * numPeopleAtRate) + (hourlyrateN *
    numPeopleAtRate)). Reinstall: NumHours * Rate * 1Dev. Easy to see which is
    the more prudent route?

    To the problem: Are you using Rocky Lhotka's data access framework? That is
    the only CSLA I know of right now.

    If so, the most likely issue is user authorization to the database. If this
    is SQL Server, turn on Profiler and run until you hit the error. When you do,
    you will see what credentials are being passed and be able to determine if
    that is the issue. If it is the issue, you have to find out why the
    credentials are being sent incorrectly on an intermitent basis. That is where
    I would look first.

    As to where the actual problem is? Since it is one machine, I would look at
    the .NET security setup on the machine first. But, it could be something in
    Windows permissions, which are harder to dig through.

    --
    Gregory A. Beamer
    MVP; MCP: +I, SE, SD, DBA

    ***************************
    Think Outside the Box!
    ***************************


    "Terry Holland" wrote:

    > I posted a follow up to an earlier post but did not receive response so here
    > it is again (with original post and response)
    >
    > > This could be because you are running the index service over this web
    > > application. try to stop indexing this application (from IIS management
    > > console, clear "Index this resource") or stop the index service to test if
    > > you still get error or not.

    >
    > I removed this option but still get the error. The error always seems to
    > indicate that Access Denied to on of the assemblies that my project
    > references. It is not always the same one.
    >
    > > Another cause for this could be because anti virus that blocks the ASP.NET
    > > temporary folder.

    >
    > How would I get around this if this is the cause?
    >
    > ##########################
    > Response from original post
    > ##########################
    > Hi Terry,
    >
    > This could be because you are running the index service over this web
    > application. try to stop indexing this application (from IIS management
    > console, clear "Index this resource") or stop the index service to test if
    > you still get error or not.
    >
    > Another cause for this could be because anti virus that blocks the ASP.NET
    > temporary folder.
    >
    > HTH
    > Mohamed Sharaf
    > MEA Developer Support Center
    > ITWorx on behalf Microsoft EMEA GTSC
    > --------------------
    > | From: "Terry Holland" <>
    > | Subject: Configuration Error
    > | Date: Mon, 26 Sep 2005 15:56:45 +0100
    > | Lines: 29
    > | X-Priority: 3
    > | X-MSMail-Priority: Normal
    > | X-Newsreader: Microsoft Outlook Express 6.00.2800.1506
    > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1506
    > | Message-ID: <>
    > | Newsgroups: microsoft.public.dotnet.framework.aspnet
    > | NNTP-Posting-Host: host127.multiserv.com 194.200.135.127
    > | Path: TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP11.phx.gbl
    > | Xref: TK2MSFTNGXA01.phx.gbl
    > microsoft.public.dotnet.framework.aspnet:127057
    > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > |
    > | I'm getting an intermittant error on my development machine when I run my
    > | ASP.Net app. If I reboot then things are fine for a couple of times then
    > | error appears again. If I use a diff development machine I do not get the
    > | error.
    > |
    > | Any ideas?
    > |
    > |
    > | The error message that I get is:
    > |
    > | Configuration Error
    > | Description: An error occurred during the processing of a configuration
    > file
    > | required to service this request. Please review the specific error details
    > | below and modify your configuration file appropriately.
    > |
    > | Parser Error Message: Access is denied: 'CSLA'.
    > |
    > | Source Error:
    > |
    > | Line 196: <add assembly="System.EnterpriseServices, Version=1.0.5000.0,
    > | Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
    > | Line 197: <add assembly="System.Web.Mobile, Version=1.0.5000.0,
    > | Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
    > | Line 198: <add assembly="*"/>
    > | Line 199: </assemblies>
    > | Line 200: </compilation>
    > |
    > |
    > |
    > |
    >
    >
    >
     
    =?Utf-8?B?Q293Ym95IChHcmVnb3J5IEEuIEJlYW1lcikgLSBN, Oct 6, 2005
    #2
    1. Advertising

  3. Hi Terry,

    As you mentioned that the problem go away after rebooting and reoccur after
    running hte application for some time, I think it is likely due to the
    assembly (CSLA) be locked by some other process. What's your dev machine's
    OS and IIS version? You can first try swtiching your asp.net's process
    identity to LOCAL SYSTEM to see whether the problem remain, if remain we
    can confirm that this is not a security permission problem.

    For assembly locking issue, as you said that you've tried the "indexing
    service kb article"'s suggestion and without luck, is there any anti-virus
    software running on your dev box? If so, you can also turned off them to
    see whether it helps. If still with no success, we may need to use some
    tools to checking the file accessing on your machine. You can download the
    Filemon tool from the www.sysinternals.net which can help monitor the file
    accessing on the system. We can run it to capture the actual access
    denied error occured in your asp.net runtime.

    In addition, is the "CSLA" assembly a third party one? And is it
    strong-named ? If strong-named, have you put it into the GAC or just
    deployed with other private asemblies in the application's private "bin"
    dir? For ASP.NET application, we must put strong-named assemblies into
    GAC rather than in private bin assembly. Since .net framework's shadow copy
    not apply on strong-named ones, it may cause assembly being locked also.

    Thanks,

    Steven Cheng
    Microsoft Online Support

    Get Secure! www.microsoft.com/security


    --------------------
    | Thread-Topic: Configuration Error
    | thread-index: AcXKdBHilPP3PmtaTUKoYyWNgnuSBg==
    | X-WBNR-Posting-Host: 170.141.92.1
    | From: "=?Utf-8?B?Q293Ym95IChHcmVnb3J5IEEuIEJlYW1lcikgLSBNVlA=?="
    <>
    | References: <eJ9#>
    | Subject: RE: Configuration Error
    | Date: Thu, 6 Oct 2005 05:47:11 -0700
    | Lines: 124
    | Message-ID: <>
    | MIME-Version: 1.0
    | Content-Type: text/plain;
    | charset="Utf-8"
    | Content-Transfer-Encoding: 7bit
    | X-Newsreader: Microsoft CDO for Windows 2000
    | Content-Class: urn:content-classes:message
    | Importance: normal
    | Priority: normal
    | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    | Newsgroups: microsoft.public.dotnet.framework.aspnet
    | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
    | Path: TK2MSFTNGXA01.phx.gbl!TK2MSFTNGXA03.phx.gbl
    | Xref: TK2MSFTNGXA01.phx.gbl
    microsoft.public.dotnet.framework.aspnet:129439
    | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    |
    | Since this is one machine, I would even consider blowing that machine
    away
    | and doing a fresh install. Unless it is affecting multiple machines, it
    is
    | likely to take less time to start flat than solve the issue. It would be
    | useful to have a solution in the corpus of the knowledge base, but being
    the
    | guinea pig that solves the problem is not always a lot of fun.
    |
    | Let me relate: We have one developer machine that does not register
    button
    | clicks (ASP.NET) and cause a postback. The rest of the machines work
    | correctly. Thus far, the networking guys have spent the last few days
    trying
    | to fix the problem. In addition, there is developer downtime. The total
    cost
    | is 8 hours * numDays *((hourlyrate1 * numPeopleAtRate) + (hourlyrateN *
    | numPeopleAtRate)). Reinstall: NumHours * Rate * 1Dev. Easy to see which
    is
    | the more prudent route?
    |
    | To the problem: Are you using Rocky Lhotka's data access framework? That
    is
    | the only CSLA I know of right now.
    |
    | If so, the most likely issue is user authorization to the database. If
    this
    | is SQL Server, turn on Profiler and run until you hit the error. When you
    do,
    | you will see what credentials are being passed and be able to determine
    if
    | that is the issue. If it is the issue, you have to find out why the
    | credentials are being sent incorrectly on an intermitent basis. That is
    where
    | I would look first.
    |
    | As to where the actual problem is? Since it is one machine, I would look
    at
    | the .NET security setup on the machine first. But, it could be something
    in
    | Windows permissions, which are harder to dig through.
    |
    | --
    | Gregory A. Beamer
    | MVP; MCP: +I, SE, SD, DBA
    |
    | ***************************
    | Think Outside the Box!
    | ***************************
    |
    |
    | "Terry Holland" wrote:
    |
    | > I posted a follow up to an earlier post but did not receive response so
    here
    | > it is again (with original post and response)
    | >
    | > > This could be because you are running the index service over this web
    | > > application. try to stop indexing this application (from IIS
    management
    | > > console, clear "Index this resource") or stop the index service to
    test if
    | > > you still get error or not.
    | >
    | > I removed this option but still get the error. The error always seems
    to
    | > indicate that Access Denied to on of the assemblies that my project
    | > references. It is not always the same one.
    | >
    | > > Another cause for this could be because anti virus that blocks the
    ASP.NET
    | > > temporary folder.
    | >
    | > How would I get around this if this is the cause?
    | >
    | > ##########################
    | > Response from original post
    | > ##########################
    | > Hi Terry,
    | >
    | > This could be because you are running the index service over this web
    | > application. try to stop indexing this application (from IIS management
    | > console, clear "Index this resource") or stop the index service to test
    if
    | > you still get error or not.
    | >
    | > Another cause for this could be because anti virus that blocks the
    ASP.NET
    | > temporary folder.
    | >
    | > HTH
    | > Mohamed Sharaf
    | > MEA Developer Support Center
    | > ITWorx on behalf Microsoft EMEA GTSC
    | > --------------------
    | > | From: "Terry Holland" <>
    | > | Subject: Configuration Error
    | > | Date: Mon, 26 Sep 2005 15:56:45 +0100
    | > | Lines: 29
    | > | X-Priority: 3
    | > | X-MSMail-Priority: Normal
    | > | X-Newsreader: Microsoft Outlook Express 6.00.2800.1506
    | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1506
    | > | Message-ID: <>
    | > | Newsgroups: microsoft.public.dotnet.framework.aspnet
    | > | NNTP-Posting-Host: host127.multiserv.com 194.200.135.127
    | > | Path: TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP11.phx.gbl
    | > | Xref: TK2MSFTNGXA01.phx.gbl
    | > microsoft.public.dotnet.framework.aspnet:127057
    | > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    | > |
    | > | I'm getting an intermittant error on my development machine when I
    run my
    | > | ASP.Net app. If I reboot then things are fine for a couple of times
    then
    | > | error appears again. If I use a diff development machine I do not
    get the
    | > | error.
    | > |
    | > | Any ideas?
    | > |
    | > |
    | > | The error message that I get is:
    | > |
    | > | Configuration Error
    | > | Description: An error occurred during the processing of a
    configuration
    | > file
    | > | required to service this request. Please review the specific error
    details
    | > | below and modify your configuration file appropriately.
    | > |
    | > | Parser Error Message: Access is denied: 'CSLA'.
    | > |
    | > | Source Error:
    | > |
    | > | Line 196: <add assembly="System.EnterpriseServices,
    Version=1.0.5000.0,
    | > | Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
    | > | Line 197: <add assembly="System.Web.Mobile, Version=1.0.5000.0,
    | > | Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
    | > | Line 198: <add assembly="*"/>
    | > | Line 199: </assemblies>
    | > | Line 200: </compilation>
    | > |
    | > |
    | > |
    | > |
    | >
    | >
    | >
    |
     
    Steven Cheng[MSFT], Oct 7, 2005
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. srinukasam

    configuration error

    srinukasam, Jul 7, 2005, in forum: VHDL
    Replies:
    3
    Views:
    1,374
    Eyck Jentzsch
    Jul 8, 2005
  2. Chris McKenzie

    Re: Configuration Error (<add assembly="*"/>)

    Chris McKenzie, Jun 24, 2003, in forum: ASP .Net
    Replies:
    0
    Views:
    5,106
    Chris McKenzie
    Jun 24, 2003
  3. TC
    Replies:
    1
    Views:
    1,430
    Eliyahu Goldin
    Apr 21, 2005
  4. Mark
    Replies:
    0
    Views:
    844
  5. Gilles
    Replies:
    5
    Views:
    328
    Gilles
    Aug 20, 2012
Loading...

Share This Page