Configuration error

Discussion in 'ASP .Net' started by =?Utf-8?B?Y2hva2s=?=, Oct 27, 2004.

  1. All,
    I am getting the following error when I try to run a form page. Can someone
    tell me what this is about and show me how to fix it. Thnaks.

    Server Error in '/' Application
    --------------------------------------------------------------------------------
    Configuration Error
    Description: An error occurred during the processing of a configuration file
    required to service this request. Please review the specific error details
    below and modify your configuration file appropriately.

    Parser Error Message: It is an error to use a section registered as
    allowDefinition='MachineToApplication' beyond application level. This error
    can be caused by a virtual directory not being configured as an application
    in IIS.
    Source Error:
    Line 37: by Microsoft that offers a single logon and core profile
    services for member sites.
    Line 38: -->
    Line 39: <authentication mode="Windows" />
    Line 40:
    Line 41:
    Source File: C:\Inetpub\wwwroot\StockQuote\web.config Line: 39
    --------------------------------------------------------------------------------
    Version Information: Microsoft .NET Framework Version:1.1.4322.573; ASP.NET
    Version:1.1.4322.573
    =?Utf-8?B?Y2hva2s=?=, Oct 27, 2004
    #1
    1. Advertising

  2. =?Utf-8?B?Y2hva2s=?=

    Karl Seguin Guest

    As you probably know, there are multiple places to set configuration
    variables (machine.config, web.config, sub-folder web.config, page-level,
    control-level). Each one being more and more specific - that is a
    control-level configuration (say, EnableViewState = false) overwirtes a
    page variable (EnableViewState=True). However, some configuration variables
    can't be placed at all levels. For example, MachineKey is only viable at
    the machine.config or the root web.config file.

    The error you are getting is saying that you are setting a configuration
    variable in a place it isn't allowed. Make sure that the StockQuote folder
    is set up as either a virtual directory or that you created an application
    for it in IIS. My guess is that this will solve your problem. If you are
    using web.config's in sub-folders, make sure you don't have any invalid
    configuration variables...

    Karl

    --
    MY ASP.Net tutorials
    http://www.openmymind.net/


    "chokk" <> wrote in message
    news:...
    > All,
    > I am getting the following error when I try to run a form page. Can

    someone
    > tell me what this is about and show me how to fix it. Thnaks.
    >
    > Server Error in '/' Application.
    > --------------------------------------------------------------------------

    ------
    > Configuration Error
    > Description: An error occurred during the processing of a configuration

    file
    > required to service this request. Please review the specific error details
    > below and modify your configuration file appropriately.
    >
    > Parser Error Message: It is an error to use a section registered as
    > allowDefinition='MachineToApplication' beyond application level. This

    error
    > can be caused by a virtual directory not being configured as an

    application
    > in IIS.
    > Source Error:
    > Line 37: by Microsoft that offers a single logon and core

    profile
    > services for member sites.
    > Line 38: -->
    > Line 39: <authentication mode="Windows" />
    > Line 40:
    > Line 41:
    > Source File: C:\Inetpub\wwwroot\StockQuote\web.config Line: 39
    > --------------------------------------------------------------------------

    ------
    > Version Information: Microsoft .NET Framework Version:1.1.4322.573;

    ASP.NET
    > Version:1.1.4322.573
    Karl Seguin, Oct 27, 2004
    #2
    1. Advertising

  3. Thanks for your response. I am afraid you must be more specific as to how
    to access those configuration variables. What puzzles me is I have not had
    to touch any of those variables in the past and everything worked just fine.
    As to virtual directory, VS .NET sets up everything when I create a web
    project within VS environment. I am running IIS on Win2K server and I don't
    see any config variable to set in IIS. I would appreciate further
    clarification. Thanks.

    "Karl Seguin" wrote:

    > As you probably know, there are multiple places to set configuration
    > variables (machine.config, web.config, sub-folder web.config, page-level,
    > control-level). Each one being more and more specific - that is a
    > control-level configuration (say, EnableViewState = false) overwirtes a
    > page variable (EnableViewState=True). However, some configuration variables
    > can't be placed at all levels. For example, MachineKey is only viable at
    > the machine.config or the root web.config file.
    >
    > The error you are getting is saying that you are setting a configuration
    > variable in a place it isn't allowed. Make sure that the StockQuote folder
    > is set up as either a virtual directory or that you created an application
    > for it in IIS. My guess is that this will solve your problem. If you are
    > using web.config's in sub-folders, make sure you don't have any invalid
    > configuration variables...
    >
    > Karl
    >
    > --
    > MY ASP.Net tutorials
    > http://www.openmymind.net/
    >
    >
    > "chokk" <> wrote in message
    > news:...
    > > All,
    > > I am getting the following error when I try to run a form page. Can

    > someone
    > > tell me what this is about and show me how to fix it. Thnaks.
    > >
    > > Server Error in '/' Application.
    > > --------------------------------------------------------------------------

    > ------
    > > Configuration Error
    > > Description: An error occurred during the processing of a configuration

    > file
    > > required to service this request. Please review the specific error details
    > > below and modify your configuration file appropriately.
    > >
    > > Parser Error Message: It is an error to use a section registered as
    > > allowDefinition='MachineToApplication' beyond application level. This

    > error
    > > can be caused by a virtual directory not being configured as an

    > application
    > > in IIS.
    > > Source Error:
    > > Line 37: by Microsoft that offers a single logon and core

    > profile
    > > services for member sites.
    > > Line 38: -->
    > > Line 39: <authentication mode="Windows" />
    > > Line 40:
    > > Line 41:
    > > Source File: C:\Inetpub\wwwroot\StockQuote\web.config Line: 39
    > > --------------------------------------------------------------------------

    > ------
    > > Version Information: Microsoft .NET Framework Version:1.1.4322.573;

    > ASP.NET
    > > Version:1.1.4322.573

    >
    >
    >
    =?Utf-8?B?Y2hva2s=?=, Oct 28, 2004
    #3
  4. =?Utf-8?B?Y2hva2s=?=

    Karl Seguin Guest

    Well, again, assuming you only have 1 web.config in your site and that
    C:\Inetpub\wwwroot\StockQuote\ is the root of that site

    Go to IIS, right click on StockQuote, select properties. The first tab
    (which is probably Directories) should have a section at the bottom called
    "Application Settings", with the first label underneath being "Application
    Name", a textbox right of it and a button. Hopefully the button says
    "Create", if so you simply push it and everything ought to work. if it says
    "remove", you can click it and then click it again (which will recreate it)
    but that won't be as likely to work...

    Karl

    --
    MY ASP.Net tutorials
    http://www.openmymind.net/


    "chokk" <> wrote in message
    news:...
    >
    > Thanks for your response. I am afraid you must be more specific as to how
    > to access those configuration variables. What puzzles me is I have not

    had
    > to touch any of those variables in the past and everything worked just

    fine.
    > As to virtual directory, VS .NET sets up everything when I create a web
    > project within VS environment. I am running IIS on Win2K server and I

    don't
    > see any config variable to set in IIS. I would appreciate further
    > clarification. Thanks.
    >
    > "Karl Seguin" wrote:
    >
    > > As you probably know, there are multiple places to set configuration
    > > variables (machine.config, web.config, sub-folder web.config,

    page-level,
    > > control-level). Each one being more and more specific - that is a
    > > control-level configuration (say, EnableViewState = false) overwirtes a
    > > page variable (EnableViewState=True). However, some configuration

    variables
    > > can't be placed at all levels. For example, MachineKey is only viable

    at
    > > the machine.config or the root web.config file.
    > >
    > > The error you are getting is saying that you are setting a configuration
    > > variable in a place it isn't allowed. Make sure that the StockQuote

    folder
    > > is set up as either a virtual directory or that you created an

    application
    > > for it in IIS. My guess is that this will solve your problem. If you

    are
    > > using web.config's in sub-folders, make sure you don't have any invalid
    > > configuration variables...
    > >
    > > Karl
    > >
    > > --
    > > MY ASP.Net tutorials
    > > http://www.openmymind.net/
    > >
    > >
    > > "chokk" <> wrote in message
    > > news:...
    > > > All,
    > > > I am getting the following error when I try to run a form page. Can

    > > someone
    > > > tell me what this is about and show me how to fix it. Thnaks.
    > > >
    > > > Server Error in '/' Application.

    > >

    > --------------------------------------------------------------------------
    > > ------
    > > > Configuration Error
    > > > Description: An error occurred during the processing of a

    configuration
    > > file
    > > > required to service this request. Please review the specific error

    details
    > > > below and modify your configuration file appropriately.
    > > >
    > > > Parser Error Message: It is an error to use a section registered as
    > > > allowDefinition='MachineToApplication' beyond application level. This

    > > error
    > > > can be caused by a virtual directory not being configured as an

    > > application
    > > > in IIS.
    > > > Source Error:
    > > > Line 37: by Microsoft that offers a single logon and core

    > > profile
    > > > services for member sites.
    > > > Line 38: -->
    > > > Line 39: <authentication mode="Windows" />
    > > > Line 40:
    > > > Line 41:
    > > > Source File: C:\Inetpub\wwwroot\StockQuote\web.config Line: 39

    > >

    > --------------------------------------------------------------------------
    > > ------
    > > > Version Information: Microsoft .NET Framework Version:1.1.4322.573;

    > > ASP.NET
    > > > Version:1.1.4322.573

    > >
    > >
    > >
    Karl Seguin, Oct 28, 2004
    #4
  5. Thanks a million, it worked!
    Apparently, in previous times VS.NET set it for me by default without my
    realizing it.
    Its was a big lesson for me and thanks again.

    "Karl Seguin" wrote:

    > Well, again, assuming you only have 1 web.config in your site and that
    > C:\Inetpub\wwwroot\StockQuote\ is the root of that site
    >
    > Go to IIS, right click on StockQuote, select properties. The first tab
    > (which is probably Directories) should have a section at the bottom called
    > "Application Settings", with the first label underneath being "Application
    > Name", a textbox right of it and a button. Hopefully the button says
    > "Create", if so you simply push it and everything ought to work. if it says
    > "remove", you can click it and then click it again (which will recreate it)
    > but that won't be as likely to work...
    >
    > Karl
    >
    > --
    > MY ASP.Net tutorials
    > http://www.openmymind.net/
    >
    >
    > "chokk" <> wrote in message
    > news:...
    > >
    > > Thanks for your response. I am afraid you must be more specific as to how
    > > to access those configuration variables. What puzzles me is I have not

    > had
    > > to touch any of those variables in the past and everything worked just

    > fine.
    > > As to virtual directory, VS .NET sets up everything when I create a web
    > > project within VS environment. I am running IIS on Win2K server and I

    > don't
    > > see any config variable to set in IIS. I would appreciate further
    > > clarification. Thanks.
    > >
    > > "Karl Seguin" wrote:
    > >
    > > > As you probably know, there are multiple places to set configuration
    > > > variables (machine.config, web.config, sub-folder web.config,

    > page-level,
    > > > control-level). Each one being more and more specific - that is a
    > > > control-level configuration (say, EnableViewState = false) overwirtes a
    > > > page variable (EnableViewState=True). However, some configuration

    > variables
    > > > can't be placed at all levels. For example, MachineKey is only viable

    > at
    > > > the machine.config or the root web.config file.
    > > >
    > > > The error you are getting is saying that you are setting a configuration
    > > > variable in a place it isn't allowed. Make sure that the StockQuote

    > folder
    > > > is set up as either a virtual directory or that you created an

    > application
    > > > for it in IIS. My guess is that this will solve your problem. If you

    > are
    > > > using web.config's in sub-folders, make sure you don't have any invalid
    > > > configuration variables...
    > > >
    > > > Karl
    > > >
    > > > --
    > > > MY ASP.Net tutorials
    > > > http://www.openmymind.net/
    > > >
    > > >
    > > > "chokk" <> wrote in message
    > > > news:...
    > > > > All,
    > > > > I am getting the following error when I try to run a form page. Can
    > > > someone
    > > > > tell me what this is about and show me how to fix it. Thnaks.
    > > > >
    > > > > Server Error in '/' Application.
    > > >

    > > --------------------------------------------------------------------------
    > > > ------
    > > > > Configuration Error
    > > > > Description: An error occurred during the processing of a

    > configuration
    > > > file
    > > > > required to service this request. Please review the specific error

    > details
    > > > > below and modify your configuration file appropriately.
    > > > >
    > > > > Parser Error Message: It is an error to use a section registered as
    > > > > allowDefinition='MachineToApplication' beyond application level. This
    > > > error
    > > > > can be caused by a virtual directory not being configured as an
    > > > application
    > > > > in IIS.
    > > > > Source Error:
    > > > > Line 37: by Microsoft that offers a single logon and core
    > > > profile
    > > > > services for member sites.
    > > > > Line 38: -->
    > > > > Line 39: <authentication mode="Windows" />
    > > > > Line 40:
    > > > > Line 41:
    > > > > Source File: C:\Inetpub\wwwroot\StockQuote\web.config Line: 39
    > > >

    > > --------------------------------------------------------------------------
    > > > ------
    > > > > Version Information: Microsoft .NET Framework Version:1.1.4322.573;
    > > > ASP.NET
    > > > > Version:1.1.4322.573
    > > >
    > > >
    > > >

    >
    >
    >
    =?Utf-8?B?Y2hva2s=?=, Oct 28, 2004
    #5
  6. Hello Karl.
    I've had the same problem as chokk, but I'm afraid mine is more serious.
    I've followed the steps you indicated but when I create the application and I
    try to load my aspx page, my computer simply stops responding and I have to
    reset it.
    I've checked this doesn't happen when I uninstall Microsoft .NET Framework
    (version 1.1.4322), but obviously then I can't develop anything in .net.
    Do you have any idea about this?
    Thank you.

    "Karl Seguin" wrote:

    > Well, again, assuming you only have 1 web.config in your site and that
    > C:\Inetpub\wwwroot\StockQuote\ is the root of that site
    >
    > Go to IIS, right click on StockQuote, select properties. The first tab
    > (which is probably Directories) should have a section at the bottom called
    > "Application Settings", with the first label underneath being "Application
    > Name", a textbox right of it and a button. Hopefully the button says
    > "Create", if so you simply push it and everything ought to work. if it says
    > "remove", you can click it and then click it again (which will recreate it)
    > but that won't be as likely to work...
    >
    > Karl
    >
    > --
    > MY ASP.Net tutorials
    > http://www.openmymind.net/
    >
    >
    > "chokk" <> wrote in message
    > news:...
    > >
    > > Thanks for your response. I am afraid you must be more specific as to how
    > > to access those configuration variables. What puzzles me is I have not

    > had
    > > to touch any of those variables in the past and everything worked just

    > fine.
    > > As to virtual directory, VS .NET sets up everything when I create a web
    > > project within VS environment. I am running IIS on Win2K server and I

    > don't
    > > see any config variable to set in IIS. I would appreciate further
    > > clarification. Thanks.
    > >
    > > "Karl Seguin" wrote:
    > >
    > > > As you probably know, there are multiple places to set configuration
    > > > variables (machine.config, web.config, sub-folder web.config,

    > page-level,
    > > > control-level). Each one being more and more specific - that is a
    > > > control-level configuration (say, EnableViewState = false) overwirtes a
    > > > page variable (EnableViewState=True). However, some configuration

    > variables
    > > > can't be placed at all levels. For example, MachineKey is only viable

    > at
    > > > the machine.config or the root web.config file.
    > > >
    > > > The error you are getting is saying that you are setting a configuration
    > > > variable in a place it isn't allowed. Make sure that the StockQuote

    > folder
    > > > is set up as either a virtual directory or that you created an

    > application
    > > > for it in IIS. My guess is that this will solve your problem. If you

    > are
    > > > using web.config's in sub-folders, make sure you don't have any invalid
    > > > configuration variables...
    > > >
    > > > Karl
    > > >
    > > > --
    > > > MY ASP.Net tutorials
    > > > http://www.openmymind.net/
    > > >
    > > >
    > > > "chokk" <> wrote in message
    > > > news:...
    > > > > All,
    > > > > I am getting the following error when I try to run a form page. Can
    > > > someone
    > > > > tell me what this is about and show me how to fix it. Thnaks.
    > > > >
    > > > > Server Error in '/' Application.
    > > >

    > > --------------------------------------------------------------------------
    > > > ------
    > > > > Configuration Error
    > > > > Description: An error occurred during the processing of a

    > configuration
    > > > file
    > > > > required to service this request. Please review the specific error

    > details
    > > > > below and modify your configuration file appropriately.
    > > > >
    > > > > Parser Error Message: It is an error to use a section registered as
    > > > > allowDefinition='MachineToApplication' beyond application level. This
    > > > error
    > > > > can be caused by a virtual directory not being configured as an
    > > > application
    > > > > in IIS.
    > > > > Source Error:
    > > > > Line 37: by Microsoft that offers a single logon and core
    > > > profile
    > > > > services for member sites.
    > > > > Line 38: -->
    > > > > Line 39: <authentication mode="Windows" />
    > > > > Line 40:
    > > > > Line 41:
    > > > > Source File: C:\Inetpub\wwwroot\StockQuote\web.config Line: 39
    > > >

    > > --------------------------------------------------------------------------
    > > > ------
    > > > > Version Information: Microsoft .NET Framework Version:1.1.4322.573;
    > > > ASP.NET
    > > > > Version:1.1.4322.573
    > > >
    > > >
    > > >

    >
    >
    >
    =?Utf-8?B?UHJvYmxlbSBkb2Vzbid0IHNvbHZl?=, Dec 21, 2004
    #6
  7. =?Utf-8?B?Y2hva2s=?=

    Guest

    Problem doesn't solve wrote:
    > Hello Karl.
    > I've had the same problem as chokk, but I'm afraid mine is more

    serious.
    > I've followed the steps you indicated but when I create the

    application and I
    > try to load my aspx page, my computer simply stops responding and I

    have to
    > reset it.
    > I've checked this doesn't happen when I uninstall Microsoft .NET

    Framework
    > (version 1.1.4322), but obviously then I can't develop anything in

    ..net.
    > Do you have any idea about this?
    > Thank you.
    >
    > "Karl Seguin" wrote:
    >
    > > Well, again, assuming you only have 1 web.config in your site and

    that
    > > C:\Inetpub\wwwroot\StockQuote\ is the root of that site
    > >
    > > Go to IIS, right click on StockQuote, select properties. The first

    tab
    > > (which is probably Directories) should have a section at the bottom

    called
    > > "Application Settings", with the first label underneath being

    "Application
    > > Name", a textbox right of it and a button. Hopefully the button

    says
    > > "Create", if so you simply push it and everything ought to work.

    if it says
    > > "remove", you can click it and then click it again (which will

    recreate it)
    > > but that won't be as likely to work...
    > >
    > > Karl
    > >
    > > --
    > > MY ASP.Net tutorials
    > > http://www.openmymind.net/
    > >
    > >
    > > "chokk" <> wrote in message
    > > news:...
    > > >
    > > > Thanks for your response. I am afraid you must be more specific

    as to how
    > > > to access those configuration variables. What puzzles me is I

    have not
    > > had
    > > > to touch any of those variables in the past and everything worked

    just
    > > fine.
    > > > As to virtual directory, VS .NET sets up everything when I create

    a web
    > > > project within VS environment. I am running IIS on Win2K server

    and I
    > > don't
    > > > see any config variable to set in IIS. I would appreciate

    further
    > > > clarification. Thanks.
    > > >
    > > > "Karl Seguin" wrote:
    > > >
    > > > > As you probably know, there are multiple places to set

    configuration
    > > > > variables (machine.config, web.config, sub-folder web.config,

    > > page-level,
    > > > > control-level). Each one being more and more specific - that

    is a
    > > > > control-level configuration (say, EnableViewState = false)

    overwirtes a
    > > > > page variable (EnableViewState=True). However, some

    configuration
    > > variables
    > > > > can't be placed at all levels. For example, MachineKey is only

    viable
    > > at
    > > > > the machine.config or the root web.config file.
    > > > >
    > > > > The error you are getting is saying that you are setting a

    configuration
    > > > > variable in a place it isn't allowed. Make sure that the

    StockQuote
    > > folder
    > > > > is set up as either a virtual directory or that you created an

    > > application
    > > > > for it in IIS. My guess is that this will solve your problem.

    If you
    > > are
    > > > > using web.config's in sub-folders, make sure you don't have any

    invalid
    > > > > configuration variables...
    > > > >
    > > > > Karl
    > > > >
    > > > > --
    > > > > MY ASP.Net tutorials
    > > > > http://www.openmymind.net/
    > > > >
    > > > >
    > > > > "chokk" <> wrote in message
    > > > > news:...
    > > > > > All,
    > > > > > I am getting the following error when I try to run a form

    page. Can
    > > > > someone
    > > > > > tell me what this is about and show me how to fix it.

    Thnaks.
    > > > > >
    > > > > > Server Error in '/' Application.
    > > > >
    > > >

    --------------------------------------------------------------------------
    > > > > ------
    > > > > > Configuration Error
    > > > > > Description: An error occurred during the processing of a

    > > configuration
    > > > > file
    > > > > > required to service this request. Please review the specific

    error
    > > details
    > > > > > below and modify your configuration file appropriately.
    > > > > >
    > > > > > Parser Error Message: It is an error to use a section

    registered as
    > > > > > allowDefinition='MachineToApplication' beyond application

    level. This
    > > > > error
    > > > > > can be caused by a virtual directory not being configured as

    an
    > > > > application
    > > > > > in IIS.
    > > > > > Source Error:
    > > > > > Line 37: by Microsoft that offers a single logon

    and core
    > > > > profile
    > > > > > services for member sites.
    > > > > > Line 38: -->
    > > > > > Line 39: <authentication mode="Windows" />
    > > > > > Line 40:
    > > > > > Line 41:
    > > > > > Source File: C:\Inetpub\wwwroot\StockQuote\web.config

    Line: 39
    > > > >
    > > >

    --------------------------------------------------------------------------
    > > > > ------
    > > > > > Version Information: Microsoft .NET Framework

    Version:1.1.4322.573;
    > > > > ASP.NET
    > > > > > Version:1.1.4322.573
    > > > >
    > > > >
    > > > >

    > >
    > >
    > >
    , Jan 15, 2005
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. srinukasam

    configuration error

    srinukasam, Jul 7, 2005, in forum: VHDL
    Replies:
    3
    Views:
    1,340
    Eyck Jentzsch
    Jul 8, 2005
  2. Chris McKenzie

    Re: Configuration Error (<add assembly="*"/>)

    Chris McKenzie, Jun 24, 2003, in forum: ASP .Net
    Replies:
    0
    Views:
    5,026
    Chris McKenzie
    Jun 24, 2003
  3. TC
    Replies:
    1
    Views:
    1,395
    Eliyahu Goldin
    Apr 21, 2005
  4. Mark
    Replies:
    0
    Views:
    797
  5. Gilles
    Replies:
    5
    Views:
    292
    Gilles
    Aug 20, 2012
Loading...

Share This Page