Configuring ASP.NET 2.0 Application Folders in IIS 5.0

Discussion in 'ASP .Net' started by =?Utf-8?B?SmFk?=, Jun 27, 2007.

  1. I'm working on adding a new .NET 2.0 web page to a web site that is currently
    using only classic ASP pages and is administered via IIS 5.0. The server has
    the .NET 2.0 framework installed and I am trying to deploy ASP.NET 2.0 aspx
    pages to an existing folder under the web site's home directory. However,
    after changing the properties of the folder, thus creating a web application,
    when browsing to the *.aspx file that is deployed there, I get an HTTP 404
    error (resource cannot be found).

    The ASP.NET tab in the configuration does show the web application to be
    running the .NET 2.0 framework.

    Here are some more details:

    * The pre-existing folder under the web site home directory is where I
    clicked properties and on the Directory tab I clicked the Create button to
    create the web application.
    * Before creating the web application in IIS, I copied a HelloWorld.aspx
    file out to the target directory and was able to browse to it successfully.


    Any ideas as to what I may be missing?

    I'll supply more details if necessary.

    --
    - Jad
     
    =?Utf-8?B?SmFk?=, Jun 27, 2007
    #1
    1. Advertising

  2. =?Utf-8?B?SmFk?=

    Mike Guest

    1) you cannot run an ASP app under the same folder as an .NET web app
    2) create a new folder for your asp.net web app
    3) make sure your asp.net web folder is configured to run under .NET 2.0
    framework.




    "Jad" <> wrote in message
    news:...
    > I'm working on adding a new .NET 2.0 web page to a web site that is
    > currently
    > using only classic ASP pages and is administered via IIS 5.0. The server
    > has
    > the .NET 2.0 framework installed and I am trying to deploy ASP.NET 2.0
    > aspx
    > pages to an existing folder under the web site's home directory. However,
    > after changing the properties of the folder, thus creating a web
    > application,
    > when browsing to the *.aspx file that is deployed there, I get an HTTP 404
    > error (resource cannot be found).
    >
    > The ASP.NET tab in the configuration does show the web application to be
    > running the .NET 2.0 framework.
    >
    > Here are some more details:
    >
    > * The pre-existing folder under the web site home directory is where I
    > clicked properties and on the Directory tab I clicked the Create button to
    > create the web application.
    > * Before creating the web application in IIS, I copied a HelloWorld.aspx
    > file out to the target directory and was able to browse to it
    > successfully.
    >
    >
    > Any ideas as to what I may be missing?
    >
    > I'll supply more details if necessary.
    >
    > --
    > - Jad
     
    Mike, Jun 27, 2007
    #2
    1. Advertising


  3. > * Before creating the web application in IIS, I copied a HelloWorld.aspx
    > file out to the target directory and was able to browse to it successfully.


    why change proprties of folder ?

    shouldn't be necessary.
     
    Jon Paal [MSMD], Jun 27, 2007
    #3
  4. Because I am trying to deploy an ASP.NET 2.0 web page, it will be executing
    code compiled into DLLs on the server. Therefore, we must change the
    property of the folder in IIS, creating an Application folder.
    --
    - Jad


    "Jon Paal [MSMD]" wrote:

    >
    >
    > > * Before creating the web application in IIS, I copied a HelloWorld.aspx
    > > file out to the target directory and was able to browse to it successfully.

    >
    > why change proprties of folder ?
    >
    > shouldn't be necessary.
    >
    >
    >
     
    =?Utf-8?B?SmFk?=, Jun 27, 2007
    #4
  5. I've never had to do that for anywebsite.

    ..


    "Jad" <> wrote in message news:D...
    > Because I am trying to deploy an ASP.NET 2.0 web page, it will be executing
    > code compiled into DLLs on the server. Therefore, we must change the
    > property of the folder in IIS, creating an Application folder.
    > --
    > - Jad
    >
    >
    > "Jon Paal [MSMD]" wrote:
    >
    >>
    >>
    >> > * Before creating the web application in IIS, I copied a HelloWorld.aspx
    >> > file out to the target directory and was able to browse to it successfully.

    >>
    >> why change proprties of folder ?
    >>
    >> shouldn't be necessary.
    >>
    >>
    >>
     
    Jon Paal [MSMD], Jun 27, 2007
    #5
  6. Hi Jad,

    For ASP.NET and ASP, they can work together side by side in the same IIS
    application virtual directory since they're using the different ISAPI
    extensions. And for IIS5, ASP.NET requests will be executed in a dedicated
    aspnet_wp.exe process after forwarded from IIS process while ASP requests
    are still being processed in IIS process(depend on the isolation level of
    the virtual directory). Here is a web article describe the process model
    and configuration mapping for ASP.NET application in IIS:

    #ASP.NET Internals ┬ĘC IIS and the Process Model
    http://dotnetslackers.com/articles/iis/ASPNETInternalsIISAndTheProcessModel.
    aspx

    For your problem, you got 404 error when visiting the ASP.NET page, I think
    you can check the following things:

    ** Create some other virtual directory(application) under the default SITE
    to see whether you can make ASP.NET page working in it.

    ** check the problem virtual directory's application extension
    mappings(through the home directory tab's "configuration" button), you can
    refer to the above article.

    In addition, since you mentioned that the asp.net page can work before you
    make the virtual directory an "application", you can change it back to a
    normal virtual directory and test it again. If that still work, try
    comparing the upper level(site root)'s ASP.NET extension mapping or other
    setting to see whether there is anything different.

    Sincerely,

    Steven Cheng

    Microsoft MSDN Online Support Lead


    This posting is provided "AS IS" with no warranties, and confers no rights.
     
    Steven Cheng[MSFT], Jun 28, 2007
    #6
  7. Hi Jad,

    How you doing? Have you got progress on this issue or does the sugestion in
    previous messages help you some? If there is anything else need help,
    please feel free to post here.

    Sincerely,

    Steven Cheng

    Microsoft MSDN Online Support Lead


    This posting is provided "AS IS" with no warranties, and confers no rights.
     
    Steven Cheng[MSFT], Jul 2, 2007
    #7
  8. Thanks for checking back. I am actually having to work the issue with a
    server admin. We are altogether stumped. Unfortunately, I won't know if
    we've made any progress until the admin has more time to sit down with me and
    work the issue.

    Thanks again for all of your feedback.
    --
    - Jad


    "Steven Cheng[MSFT]" wrote:

    > Hi Jad,
    >
    > How you doing? Have you got progress on this issue or does the sugestion in
    > previous messages help you some? If there is anything else need help,
    > please feel free to post here.
    >
    > Sincerely,
    >
    > Steven Cheng
    >
    > Microsoft MSDN Online Support Lead
    >
    >
    > This posting is provided "AS IS" with no warranties, and confers no rights.
    >
    >
     
    =?Utf-8?B?SmFk?=, Jul 2, 2007
    #8
  9. Hi Jad,

    Thanks for the reply and if you have any new update later or anything we
    can help, welcome to discuss here.

    Sincerely,

    Steven Cheng

    Microsoft MSDN Online Support Lead


    This posting is provided "AS IS" with no warranties, and confers no rights.
     
    Steven Cheng[MSFT], Jul 3, 2007
    #9
  10. =?Utf-8?B?SmFk?=

    RH Guest

    I just struggled with this issue and found this posting. I had already
    followed the suggested steps listed above. The solution for me was to
    enable the web extensions for both ASP and ASP.netV2.0 in inetmgr.exe.

    *** Sent via Developersdex http://www.developersdex.com ***
     
    RH, Jul 6, 2007
    #10
  11. Thank you for your input RH,

    Yes, for IIS 6, the "web service extension" is a possible cause. However,
    for IIS5, there is no web service extension setting. Anyway, there does
    exists something in IIS we need to take care for such scenario.

    Sincerely,

    Steven Cheng

    Microsoft MSDN Online Support Lead


    This posting is provided "AS IS" with no warranties, and confers no rights.
     
    Steven Cheng[MSFT], Jul 9, 2007
    #11
  12. ramlal panwar, Jul 18, 2007
    #12
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. gh0st54

    configuring application folders

    gh0st54, Mar 1, 2005, in forum: ASP .Net
    Replies:
    1
    Views:
    325
    Karl Seguin
    Mar 1, 2005
  2. VMI
    Replies:
    5
    Views:
    431
    Curt_C [MVP]
    Aug 10, 2005
  3. Jay
    Replies:
    7
    Views:
    12,296
  4. daokfella
    Replies:
    2
    Views:
    705
    Juan T. Llibre
    Apr 30, 2007
  5. jthg
    Replies:
    0
    Views:
    436
Loading...

Share This Page