Connection NULL Torque Postgresql web app

Discussion in 'Java' started by mike, Nov 7, 2003.

  1. mike

    mike Guest

    I'm receiving the following error message
    Connection object was null. This could be due to amisconfiguration of the
    DataSourceFactory.

    I had no problem building torque and my db and tables. Just running my app

    I have tried many different configurations of the torque.properties file

    here is my current:

    # -------------------------------------------------------------------
    # $Id: Torque.master,v 1.5 2002/11/28 14:06:12 mpoeschl Exp $
    #
    # This is the configuration file for Torque.
    #
    # Note that strings containing "," (comma) characters must backslash
    # escape the comma (i.e. '\,')
    #
    # -------------------------------------------------------------------

    torque.applicationRoot = .

    # -------------------------------------------------------------------
    #
    # L O G G I N G
    #
    # -------------------------------------------------------------------
    # We use Log4J for all Torque logging and we embed the log4j
    # properties within our application configuration.
    # -------------------------------------------------------------------

    # This first category is required and the category
    # must be named 'default'. This is used for all logging
    # where an explicit category is not specified.

    log4j.category.org.apache.torque = ALL, org.apache.torque
    log4j.appender.org.apache.torque = org.apache.log4j.FileAppender
    log4j.appender.org.apache.torque.file =
    ${torque.applicationRoot}/logs/torque.log
    log4j.appender.org.apache.torque.layout = org.apache.log4j.PatternLayout
    log4j.appender.org.apache.torque.layout.conversionPattern = %d [%t] %-5p
    %c - %m%n
    log4j.appender.org.apache.torque.append = false

    # -------------------------------------------------------------------
    #
    # T O R Q U E P R O P E R T I E S
    #
    # -------------------------------------------------------------------
    # These are your database settings. Look in the
    # org.apache.torque.pool.* packages for more information.
    #
    # The parameters to connect to the default database. You MUST
    # configure these properly.
    # -------------------------------------------------------------------
    torque.database.default.adapter=postgresql
    torque.dsfactory.default.factory=org.apache.torque.dsfactory.TorqueDataSourc
    eFactory

    torque.dsfactory.default.pool.defaultMaxConnections=10
    torque.dsfactory.default.pool.maxExpiryTime=3600
    torque.dsfactory.default.pool.connectionWaitTimeout=10

    torque.dsfactory.default.connection.driver = org.postgresql.Driver
    torque.dsfactory.default.connection.url
    =jdbc:postgresql://localhost:5432/eqi
    que.dsfactory.default.connection.user = postgres
    torque.dsfactory.default.connection.password =

    Please let me know if you see anything wrong or have any advice.
    Thanks in advance

    Mike
     
    mike, Nov 7, 2003
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. marcelino

    torque- connection error

    marcelino, Mar 1, 2004, in forum: Java
    Replies:
    0
    Views:
    512
    marcelino
    Mar 1, 2004
  2. Mark

    Wrenching Torque

    Mark, May 7, 2004, in forum: Java
    Replies:
    0
    Views:
    537
  3. Replies:
    5
    Views:
    27,011
    Mike Schilling
    Mar 29, 2006
  4. Ben
    Replies:
    2
    Views:
    254
  5. Anasuya Devi

    Need gudance in using apache Torque

    Anasuya Devi, Sep 19, 2013, in forum: Java
    Replies:
    2
    Views:
    220
Loading...

Share This Page