Connection timeout (connection closing after 100 sec )

Discussion in 'ASP .Net Web Services' started by shmuel witman, Dec 4, 2005.

  1. Hi,



    Although I setting the Connection timeout of IIS 6.0 to 600 sec

    I am still seeing the connection closing after 100 sec (via perfmon -
    Current Connections of Web service).



    The Enable HTTP Keep-Alives in the IIS is on.

    And the client sends the HTTP header Connection: Keep-Alive.



    Thanks

    Shmuel
    shmuel witman, Dec 4, 2005
    #1
    1. Advertising

  2. shmuel witman

    Peter Kelcey Guest

    Shmuel

    There are a number of things that can affect timeouts on your web
    service calls. Here's an overview

    1) There is also a config setting in your machine.config that controls
    the timeout for requests. The <httpRuntime> tag has an attribute called
    executionTimeout that has a default of 90 seconds. It will affect the
    timeout when you are not running underdebug mode.

    2) In you web service you can user the Server.ScriptTimeout to set the
    request timeout in terms of seconds

    3) Finally (and probably most important to your scenario) the .NET
    client proxy has a property called "Timeout". Have you set a value for
    this property in your code? I think the default is 100 seconds. This
    probably what is causing your timeout.

    Hope that helps

    Peter Kelcey
    Peter Kelcey, Dec 5, 2005
    #2
    1. Advertising

  3. Hi Peter,

    In my question I asked about the connection that opens in the web server.

    This connection should stay open until the end of the connection time or
    renew on any new request



    I think that your answer was about timeout of the request - response





    You can this counter in prfmon app



    Performance object: Web service

    Counter: Current connections

    (Current Connections is the current number of connections established with
    the Web service)



    Thanks

    Shmuel


    "Peter Kelcey" <> wrote in message
    news:...
    > Shmuel
    >
    > There are a number of things that can affect timeouts on your web
    > service calls. Here's an overview
    >
    > 1) There is also a config setting in your machine.config that controls
    > the timeout for requests. The <httpRuntime> tag has an attribute called
    > executionTimeout that has a default of 90 seconds. It will affect the
    > timeout when you are not running underdebug mode.
    >
    > 2) In you web service you can user the Server.ScriptTimeout to set the
    > request timeout in terms of seconds
    >
    > 3) Finally (and probably most important to your scenario) the .NET
    > client proxy has a property called "Timeout". Have you set a value for
    > this property in your code? I think the default is 100 seconds. This
    > probably what is causing your timeout.
    >
    > Hope that helps
    >
    > Peter Kelcey
    >
    shmuel witman, Dec 6, 2005
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Andreas Klemt
    Replies:
    2
    Views:
    402
    Marina
    Jul 28, 2003
  2. =?Utf-8?B?bWZlaW5nb2xk?=
    Replies:
    7
    Views:
    806
    =?Utf-8?B?bWZlaW5nb2xk?=
    Nov 8, 2004
  3. Mark Probert

    Timeout::timeout and Socket timeout

    Mark Probert, Oct 6, 2004, in forum: Ruby
    Replies:
    1
    Views:
    1,263
    Brian Candler
    Oct 6, 2004
  4. fred
    Replies:
    3
    Views:
    256
    Zifud
    Mar 17, 2005
  5. Replies:
    5
    Views:
    861
Loading...

Share This Page